Page does not print correctly (data loss)

VERIFIED FIXED in mozilla1.0

Status

()

Core
Printing: Output
P1
critical
VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: roberts, Assigned: karnaze (gone))

Tracking

({dataloss})

Trunk
mozilla1.0
x86
All
dataloss
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: verify all DUPs after this bug is fixed., URL)

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

17 years ago
This page prints correctly with Netscape 4.78.. With Mozilla 0.9.8 mostly blank
pages print.

--Doug

Comment 1

17 years ago
reporter: in the future, please try to pick the obvious component for your 
problems instead of selecting browser general.
Assignee: asa → rods
Component: Browser-General → Printing
QA Contact: doronr → sujay

Comment 2

17 years ago
confirming on windows....every other page printed is blank..

Amar, can you find a reduced test case?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

17 years ago
My guess is that this is table layout issue. Everyother page isn't blank. The
first is blank, but that is probably because the table doesn't fit on a page.
The second page has a little text and then the third page has  most of the content.
Assignee: rods → karnaze
(Assignee)

Updated

17 years ago
Severity: normal → critical
Status: NEW → ASSIGNED
Keywords: dataloss, nsbeta1+
Priority: -- → P1
Target Milestone: --- → mozilla1.0

Comment 4

17 years ago
Created attachment 70552 [details]
testcase attached



 I my attached reduced testcase even if I remove a <br> tag it makes lot of
difference in print previewing and printing. I think the the first page is
blank because it could not fit the page with the mapquest image.

Comment 5

17 years ago
Created attachment 70561 [details]
more simplified testcase

The table in the testcase have a defined height="400". I think that this is
equivalent to two logical pages and its trying to print the content on two
pages instead of one. I am attaching a much simplified testcase.
(Assignee)

Comment 6

16 years ago
The test cases no longer have dataloss (may be due to fixing bug 120364). But 
they skip a page, because the containing block of a floated image erronously 
will not split, so the table moves to the next page to accomodate it. 

The url has dataloss, so we need a test case. 
Keywords: qawanted
(Assignee)

Comment 7

16 years ago
Created attachment 73972 [details]
reduced test case with data loss
(Assignee)

Updated

16 years ago
Attachment #70552 - Attachment is obsolete: true
(Assignee)

Updated

16 years ago
Attachment #70561 - Attachment is obsolete: true
(Assignee)

Comment 8

16 years ago
I filed bug 130939 to deal with the page breaking problem. This bug handles the 
data loss issues.
Keywords: qawanted
Summary: Page does not print correctly → Page does not print correctly (data loss)
(Assignee)

Comment 9

16 years ago
Created attachment 74153 [details] [diff] [review]
patch to fix the bug
(Assignee)

Updated

16 years ago
Whiteboard: PATCH

Comment 10

16 years ago
Comment on attachment 74153 [details] [diff] [review]
patch to fix the bug

sr=attinasi
Attachment #74153 - Flags: superreview+

Comment 11

16 years ago
Comment on attachment 74153 [details] [diff] [review]
patch to fix the bug

r= alexsavulov
Attachment #74153 - Flags: review+
(Assignee)

Updated

16 years ago
OS: Linux → All

Comment 12

16 years ago
Comment on attachment 74153 [details] [diff] [review]
patch to fix the bug

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #74153 - Flags: approval+
(Assignee)

Comment 13

16 years ago
The patch is in.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 14

16 years ago
ok now we get only the first page blank...rest of the pages 
print fine...

changing summary and REOPEN..
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: Page does not print correctly (data loss) → only first page not printed out; rest print out fine.

Comment 15

16 years ago
*** Bug 131979 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Whiteboard: PATCH → verify all DUPs after this bug is fixed.
(Assignee)

Comment 16

16 years ago
Changing summary back and marking closed again, because I don't see any data 
loss. In comment #8 I mentioned filing bug 130939 to deal with page breaking due 
to blocks. The url also has floaters which cause the print preview to look bad, 
but there is already a bug on that. So, unless there is data loss on the url, 
please leave this nsbeta1+ bug closed. 
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED
Summary: only first page not printed out; rest print out fine. → Page does not print correctly (data loss)

Comment 17

16 years ago
verified.
Status: RESOLVED → VERIFIED

Comment 18

16 years ago
I see exactly the same bug again in the same
page as well as at the following URL:
http://www.geocaching.com/seek/cache_details.asp?ID=10701
Using Mozilla 2003020408 on Win2k...
You need to log in before you can comment on or make changes to this bug.