Check for new messages every XX minutes not working when using Kerberos/GSSAPI authentication / "No password"

UNCONFIRMED
Unassigned

Status

Thunderbird
Security
UNCONFIRMED
2 years ago
2 months ago

People

(Reporter: nohaj, Unassigned)

Tracking

38 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20160309073831

Steps to reproduce:

User agent : Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.7.0

Hello,

I'm running Thunderbird 38.7.0 on CentOS 7.2. I have a POP3 account connected to a Dovecot MDA server. 

Connection settings : SSL/TLS, Kerberos/GSSAPI, port 995, no password

Everything works fine except the "Check for new messages every 10 minutes" which is not working at all.

When i launch Thunderbird, the setting "Check for new messages at startup" is working and when i click on "retrieve emails" it's working as well.

I have this issue on 30 computers with the same configurations and the same accounts settings.

Regards,

Johan



Actual results:

Nothing.


Expected results:

Auto retrieve new messages every XX minutes
(Reporter)

Updated

2 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Comment 1

2 years ago
Hi, what does "no password" mean?

Can you attach a screenshot of the Account settings panel where the checking interval is set?

Also after the 10 minutes interval passes and no emails are downloaded, see in tools->error console if there are any errors/warnings.
(Reporter)

Comment 2

2 years ago
Hello,

You will find enclosed the screenshot of the Account settings and the screenshot of the error console.

I have some errors in the console when i launch Thunderbird but not errors after that.

"No password" mean that i don't provide a password to login, i thought it could be relevant.
(Reporter)

Comment 3

2 years ago
Created attachment 8739021 [details]
Account-settings
(Reporter)

Comment 4

2 years ago
Created attachment 8739022 [details]
error-console

Comment 5

2 years ago
Why is the option 'check for new messages at startup' locked (greyed out)? Are you in a company that has locked those settings? So "no password" seems to mean Kerberos/GSSAPI.

The error console does not look good. Do you also have problems with sending out messages?

Do you use any addons in TB that could cause this? Best would be to try TB Safe mode (help->restart with addons disabled).
(Reporter)

Comment 6

2 years ago
Why is the option 'check for new messages at startup' locked (greyed out)? Are you in a company that has locked those settings? So "no password" seems to mean Kerberos/GSSAPI.

-> Yes, i use a thunderbird.cfg to lock some settings and i authenticate myself through Kerberos/GSSAPI.

The error console does not look good. Do you also have problems with sending out messages?

-> No problems. Everything is working fine except this option.

Do you use any addons in TB that could cause this? Best would be to try TB Safe mode (help->restart with addons disabled).

-> I don't use any addons. I have the same problem in Safe Mode.
(Reporter)

Comment 7

2 years ago
When i use "Normal password" in "Authentication method", the new messages are checked at the define interval !! 

So the problem is coming from the Kerberos/GSSAPI authentication. 

Moreover, if I switch from normal password to Kerberos/GSSAPI in an open thunderbird, the option is still working after that. If I close thunderbird and open it again, it's once again not working.

To summarize :

- Open a thunderbird with Kerberos/GSSAPI authentication -> "check new messages" is not working
- Switch to normal password authentication -> "check new messages" is working
- Switch again to Kerberos/GSSAPI authentication -> "check new messages" is still working
- Close thunderbird and open it again -> "check new messages" is not working anymore

Comment 8

2 years ago
nohaj, did you get this solved?
Component: Preferences → Security
Flags: needinfo?(nohaj.23)
(Reporter)

Comment 9

2 years ago
Hello,

Sadly no =(

Comment 10

2 years ago
Doe sthis happen if you test in a new profile I have this issue on 30 computers with the same configurations and the same accounts settings.

Comment 11

2 months ago
nohaj writes "I'm not working for this client anymore, so i can't tell you if it's solved or not with some system update." about whether the problem exists using current version.

But, turns out we have other reports of this - bug 1155614 and bug 1383635*.  Note, bug 525238 has some interesting blockers and dendencies.

* perhaps more can be gotten by modifying query https://mzl.la/2KZQKrE - https://mzl.la/2GWAoh8 is one attempt
Flags: needinfo?(nohaj.23)
Summary: Check for new messages every XX minutes not working → Check for new messages every XX minutes not working when using Kerberos/GSSAPI authentication / "No password"
You need to log in before you can comment on or make changes to this bug.