Closed Bug 1261401 Opened 5 years ago Closed 5 years ago

Update sv-SE translation for chatzilla

Categories

(SeaMonkey :: General, defect)

SeaMonkey 2.40 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1244467

People

(Reporter: az, Unassigned)

Details

Attachments

(1 file)

Attached file irc extension
All strings are translated for chatzilla, but released versions of SeaMonkey contains a not fully translated version of chatzilla.
@Reporter:
a) We are talking about Swedish localized builds from 
   <http://www.seamonkey-project.org/releases/>?
b) Language Pack also affected?
I don't know. Where does Chatzilla put their translations?
(In reply to Philip Chee from comment #2)
> I don't know. Where does Chatzilla put their translations?
NI: stefanh
Flags: needinfo?(stefanh)
There's http://mxr.mozilla.org/l10n-central/source/sv-SE/extensions/irc/chrome/. But what happens if you run a version of cz that is different from the one that ships with SeaMonkey?
Flags: needinfo?(stefanh)
Building your own lang pack for Swedish works fine for Chatzilla. It's the version who is included in SeaMonkey thats needs to be updated http://www.seamonkey-project.org/releases/
When I run Chatzilla in SeaMonkey 2.40, the Chatzilla menus and labels are in English. For example, the main menubar in the cz window have the following menus: Chatzilla, IRC, Edit, View, Verktyg, Fönster, Help. I think that "Verktyg" and "Fönster" are overlayed from SeaMonkey, so they're from the suite translation (I'm a bit puzzled that the Help menu label is in English, though). My guess is that we don't get the sv-SE package which then would be bug 1244467.

az@kth.se, are the files that you attached the same as the files in http://mxr.mozilla.org/l10n-central/source/sv-SE/extensions/irc/chrome/?
Flags: needinfo?(az)
I used the URL https://hg.mozilla.org/releases/l10n/mozilla-aurora/sv-SE/.
Flags: needinfo?(az)
Yeah, sorry - I was looking at trunk. But that should be the place for aurora, so that's right. So I think the translation is fine, but we don't include the language pack. Assuming you also get the en-US version of Chatzilla (I could have messed up long time ago and installed a different cz version) - would you say that you get no sv-SE translation at all (except for the standard menus "Verktyg" and "Fönster")?
Actually, by reading bug 1244467 it's kind of obvious that the langpack wasn't included in 2.40 and I don't see any langpacks on aurora either.

I'm duping this against bug 1244467 (you'll get cc:ed automatically so you can follow the progress there).
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1244467
You need to log in before you can comment on or make changes to this bug.