about:blank frames should inherit controlling service worker from parent

RESOLVED DUPLICATE of bug 1293277

Status

()

defect
P2
normal
RESOLVED DUPLICATE of bug 1293277
3 years ago
a year ago

People

(Reporter: bkelly, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: btpp-fixlater)

See:

  https://github.com/whatwg/html/pull/322#issuecomment-204278675

Spec says:

  "When the request’s url is local, if the service worker client’s responsible browsing context is a nested browsing context or the service worker client is a worker client, the service worker client inherits the service worker registration from its parent browsing context’s environment or one of the worker’s Documents' environment, respectively, if it exists."
Whiteboard: btpp-fixlater
Note, this is a compat issue affecting people in the wild.  See the chromium ticket for some examples:

https://bugs.chromium.org/p/chromium/issues/detail?id=439697
Priority: -- → P2
(Reporter)

Updated

2 years ago
Duplicate of this bug: 1350850
(Reporter)

Updated

a year ago
No longer blocks: ServiceWorkers-compat
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1293277
You need to log in before you can comment on or make changes to this bug.