64-bit version 45.0.1 limits my Internet connection speed

RESOLVED WORKSFORME

Status

()

Core
Networking
RESOLVED WORKSFORME
2 years ago
a year ago

People

(Reporter: Anthony, Unassigned)

Tracking

({64bit, perf})

45 Branch
x86_64
Windows 7
64bit, perf
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160303134406

Steps to reproduce:

Noticed my download speed while running speed test was limited. Went through all of the troubleshooting steps to isolate the problem. Fired up a second computer and the speed test ran normally. Came back to original computer with 64-bit version 45.0.1 and tested again. Same problem. Started version 45.0.1 32-bit on the original machine and speed test function normally. reinstalled version 45.0.0 64-bit. Both computers are running windows 7 professional with 8 GB of memory, and multicore processors.


Actual results:

Everything works normal. No problems with downloading speed test using the older version of Firefox.
On 100 Mb service, it was limited to 35 to 50 Mb download speed with normal upload speed of 3 Mb.using the newest version 45.0 .164 bit.


Expected results:

64-bit version 45.0.1 should allow full speed.

Updated

2 years ago
Component: Untriaged → Untriaged
Keywords: 64bit, perf
Product: Firefox → Core

Comment 1

2 years ago
Could you provide the URL of the speed test? Is it in Flash or standard HTML?

Did you test with a fresh profile with FF45 64b?
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(peaceful1003)
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
Summary: Ver 45.0.1 limits my Internet connection speed → 64-bit version 45.0.1 limits my Internet connection speed
(Reporter)

Comment 2

2 years ago
Results were obtained using both:  http://www.speedtest.net/ and  http://my.verizon.com/services/speedtest/
I believe speed test.net uses flash but I'm not certain about Verizon.
I did not create a new profile, or even think about it because I had never needed to do that before. And also my profile worked fine with the previous version of Firefox when I reinstalled it. I went through that scenario several times. Using speed test.net I tried four different servers,with the same result.
Using speedtest.net I would get an error,from the Phoenix location, indicating an inability to complete the ping test, and the speed test would terminate. I don't remember the exact verbiage, but it came up in a red box.
Absolutely no problem when using the 32-bit version from the same computer or a different machine.
I am using FF 45.0.0 64-bit now with no problems. Same profile.
If you would like me to do further testing, just lay out the steps for me.
Flags: needinfo?(peaceful1003)
(Reporter)

Comment 3

2 years ago
I also did use the REFRESH Firefox feature while troubleshooting the issue.
Component: Untriaged → Download Manager
Product: Core → Toolkit
> If you would like me to do further testing, just lay out the steps for me.

see bug comment 1
Flags: needinfo?(peaceful1003)

Updated

a year ago
Component: Downloads API → Networking
Product: Toolkit → Core
(Reporter)

Comment 5

a year ago
Delete this Bug report as the issue is moot after installing Firefox latter versions.

Updated

a year ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(peaceful1003)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.