Closed Bug 1261549 Opened 6 years ago Closed 6 years ago

Gaia does not build due to manifest error

Categories

(Firefox OS Graveyard :: Gaia::Build, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: nhirata, Assigned: aus)

References

Details

(Whiteboard: fixed-in-kanikani)

Attachments

(1 file, 2 obsolete files)

Attached file gaia_build_log.txt
1. git clone -b kanikani http://git.mozilla.org/releases/gaia.git
2. adb root
3. make reset-gaia
Expected: builds and flashes gaia on phone
Actual: 
[svoperapps.js] PROFILE_DIR, GAIA_DISTRIBUTION_DIR, VARIANT_PATH are all required
Exception: Error: We got 1 manifest error while building:
 * External webapp `mochitest` has an invalid origin: http://mochi.test:8888

gaia: fb780bf99eb056d59271843ad37c44660b1cb7ab

Note: full gaia build log attached.
Note: make production will work; it looks like this is due to an engineering app.
I think it's the mochitest app.  Can we get rid of it?

https://github.com/mozilla-b2g/gaia/commit/fdd52c63dc66baf3751410909c3ab236a7e23f0d
Well, we still hope to run tests...
Attached file PR for removing mochitest webapp (obsolete) —
Removing mochitest as a engineering app.  Are we using mochitest?  If so, then we'll have to fix the mochi.test location.  Not sure yet what caused the regression.
Last working gaia build was : 555db55f8be289136545301832edc6a3210fb1e1
Aus, both : aa48dd870b640b704c54ac64f66ecf41478ca683 and fb780bf99eb056d59271843ad37c44660b1cb7ab causes build failure.  Can you take a look, please?
Flags: needinfo?(aus)
Attachment #8737449 - Attachment is obsolete: true
Attachment #8737447 - Attachment is obsolete: true
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #5)
> Last working gaia build was : 555db55f8be289136545301832edc6a3210fb1e1
> Aus, both : aa48dd870b640b704c54ac64f66ecf41478ca683 and
> fb780bf99eb056d59271843ad37c44660b1cb7ab causes build failure.  Can you take
> a look, please?

I have a fix ready for this and another issue I noticed pop-up over the weekend. PR is currently testing and should land shortly.
Flags: needinfo?(aus)
Assignee: nobody → aus
Status: NEW → ASSIGNED
Commit (kanikani): https://github.com/mozilla-b2g/gaia/commit/5f1e3d4ab5a0faf639c55b764edbaaa4d474e45f

Fixed, other issues remain as noted but the issue reported here is resolved.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: fixed-in-kanikani
Blocks: 1252482
You need to log in before you can comment on or make changes to this bug.