Intermittent TEST-UNEXPECTED-FAIL | testUnifiedTelemetryClientId | Retrieving reset from JS has timed out -

RESOLVED DUPLICATE of bug 1261494

Status

()

Firefox for Android
Metrics
RESOLVED DUPLICATE of bug 1261494
2 years ago
a year ago

People

(Reporter: aryx, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

https://treeherder.mozilla.org/logviewer.html#?job_id=25031259&repo=mozilla-inbound

18:20:14     INFO -  TEST-PASS | testUnifiedTelemetryClientId | Given message occurred for registered event: {"innerType":"async-call","type":"Robocop:JS","args":[false,""],"method":"blockingFromJsResponseString"} - Robocop:JS should equal Robocop:JS
18:20:14     INFO -  TEST-PASS | testUnifiedTelemetryClientId | Given message occurred for registered event: {"innerType":"sync-reply","type":"Robocop:JS","args":[],"method":"pollGetAsyncReset"} - Robocop:JS should equal Robocop:JS
18:20:14  WARNING -  TEST-UNEXPECTED-FAIL | testUnifiedTelemetryClientId | Retrieving reset from JS has timed out -
18:20:14     INFO -  0 ERROR Exception caught during test! - junit.framework.AssertionFailedError: TEST-UNEXPECTED-FAIL | testUnifiedTelemetryClientId | Retrieving reset from JS has timed out -
18:20:14     INFO -  	at junit.framework.Assert.fail(Assert.java:50)
18:20:14     INFO -  	at org.mozilla.gecko.FennecMochitestAssert._logMochitestResult(FennecMochitestAssert.java:128)
18:20:14     INFO -  	at org.mozilla.gecko.FennecMochitestAssert.ok(FennecMochitestAssert.java:150)
18:20:14     INFO -  	at org.mozilla.gecko.tests.helpers.AssertionHelper.fFail(AssertionHelper.java:110)
18:20:14     INFO -  	at org.mozilla.gecko.tests.JavascriptBridgeTest.getBlockingFromJsString(JavascriptBridgeTest.java:89)
18:20:14     INFO -  	at org.mozilla.gecko.tests.testUnifiedTelemetryClientId.resetJSCache(testUnifiedTelemetryClientId.java:197)
18:20:14     INFO -  	at org.mozilla.gecko.tests.testUnifiedTelemetryClientId.testUnifiedTelemetryClientId(testUnifiedTelemetryClientId.java:56)
18:20:14     INFO -  	at java.lang.reflect.Method.invokeNative(Native Method)
18:20:14     INFO -  	at java.lang.reflect.Method.invoke(Method.java:525)
18:20:14     INFO -  	at android.test.InstrumentationTestCase.runMethod(InstrumentationTestCase.java:214)
18:20:14     INFO -  	at android.test.InstrumentationTestCase.runTest(InstrumentationTestCase.java:199)
18:20:14     INFO -  	at android.test.ActivityInstrumentationTestCase2.runTest(ActivityInstrumentationTestCase2.java:192)
18:20:14     INFO -  	at org.mozilla.gecko.tests.BaseRobocopTest.runTest(BaseRobocopTest.java:189)
18:20:14     INFO -  	at junit.framework.TestCase.runBare(TestCase.java:134)
18:20:14     INFO -  	at junit.framework.TestResult$1.protect(TestResult.java:115)
18:20:14     INFO -  	at junit.framework.TestResult.runProtected(TestResult.java:133)
18:20:14     INFO -  	at junit.framework.TestResult.run(TestResult.java:118)
18:20:14     INFO -  	at junit.framework.TestCase.run(TestCase.java:124)
18:20:14     INFO -  	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:191)
18:20:14     INFO -  	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:176)
18:20:14     INFO -  	at android.test.InstrumentationTestRunner.onStart(InstrumentationTestRunner.java:554)
18:20:14     INFO -  	at org.mozilla.gecko.FennecInstrumentationTestRunner.onStart(FennecInstrumentationTestRunner.java:64)
18:20:14     INFO -  	at android.app.Instrumentation$InstrumentationThread.run(Instrumentation.java:1701)
18:20:14  WARNING -  TEST-UNEXPECTED-FAIL | testUnifiedTelemetryClientId | Exception caught - junit.framework.AssertionFailedError: TEST-UNEXPECTED-FAIL | testUnifiedTelemetryClientId | Retrieving reset from JS has timed out -
18:20:14     INFO -  EventExpecter: no longer listening for Robocop:JS
18:20:14     INFO -  TEST-OK | testUnifiedTelemetryClientId | took 218918ms
See Also: → bug 1261494

Comment 1

2 years ago
5 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 4
* fx-team: 1

Platform breakdown:
* android-4-3-armv7-api15: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1261596&startday=2016-04-04&endday=2016-04-10&tree=all

Comment 2

2 years ago
10 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 8
* mozilla-central: 1
* fx-team: 1

Platform breakdown:
* android-4-3-armv7-api15: 10

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1261596&startday=2016-05-30&endday=2016-06-05&tree=all

Comment 3

a year ago
10 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 9
* mozilla-central: 1

Platform breakdown:
* android-4-3-armv7-api15: 10

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1261596&startday=2016-06-06&endday=2016-06-12&tree=all

Comment 4

a year ago
5 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 3
* mozilla-central: 2

Platform breakdown:
* android-4-3-armv7-api15: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1261596&startday=2016-06-13&endday=2016-06-19&tree=all

Comment 5

a year ago
10 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 8
* mozilla-aurora: 1
* fx-team: 1

Platform breakdown:
* android-4-3-armv7-api15: 10

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1261596&startday=2016-06-20&endday=2016-06-26&tree=all

Comment 6

a year ago
18 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 8
* fx-team: 4
* mozilla-central: 3
* autoland: 3

Platform breakdown:
* android-4-3-armv7-api15: 18

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1261596&startday=2016-06-30&endday=2016-06-30&tree=all

Comment 7

a year ago
15 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 7
* autoland: 6
* mozilla-central: 1
* fx-team: 1

Platform breakdown:
* android-4-3-armv7-api15: 14
* windows8-64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1261596&startday=2016-07-01&endday=2016-07-01&tree=all

Comment 8

a year ago
50 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 23
* autoland: 15
* fx-team: 8
* mozilla-central: 4

Platform breakdown:
* android-4-3-armv7-api15: 49
* windows8-64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1261596&startday=2016-06-27&endday=2016-07-03&tree=all
Michael, can you tell whats going on here?
Could this be fallout from bug 1233986?
Flags: needinfo?(michael.l.comella)
I've previously done some work to try to fix this in bug 1261494, which may also be related to the increase in errors seen here. But I'll also check out bug 1233986.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(michael.l.comella)
Resolution: --- → DUPLICATE
Duplicate of bug: 1261494
33 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 16
* autoland: 8
* try: 7
* mozilla-central: 1
* mozilla-aurora: 1

Platform breakdown:
* android-4-3-armv7-api15: 33

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1261596&startday=2016-07-04&endday=2016-07-10&tree=all
6 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 3
* autoland: 2
* fx-team: 1

Platform breakdown:
* android-4-3-armv7-api15: 6

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1261596&startday=2016-08-01&endday=2016-08-07&tree=all
6 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 3
* autoland: 2
* mozilla-central: 1

Platform breakdown:
* android-4-3-armv7-api15: 6

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1261596&startday=2016-08-08&endday=2016-08-14&tree=all
You need to log in before you can comment on or make changes to this bug.