Intermittent OX X 10.10 debug mda Output exceeded X, remaining output has been truncated (output was Y bytes) | command timed out: 7200 seconds elapsed running

RESOLVED WORKSFORME

Status

()

Core
WebRTC
P4
normal
Rank:
35
RESOLVED WORKSFORME
2 years ago
5 months ago

People

(Reporter: aryx, Unassigned)

Tracking

({intermittent-failure})

Trunk
Unspecified
Mac OS X
intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox48 affected)

Details

https://treeherder.mozilla.org/logviewer.html#?job_id=25033152&repo=mozilla-inbound

18:54:00     INFO -  [2051] WARNING: MediaPipeline Transport failed. This is not properly cleaned up yet: file /builds/slave/m-in-m64-d-0000000000000000000/build/src/media/webrtc/signaling/src/mediapipeline/MediaPipeline.cpp, line 371
18:54:00     INFO -  795643904[1142b88c0]: [|WebrtcAudioSessionConduit] AudioConduit.cpp:651: GetAudioFrame Engine not Receiving
18:54:00     INFO -  1963311872[1005852d0]: [main|PeerConnectionImpl] PeerConnectionImpl.cpp:2718: CloseInt: Closing PeerConnectionImpl e7bc84df88929097; ending call
18:54:00     INFO -  1963311872[1005852d0]: [1459562038831587 (id=18 url=http://mochi.test:8888/tests/dom/media/tests/mochitest/test_dataChannel_basicAudioVideo.html)]: stable -> closed
18:54:00     INFO -  1963311872[1005852d0]: [main|PeerConnectionImpl] PeerConnectionImpl.cpp:2725: CloseInt: Destroying DataChannelConnection 0x1124c8850 for e7bc84df88929097
18:54:00     INFO -  MEMORY STAT | vsize 3400MB | residentFast 413MB | heapAllocated 147MB
18:54:00     INFO -  795643904[1142b88c0]: [|WebrtcAudioSessionConduit] AudioConduit.cpp:651: GetAudioFrame Engine not Receiving
18:54:00     INFO -  1878 INFO TEST-OK | dom/media/tests/mochitest/test_dataChannel_basicAudioVideo.html | took 2405ms
18:54:00     INFO -  [2051] WARNING: Audio Buffer is not full by the end of the callback.: 'Available() == 0 || mSampleWriteOffset == 0', file /builds/slave/m-in-m64-d-0000000000000000000/build/src/dom/media/AudioBufferUtils.h, line 87
18:54:00     INFO -  [2051] WARNING: MediaEngineDefaultAudioSource data underrun: '!data || data->IsEnded() || aDesiredTime <= aSource->GetEndOfAppendedData(aId)', file /builds/slave/m-in-m64-d-0000000000000000000/build/src/dom/media/webrtc/MediaEngineDefault.h, line 137
If this happens with any regularity,  we'll need to verify it's not just looping, and consider reducing logging.
Rank: 35
Priority: -- → P3
Mass change P3->P4 to align with new Mozilla triage process.
Priority: P3 → P4

Updated

5 months ago
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.