Closed Bug 1261689 Opened 3 years ago Closed 3 years ago

JavaScript error: resource:///modules/activity/pop3Download.js, line 93: TypeError: this._mostRecentActivityForFolder[aFolder.URI] is undefined

Categories

(Thunderbird :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 53.0

People

(Reporter: aceman, Assigned: aceman)

Details

Attachments

(1 file)

JavaScript error: resource:///modules/activity/pop3Download.js, line 93: TypeError: this._mostRecentActivityForFolder[aFolder.URI] is undefined

Can be seen e.g. in http://archive.mozilla.org/pub/thunderbird/tinderbox-builds/comm-central-win32/1459469082/comm-central_xp-ix_test-mozmill-bm111-tests1-windows-build0.txt.gz

I can also reproduce it locally by having an account defined with server that does not exist. TB tries to connect to it, but does not finish and does not ask for a password (correctly, the server didn't ask for it).
When I toggle to offline mode, then the error appears in the Error console.

The log from the connection is like this:
-147413248[f7155240]: POP3: [this=d880aff0] LoadUrl()
-147413248[f7155240]: POP3: [this=d880aff0] Initialize()
-147413248[f7155240]: POP3: [this=d880aff0] Connecting to server pop.sfr.fr:110
-147413248[f7155240]: POP3: [this=d880aff0] Setting server busy in nsPop3Protocol::LoadUrl()
-147413248[f7155240]: POP3: [this=d880aff0] Abort
-147413248[f7155240]: POP3 sink: [this=ddc751a0] Calling ReleaseFolderLock from AbortMailDelivery
-147413248[f7155240]: POP3 sink: [this=ddc751a0] ReleaseFolderLock haveSemaphore = FALSE
-147413248[f7155240]: POP3: [this=d880aff0] Clearing running protocol in nsPop3Protocol::Abort()
-147413248[f7155240]: POP3: [this=d880aff0] Entering NET_ProcessPop3 0
-147413248[f7155240]: POP3: [this=d880aff0] Entering state: 24
-147413248[f7155240]: POP3: [this=d880aff0] Entering state: 25
-147413248[f7155240]: POP3: [this=d880aff0] Clearing server busy in POP3_FREE
-147413248[f7155240]: POP3: [this=d880aff0] Clearing running protocol in POP3_FREE
-147413248[f7155240]: POP3: [this=d880aff0] ~nsPop3Protocol()
-147413248[f7155240]: POP3 sink: [this=ddc751a0] Calling ReleaseFolderLock from ~nsPop3Sink
-147413248[f7155240]: POP3 sink: [this=ddc751a0] ReleaseFolderLock haveSemaphore = FALSE

The bug is that we get a onDownloadCompleted notification even after this unsuccessful connection and when we never got a onDownloadStarted notification.

The question is whether we should paper over it in pop3Download.js::onDownloadCompleted(). Or if we should fix the backend (if it is broken).

When the server does exist and asks for the password and I do not provide it (click Cancel on the password prompt), the connection is closed and this wrong notification is NOT sent, so all is fine. (Actually except that the "Connected to server X" is still shown on the status bar, maybe exactly because there was no notification?).
Attached patch patchSplinter Review
I still get this error when the connection to server fails.
Attachment #8812614 - Flags: review?(mkmelin+mozilla)
Comment on attachment 8812614 [details] [diff] [review]
patch

Review of attachment 8812614 [details] [diff] [review]:
-----------------------------------------------------------------

I suppose this should be fine. r=mkmelin
Attachment #8812614 - Flags: review?(mkmelin+mozilla) → review+
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/5b50177b250c806d55d1d5108de5f9da6058b395
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 53.0
You need to log in before you can comment on or make changes to this bug.