RESOLVED DUPLICATE of bug 1261741

Status

()

RESOLVED DUPLICATE of bug 1261741
2 years ago
2 years ago

People

(Reporter: sicking, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

When doing two-finger scrolling on http://panamapapers.sueddeutsche.de/en/ using the touchpad of a macbook the scrolling behaves very strange.

It feels like the page is updating the scroll position at arbitrary times making it very hard to predict how far to move my fingers in order to get to where I want on the page.

This does not happen in Chrome.

I'm not sure if this is due to buggy logic in the page, or if the logic in the page simply interacts poorly with our APZ logic.

Steps to reproduce. Alt A:
1. Load http://panamapapers.sueddeutsche.de/en/
2. Use two fingers on the touchpad to try to "fling" the page about halfway down.
   I.e. try to give it enough momentum that the viewport ends up halfway down
   the total length of the page.

Actual results:
As the page scrolls down, its scrolling speed is very inconsistent and it almost seems to stutter/jerk as it scrolls down.

Expected results:
That the page scrolls with a consistent but slowing speed until it comes to a stop.

Steps to reproduce. Alt B:
1. Load http://panamapapers.sueddeutsche.de/en/
2. Use two fingers on the touchpad to slowly scroll the page down at a constant
   speed.

Actual results:
As the page scrolls down, makes occasional jumps with very different scroll speed.

Expected results:
That the page scrolls with a consistent, roughly proportional to the speed my fingers are moving.
I'm not able to reproduce this (OS X nightly, non-retina). There also don't appear to be an wheel listeners on the page, so it shouldn't be caused by the page.

Do you have a retina display? Also, can you set nglayout.debug.paint_flashing to true and see if the entire page is getting repainted as you scroll? That might be one cause.

Branch checks would be nice as well - does this affect beta/aurora/nightly/all?
Flags: needinfo?(jonas)
Actually it looks like Markus filed the same issue shortly before you did.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(jonas)
Resolution: --- → DUPLICATE
Duplicate of bug: 1261741
You need to log in before you can comment on or make changes to this bug.