Encoding is broken when opening mails in draft with Lightning plugin enabled

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: sacredfox, Unassigned)

Tracking

38 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160315153207

Steps to reproduce:

1. Install Lightning plugin 4.0.5.2
2. Write mail using Japanese, and save to draft.
3. Restart Thunderbird
4. Open the saved mail


Actual results:

Mails are displayed with wrong encoding.

I'm using Thunderbird 38.7.0 in Windows 10 with Japanese locale.
I tried both ISO-2022-JP and Unicode in step 2. above, both of them are broken.
I guess it's treat as some ASCII-based encoding such as windows-1252.
This issue did not occur when I uninstall Lightning plugin.



Expected results:

Draft mail is shown in proper encoding.

Comment 1

3 years ago
Do you see the same problem with version 45?
Flags: needinfo?(sacredfox)
Whiteboard: [closeme 2016-06-10]
(Reporter)

Comment 2

3 years ago
I tried again with Thunderbird 45.1.0 + Lightning 4.7.1 , and could not reproduce the same problem.
If no one claim this issue occur, please close this bug.
Thanks.
Flags: needinfo?(sacredfox)

Comment 3

2 years ago
Resolved per whiteboard and Comment 2
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2016-06-10]
You need to log in before you can comment on or make changes to this bug.