Closed Bug 1261843 Opened 7 years ago Closed 7 years ago

Two conversation can be opened while the new Sharing panel is shown

Categories

(Hello (Loop) :: Client, defect, P1)

defect

Tracking

(firefox45 unaffected, firefox46+ fixed, firefox47 fixed, firefox48 fixed)

RESOLVED FIXED
Iteration:
48.3 - Apr 25
Tracking Status
firefox45 --- unaffected
firefox46 + fixed
firefox47 --- fixed
firefox48 --- fixed

People

(Reporter: bogdan_maris, Assigned: Mardak)

References

Details

(Whiteboard: [btpp-fix-now])

Attachments

(3 files)

[Affected versions]:
- Firefox 46 beta 7 
- latest Developer Edition 47.0a2
- latest Nightly 48.0a1

[Affected platforms]:
- Windows 7 64-bit
- Windows XP 32-bit
- Mac OS X 10.10.5
- Ubuntu 14.04 64-bit

[Steps to reproduce]:
1. Start Firefox
2. Make sure you have another conversation in Hello panel
3. Click 'Browse this page with a friend'
4. Before Share panel shows up click the conversation that's displayed in Hello panel
- If two conversation did not open at the same time an additional step is required:
5. Click Hello Panel.

[Expected result]:
- While the transition to Share panel, user can't access other conversations

[Actual result]:
- Two conversation are opened. After step 5 the Share panel is displayed over Disconnect button and also after closing one conversation (does not matter which one) Disconnect button will not show up anymore in Hello Panel.

[Regression range]:
- This is not a regression, it reproduces since Share panel was introduced.

[Additional notes]:
- Screencast attached showing the issue.
- Firefox 45.0.1 is not affected since it does not have this panel.
[Tracking Requested - why for this release]:
Easily reproducible issue affecting the Hello user experience on Fx46.
Rank: 12
Priority: -- → P1
Whiteboard: [btpp-fix-now]
Bumping this up a bit, as I think we should fix it reasonably soon, as the effects with the share panel not opening straight away are quite apparent.
Rank: 12 → 6
Comment on attachment 8738159 [details] [review]
[loop] Mardak:bug-1261843-double > mozilla:master

Test incoming to set state and check the class is set.
Attachment #8738159 - Flags: review?(dmose)
Attachment #8738159 - Flags: review?(dcritchley)
Attachment #8738159 - Flags: review?(crafuse)
Attached video v1 video
Showing that the list gets disabled on create room.
Assignee: nobody → edilee
Status: NEW → ASSIGNED
Comment on attachment 8738159 [details] [review]
[loop] Mardak:bug-1261843-double > mozilla:master

Looks good
Attachment #8738159 - Flags: review?(dmose)
Attachment #8738159 - Flags: review?(dcritchley)
Attachment #8738159 - Flags: review?(crafuse)
Attachment #8738159 - Flags: review+
Blocks: 1262522
https://github.com/mozilla/loop/commit/9741a608303cefbe49f3611bb5a4752bba632b6d
Status: ASSIGNED → RESOLVED
Iteration: --- → 48.3 - Apr 18
Closed: 7 years ago
Resolution: --- → FIXED
Oops. Thanks for pasting the commit and resolving.
You need to log in before you can comment on or make changes to this bug.