Firefox sync sign-in fails

RESOLVED DUPLICATE of bug 1261753

Status

()

Firefox
Sync
RESOLVED DUPLICATE of bug 1261753
2 years ago
2 years ago

People

(Reporter: Greta, Unassigned)

Tracking

45 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160315153207

Steps to reproduce:

Using Fedora Linux.  Using latest Firefox from Mozilla site (45.0.1).

1.  Go to Edit menu.
2.  Select Preferences.
3.  Select Sync.
4.  Attempt to log in.


Actual results:

After doing the above steps, a message appears:  A different user was previously signed in to Sync on this computer. Signing in will merge this browser’s bookmarks, passwords and other settings with <the very same account name>.  When I select "continue", I get "Unexpected error".

So, I can't sign in.  I tried creating another account, but when I tried to sign in with that account, I got the same message and the same error.

Since I cannot sign in, I cannot delete these accounts, and cannot use sync at all.

Other things I tried:  starting Firefox in safe mode; "refreshing" Firefox, trying to sign in from a phone onto which I recently installed Firefox.  Every time, I got the message about merging and then the error message.




Expected results:

I should be able to sign in.  I should be able to delete accounts, change passwords, and use sync.
(Reporter)

Comment 1

2 years ago
I tried one more thing:  I totally eliminated my Firefox profile by moving them out of the way (<some random characters>.default and profiles.ini).  Then I started Firefox with a clean profile.  At that point, my original Sync account seems to have disappeared.  I was then able to manage new profiles, and added the one I wanted to have.

I signed in and got sync working.  Then I signed out from sync.

When I then moved my original Firefox profile back to its location, I was still able to manage my newly-created account and sync to my phone.

Updated

2 years ago
Component: Untriaged → Sync
Thanks for the report!  We had a partial service outage with Firefox Accounts that was producing these "unexpected error" messages.  It sounds like youhit the very tail end of it, and we got things working again in production by the time you tried the steps in Comment 1.  I'm going to close this resolved, but please feel free to re-open if you're still having issues getting connected.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED

Updated

2 years ago
Resolution: FIXED → DUPLICATE
Duplicate of bug: 1261753
You need to log in before you can comment on or make changes to this bug.