Show community support link on localized product landing pages

ASSIGNED
Assigned to

Status

ASSIGNED
3 years ago
6 months ago

People

(Reporter: kohei, Assigned: MikkCZ)

Tracking

({jp-critical, regression})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 3 obsolete attachments)

(Reporter)

Description

3 years ago
Currently it's pretty difficult for Japanese Firefox/Thunderbird users to find the localized forum because there's no link to the "Get community support" page on each product. I thought it was there before; maybe regressed from Bug 1068720? Please enable the link for the Japanese (ja) locale in all products. We do have a localized page at https://support.mozilla.org/ja/kb/get-community-support that offers links to the localized forum as well as our enterprise support page. Thanks!
I see the link '質問する' leading to https://support.mozilla.org/ja/kb/get-community-support in the top menu (very left). Or should it be somewhere else too?

Btw. as for the article l10n, I see there a button linking to https://support.mozilla.org/en-US/questions/new - maybe you want to point it to your local forum too.
(Reporter)

Comment 2

3 years ago
The English equivalent https://support.mozilla.org/en-US/products/firefox has a prominent "Get community support" link in the Help Topics section. It's missing on localized pages including ja.
Right, in the tiles, I understand now.
Created attachment 8737920 [details] [diff] [review]
bug-1261896.patch

This would fix it, but I am not sure if it should be enabled globally for all locales and products, or it can be set from admin too without any code changes.
Now it depends on
> questions_enabled(request.LANGUAGE_CODE)
so shows for locales with SUMO support forum enabled only.
Created attachment 8738701 [details] [review]
GitHub PR
Assignee: nobody → mstanke
Status: NEW → ASSIGNED
Comment on attachment 8737920 [details] [diff] [review]
bug-1261896.patch

>From 93cbdd09b8bda9e3630988c3611804cb27803c1a Mon Sep 17 00:00:00 2001
>From: Michal Stanke <mstanke@mozilla.cz>
>Date: Mon, 4 Apr 2016 22:21:38 +0200
>Subject: [PATCH] [Bug 1261896] Show community support link for all products
> and locales
>
>---
> kitsune/products/jinja2/products/includes/topic_macros.html | 2 --
> 1 file changed, 2 deletions(-)
>
>diff --git a/kitsune/products/jinja2/products/includes/topic_macros.html b/kitsune/products/jinja2/products/includes/topic_macros.html
>index a8f1db2..8026055 100644
>--- a/kitsune/products/jinja2/products/includes/topic_macros.html
>+++ b/kitsune/products/jinja2/products/includes/topic_macros.html
>@@ -9,14 +9,12 @@
>       </a>
>     </li>
>     {% if loop.last %}
>-      {% if show_community_support %}
>         <li class="community-support">
>           <a href="{{ url('wiki.document', 'get-community-support') }}" class="cf">
>             <img src="{{ STATIC_URL }}sumo/img/blank.png" class="topic-icon" alt="" />
>             <span class="title">{{ _('Get community support') }}</span>
>           </a>
>         </li>
>-      {% endif %}
>       </ul>
>     {% endif %}
>   {% endfor %}
>-- 
>1.9.1
>
Attachment #8737920 - Attachment is obsolete: true
I think this should only be shown for locales that have a translated version of get get-community-support page. I think we need to figure out what we want here before moving forward.

Vesper: What do you think about this?
Flags: needinfo?(mdziewonski)
A link to the article is in the menu instead of AAQ if the SUMO support forum is not opened for the locale, so I do not see a reason why to hide it here. (check https://support.mozilla.org/de/)

But it's true it does not check if the article is translated AFAIK.

Comment 10

3 years ago
I'm CCing Madalina and Rachel since this is directly connected to community support.

Madalina, Rachel: please take a look and decide where links to the forums should appear.
Flags: needinfo?(mdziewonski)
Madalina, Rachel, what are your opinions?
Flags: needinfo?(rmcguigan)
Flags: needinfo?(mana)
(Reporter)

Comment 12

3 years ago
This is not Japanese-specific issue.
Summary: Enable community support link for Japanese → Show community support link on localized product landing pages
I agree it should be more obvious. If the english version appears in the AAQ I think the detected locale link should be there too. Thinking like a user I would see it and think "Oh, there is a forum in my language, I prefer that"
Flags: needinfo?(rmcguigan)
So beside adding the "Get community help" tile at the end of product list also to add a link to the redirect info shown e.g. here https://support.mozilla.org/de/questions/new ?
Flags: needinfo?(rmcguigan)

Comment 15

3 years ago
Makes sense to me to have the "Get community support" page added in the tiles. However we should only have it enabled for those locales who already have that page localized.
Flags: needinfo?(mana)
Well, we do not have such check in the top menu (partially I guess because there is no possible fallback), but I hope I can implement it for the tiles.
I have updated the PR to show the link for locales with AAQ enabled (the same behavior as now) or get-community-support article localized (requested behavior).

Waiting to know from Rachel, if the link should be added to the en-US fallback info, too.
All good, all in on my side. I agree with Madalina to only show it if its localized.  Sorry for the delay here.
Flags: needinfo?(rmcguigan)
Flags: needinfo?(mstanke)
The patch has been already in the review process, but we are cautious to change the code and waiting for the platform decision, so we won't spend too much time with potentially never used changes. Thank you everyone for your patience. If Kitsune is chosen as SUMO platform for the future, this definitely needs to be fixed ASAP.
Flags: needinfo?(mstanke)
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Duplicate of this bug: 1339759

Comment 23

6 months ago
Nearing completion?
Status: REOPENED → ASSIGNED
Flags: needinfo?(mstanke)
Hi Wayne.

The patches are in the same state as in May 2016 - waiting for review until the codebase is unfreezed for new feature.

Giorgos, is there any ETA when the changed for Amazon migration are all done and there will be time to review also feature related patches?
Flags: needinfo?(mstanke) → needinfo?(giorgos)
(In reply to Michal Stanke (Mozilla.cz) [:MikkCZ][:mstanke] (use needinfo) from comment #24)
> Giorgos, is there any ETA when the changed for Amazon migration are all done
> and there will be time to review also feature related patches?

AWS migration is done. We now accept pull requests for features and fixes and will review the open ones as time allows.
Flags: needinfo?(giorgos)
You need to log in before you can comment on or make changes to this bug.