Document all API methods, including request/response types

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: dustin, Assigned: dustin)

Tracking

Details

A bunch of the AWS manager's API methods have no request/response types in the documentation.  They should all be fully documented.
Assignee: nobody → dustin
Assignee: dustin → nobody
Assignee: nobody → dustin
Duplicate of this bug: 1261913
Duplicate of this bug: 1261912
It turns out that most of the endpoints without any schema are actually slated for deletion in bug 1261912 and bug 1261913.  So let's lump all of that together.
oh, ergh, awsState() and state(<workerType>) are both returning whole JSON blobs.  I don't think that's a good idea, and as part of bug 1198391 I'll change how state(<workerType>) works.  So for now, I'll assume that's going away, and not document it.  So this comes down to removing some methods.
So we have:
 - awsState/state -- getting rewritten in bug 1198391
 - launch-specifications -- requested to remain, has output schema, decent documentation
 - backend-status -- requested to remain, needs docs in bug 1261912
 - api-reference -- can go away
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.