Status

defect
RESOLVED DUPLICATE of bug 1261911
3 years ago
3 months ago

People

(Reporter: dustin, Unassigned, Mentored)

Tracking

Details

(Whiteboard: [good-first-bug])

All services now publish their references to references.taskcluster.net, so it's no longer necessary to keep this API method around.
One disadvantage of references being on references.taskcluster.net is that they are not easily discoverable - i.e. you have to know under which url they are published (references.taskcluster.net isn't searchable or browsable).

Maybe there is a naming convention that makes this easy, but a nice feature of having an endpoint is that you get some level of self-describing APIs. I wonder if we could arrange that the top-level endpoint (e.g. https://queue.taskcluster.net/v1/) would return the API definitions.

If apiReference() already implements something which returns the API definitions, maybe we shouldn't get rid of it, but just make it available at the baseURL location.

Please note, we may have discussed this elsewhere, and decided against it for some reason, my memory is unfortunately frazzled.

Thanks!
If we want to change the way that kind of stuff works (and we might, as part of Kristel's work), we can do so for all services at once.  Leaving it in for this one service is not great.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1251911
Duplicate of bug: 1261911
(In reply to Dustin J. Mitchell [:dustin] from comment #2)
> If we want to change the way that kind of stuff works (and we might, as part
> of Kristel's work), we can do so for all services at once.  Leaving it in
> for this one service is not great.

Ah, apologies, I thought this was a taskcluster-base or other taskcluster lib thing.
Component: AWS-Provisioner → Services
Product: Taskcluster → Taskcluster
You need to log in before you can comment on or make changes to this bug.