Better inclusion of bookmarks in awesomebar search results

RESOLVED FIXED

Status

()

Firefox for iOS
Data Storage
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: rnewman, Assigned: fluffyemily)

Tracking

unspecified
All
iOS

Firefox Tracking Flags

(fxios-v5.0 fixed, fxios6.0+)

Details

(Whiteboard: [target 5.0])

Attachments

(1 attachment)

48 bytes, text/x-github-pull-request
sleroux
: review+
Details | Review | Splinter Review
(Reporter)

Description

2 years ago
The first stab at this landed in Bug 1185038.

This adds 0-5 matching bookmarks at the front of the matching history results.

This is missing a few things:

* You can get duplicate bookmarks if they're present multiple times in the DB (e.g., in your Toolbar and in Menu, or bookmarked locally and remotely).
* You can get duplicates between bookmarks and history -- e.g., visit Reddit, bookmark it, search for "reddit", and you'll see two rows.
* History items aren't marked with the star, even if they're not present in the list at the top.

See Bug 1185038 for discussion of these limitations and possibilities for improving them.
(Reporter)

Comment 1

2 years ago
Nomming for prioritization.
tracking-fxios: --- → ?
tracking-fxios: ? → 4.0+

Updated

2 years ago
Duplicate of this bug: 1263658
tracking-fxios: 4.0+ → 5.0+
Whiteboard: [nicetohave]
(Assignee)

Updated

2 years ago
tracking-fxios: 5.0+ → 6.0+
Rank: 3
(Assignee)

Updated

2 years ago
Assignee: nobody → etoop
Status: NEW → ASSIGNED
(Assignee)

Comment 3

2 years ago
Created attachment 8759647 [details] [review]
Pull request

:rnewman - I added you in case you were interested, if you're too busy don't worry.
Attachment #8759647 - Flags: review?(sleroux)
Attachment #8759647 - Flags: review?(rnewman)
Comment on attachment 8759647 [details] [review]
Pull request

I _think_ this looks pretty good. Just left a question about the alias. The feature works pretty well on my bookmarks and from what I can tell from the SQL changes to UNION -> UNION ALL and the added JOIN it looks good but my SQL-foo isn't the greatest so I'll defer to Richard if he has any additional comments.
Attachment #8759647 - Flags: review?(sleroux) → review+
(Assignee)

Comment 5

2 years ago
merged behind feature flag https://github.com/mozilla/firefox-ios/commit/72d82db92109676d1b41fd62db32387348be3ef4
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Whiteboard: [nicetohave] → [target 5.0][needsuplift]
v5.x 05006be3a52ad7c2cc4a8ba929f0e942591845f2
status-fxios-v5.0: --- → fixed
Whiteboard: [target 5.0][needsuplift] → [target 5.0]
(Assignee)

Updated

2 years ago
Attachment #8759647 - Flags: review?(rnewman)
You need to log in before you can comment on or make changes to this bug.