segfault on start -funroll-loops

RESOLVED WONTFIX

Status

()

Core
XPCOM
--
critical
RESOLVED WONTFIX
16 years ago
16 years ago

People

(Reporter: Ervin Németh, Assigned: dougt)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Mozilla makes a segfault on startup.  The 2002-02-15 4:00 (GMT) build was ok,
but the 2002-02-18 4:00 (and after) build makes a segfault.  TestXPTCInvoke is
still working.

gcc-3.0.3 CFLAGS="-O3 -march=i686 -ffast-math -funroll-loops
-maccumulate-outgoing-args" LDFLAGS="-Wl,-O1,-z,combreloc"

Deleting ~/.mozilla doesn't help, either.

No trace available (yet), it is a non-debug build.
(Assignee)

Comment 1

16 years ago
try rebuilding with default options.  see http://www.mozilla.org/build/unix.html
for details.
(Reporter)

Comment 2

16 years ago
I am reporting a successfull build using CFLAGS="-O2 -march=i686"

I was there as "-fomit-frame-pointer" started to cause a wrong build, now I am
here as something breaks an other flag.  As I have time I will research which
flag is unusable this time.

Now some philosophical fuming.  My Mozilla build is now 144 Megabytes, mainly of
C and C++ code.  Then somebody comes and does some assembly wizardry which makes
a single object-file a little bit faster, but at the same time prevents the
other 143M of code from being optimized making the program slower.  Call me a
freak but I still believe that code optimization is cheaper than buying a faster
processor.

Should we close this bug when I've figured out the compiler-flag or does
somebody agree with me?
(Assignee)

Comment 3

16 years ago
I agree with you in theory.  although, I do not totally grok the need for it.  

I think that there are bugs with this -fomit-frame-pointer discussion.  Find
those discussions and lets close out this bug.
(Reporter)

Comment 4

16 years ago
Finally I've got it.  It is the "-funroll-loops" flag.  With gcc-3.0.4, too.

I'm really sad because this flag could give a good performance boost.

Doug, should we mark this bug WONTFIX or LATER?  :)
(Assignee)

Comment 5

16 years ago
post a message to the builds newsgroup regarding this.  Maybe someone would know
how or want to try to fix this.  As for the bug, afaiac, WONTFIX.  
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX

Comment 6

16 years ago
fwiw later should not be used. and if you intend to get some help with this bug please find out precisely which file is causing the problem

--enable-optimize="-O1 -g", crash, get a stack trace, figure out which file doesn't work with  -funroll-loops, reuild that file without the flag, rinse and repeat until mozilla runs, then provide the list here (or try to isolate the affected functions). when you get stuck, as for help.
Severity: blocker → critical
Keywords: crash
Summary: segfault on start → segfault on start -funroll-loops

Comment 7

16 years ago
'-O2 -march=i686 -funroll-loops' works ok with the gcc version included in
redhat 7.2
(Reporter)

Comment 8

16 years ago
gcc-3.1 seems not to be affected either.  Try out the new MMX and SSE
optimization, too.
You need to log in before you can comment on or make changes to this bug.