If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

The application will crash when opening/exiting split screen feature

VERIFIED FIXED

Status

()

Firefox for iOS
General
VERIFIED FIXED
2 years ago
a year ago

People

(Reporter: SimonB, Assigned: fluffyemily)

Tracking

unspecified
Other
iOS

Firefox Tracking Flags

(fxios5.0+, fxios-v3.0 affected, fxios-v4.0 affected, fxios-v5.0 verified)

Details

Attachments

(1 attachment)

48 bytes, text/x-github-pull-request
bnicholson
: review+
Details | Review | Splinter Review
(Reporter)

Description

2 years ago
Build: 3.0 (9), 4.0.(1)
Device: IPad Air 2 (iOS 9.2)

Steps to reproduce:
1. Launch Youtube application on IPad Air 2
2. Slide the screen left to open split screen feature and access wikipedia.org
3. Swipe left and right two times to enter and exit split screen mode
4. Press home button to minimize all aplications 
5. Again open Youtube app 
6. Swipe left to enter split screen mode
7. Open a new tab and access facebook.com
8. Swipe left and right to enter and exit split screen mode
9. Repeat step 8) several times and observe that the application will crash

Actual results:
- The application will crash

Please see a video of the issue at the following URL: https://www.youtube.com/watch?v=p8C25BZPuAw
Severity: critical → normal
Rank: 5
tracking-fxios: ? → +
Whiteboard: [5.0]
tracking-fxios: + → 5.0+
Whiteboard: [5.0]
(Assignee)

Comment 1

2 years ago
Created attachment 8741320 [details] [review]
Pull request

The problem was caused by a pointer to an expired version of self in applicationDidEnterBackground during the execution of background tasks. Added [unowned self] to ensure self hung around long enough to execute those tasks
Attachment #8741320 - Flags: review?(bnicholson)
(Assignee)

Updated

2 years ago
Assignee: nobody → etoop
Status: NEW → ASSIGNED
Comment on attachment 8741320 [details] [review]
Pull request

Don't think the explanation or commit message here are accurate, so I'm not sure how this fix works. If you verified that this does fix the crash, though, (meaning the issue is somehow related to a retain cycle?) I'll happily r+ as-is with an updated message!
Attachment #8741320 - Flags: review?(bnicholson) → feedback+
(Assignee)

Comment 3

a year ago
:bnicholson

When I returned to this I got a far more useful crash location and feel that this is a better fix.
(Assignee)

Updated

a year ago
Attachment #8741320 - Flags: review?(bnicholson)
Comment on attachment 8741320 [details] [review]
Pull request

LGTM!
Attachment #8741320 - Flags: review?(bnicholson)
Attachment #8741320 - Flags: review+
Attachment #8741320 - Flags: feedback+
(Assignee)

Updated

a year ago
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
(Assignee)

Updated

a year ago
Duplicate of this bug: 1265846
(Reporter)

Comment 6

a year ago
Tested on build 0977e5b5

The issue is not reproducible following the above steps to reproduce.
Status: RESOLVED → VERIFIED
status-fxios-v5.0: --- → verified
You need to log in before you can comment on or make changes to this bug.