Closed Bug 12622 Opened 21 years ago Closed 21 years ago

new message crashes m9

Categories

(MailNews Core :: Composition, defect, P3, major)

x86
Windows NT

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: wtopp, Assigned: bugzilla)

Details

i open m9.  preferences state to open both navigator and messenger.  only
navigator opens.  this is reproducible.  so, i click on the envelope and
messenger opens.  i click "new message" and apprunner crashes.  did this three
times running.  on my box it's reproducible.
Assignee: mscott → ducarroz
Component: Networking-Mail → Composition
I'm going to re-assign this to Jean-Francois. topp, did you run apprunner
-installer to migrate a 4.x mail account to 5.0? Or did you just run apprunner
straight up? I wonder if the crash happened because we don't have any mailnews
preferences (i.e. we didn't migrate anything over).

QA/Jean-Francois...an easy way to test this theory is to create a new profile
and run apprunner so you don't have any mailnews preferences in there. Try to
hit new message and see if we crash. I'm guessing this is the problem.

Changing component to composition. Re-assigning to ducarroz
Status: NEW → ASSIGNED
Target Milestone: M10
Can somebody in QA verify this problem. Thanks
may be similar to http://bugzilla.mozilla.org/show_bug.cgi?id=12570 if mscott's
theory holds true.

Peter, can you try this theory out when you get a chance?

topp@orn.net - need you to answer mscott's questions on how your mail prefs are
migrated/set up. Thanks.  Pls post your reply to the bug report.
I just did the following test with THE M9 build I get from Mozilla ftp server:

1)Delete the mozRegistry file
2)Start Apprunner & create a new profile
3)Load messenger, I get a default mail account
4)Create a new message and sent it

Works fine, I receive the message.

I then do:

1) quit apprunner,
2) Delete all the content of my prefs.js file
3) Start Apprunner and load messenger
4) Create a new message.The account list is empty
5) Send the message

At this point I didn't crash but the sent failed without any message I the
compose window has never been destroyed.
email receive from topp@orn.net:

okay.  i deleted the mozregistry.dat.  i cleansed users50.  i reinstalled m9.  i
got migrate to work, two profiles.  i open m9.  navigator has my bookmarks.
navigation partly worked.  i click on the envelopes.  messenger opens.  i click
on "new message".  m9 crashes.  my address.htm file has moved to users50 but i
can't convince myself it is being recognized.

i now restart m9.  in profile manager i choose "new" and accept the default
(mozProfile or something).  i then select the new account and start.  navigator
opens.  i click the envelopes, messenger opens.  i click "new message".  m9
crashes.

so, either with a new profile or a migrated profile m9 crashes when i click on
"new message".

however i note that in the mozProfile folder in the Users50 folder there is no
address.htm file.  there is an address.htm file in the two migrated folders but
when i go to messenger and select tasks/address book i can find no evidence my
addresses are there.  i suspect messenger is not finding the address file.
would this cause "new message" to crash m9?  lack of address file throws an
exception you're not catching or something?  btw message/new message causes the
same crash as the "new message" button.

please note i'm running nt4 sp4.  sorry about that.  i could try this on a win98
box but it's proxied onto the internet through the nt box and i've not yet found
a way to point all the m9 browser/message functions to the proxy.  i think
that's because of another bug report i filed on edit/new account wizard but i'm
not sure.
you want my migration information.  i migrated and it seemed to work.  my
bookmarks are there and fully functional in navigator.  my address.htm file is
in users50\topp\ and is correct.  however when i try "tasks/address book" the
"personal address book" appears empty.  so, it looks like the address book
migrated but isn't being used.  so, this behavior is consistent with m9 opening
a new message, looking for some feature like an address book, not finding it,
throwing an exception, and it's not caught.
Just so we don't get too sidetracked on the migration issue. Your addressbook
isn't supposed to get migrated yet. The database format for the addressbook is a
3rd party proprietary format and we haven't developed a tool to convert it to
our new open source format yet. So don't view that as an indication of the
mailnews migration failing.
I was not able to reproduce the problem also.  I tested it under WinNT 4.0 SP5. I
was testing with  the M9 build 1999-08-24-12-m9

I ran two scenarios:
Scenario A.
1) Deleting my mozregistry.dat and all profiles in my Users50 directory
2) Run Apprunner -installer
    The migration window appears
3) Select a existing profile and click on the start button
4) Click on the Close button
5) Click on the messenger icon
    The messenger window appears.
    I can see my profile has been migrated b/c I can see my subscribed newsgroups
6) Click on the New Msg button
    A new html compose window appears
7) Compose a message to yourself and send
8) Retrieve the message
    The message was received.

Scenario B
1) Deleting my mozregistry.dat and all profiles in my Users50 directory
2) Run Apprunner
    The basic migration agent apppears
3) Type in a profile name
4) Click on the Next button
    The browser window appears
5) Click on the messenger icon
    The messenger window appears.
    I can see my profile has been migrated b/c I can see my subscribed newsgroups
6) Click on the New Msg button
    A new html compose window appears
7) Compose a message to yourself and send
8) Retrieve the message
    The message was received.

I also tried setting the navigator to open both the browser and messenger window
at the same time.  As reporter noted, the messenger window does not open.  I have
to click on the envelop icon to manual open messenger.  For me, it does not crash
when I click on the New Msg icon.

Am I missing a step?
Bill wrote in a email reply,
"nope.  i have no newsgroups so i can't verify that but my bookmarks migrated.
 only difference i spot is nt 4 sp4 vs. sp5.  i do what you do and it crashes on
 my box.  one tiny chance, i've got m9 on the d: drive but 4.61 on the c: drive.
 if some part of the migration involves the location of a specific file and the
 drive is assumed this could be it.

 sorry.  let me know if there is anything else you want me to try.

 --
 bill topp
 topp@orn.net
 914 386 1938 "

Thank you for the information Bill.  On my PC, I have Communicator on a different
drive from my seamonkey binary.  I will try with no no newsgroup.
Bill,

Do you have a talkback report that you can send us?  When you crash, what is in
your xul/ms-dos windows?  Any additional information is appreciated... :)

One more thing, it might be good idea to have you try on of the nightly build?
There has been a lot of changes between M9 and the work in progress M10.
One more thing to verify:
Do you have a diretory called TEMP on c:\?
With m9, I migrated a profile with no subscribed newsgroup.  I was able to open a
new compose window.  I did not crash.

With m10, downloaded the latest win32 build from
  ftp://ftp.mozilla.org/pub/mozilla/nightly/latest/
this build appears to have problem with the profile manager wizard and migration
dialog.  It doesn't allow me to create a profile or migrate a profile.
Email reply from Bill,
 " > + ------- Additional Comments From pmock@netscape.com  08/30/99 11:40
   > + Bill,
   > +
   > + Do you have a talkback report that you can send us?

 don't know what this is.  do you mean a dr. watson file from nt?

 > When you crash, what is in
 > + your xul/ms-dos windows?
 ComposeMessage from XUL
 Created nsToolkitCore
 Toolbar registered as Drag Listener
 Toolbar registered as Drag Listener

 ComposeLoad from XUL
 Compose: ComposeStartup
 [format=0]
 [type=0]


 > + One more thing, it might be good idea to have you try on of the nightly
build?
 > + There has been a lot of changes between M9 and the work in progress M10.
 no.  profile manager in the nightly build is all messed up.  won't work at all.
 but here's one piece of good news.  i put in a newsgroup and m9 finds it just
 fine and loads the latest from my isp when asked.  so newsgroups appears to
 migrate over and work fine, as bookmarks did.  "new message" still crashes even
 with the newsgroup present.
 > +

 --
 bill topp
 topp@orn.net
 914 386 1938 "

Thank you for the feedback Bill.  Full Circle Enabled builds allow transmission
of crash data back to Netscape, improved crash analysis, and posting of crash
related information to the netscape.public.mozilla.crash-data news group...

Talkback log different from DrWatsons log.  After an apprunner crashes, the next
time you launch apprunner, the talkback program should run and prompt you if you
would like to send a talkback log to netscape.

In the future, when you download a nightly binary, try to download the build
that contains Fullcircle.
Email reply from Bill,
 " name of download and url? at the ftp site i only saw a whole bunch of mac
   downloads, some tar balls, and mozilla-win32.zip so that's what i grabbed.
   nothing else looked pc platform-ish. "

I'm sorry.  You're right.  It appears that the mozilla with talkback build is
available only in the milestone builds but not the nightly builds.

i.e ftp://ftp.mozilla.org/pub/mozilla/releases/m9/
    The file is called mozilla-win32-M9-fullcircle.zip
Target Milestone: M10 → M11
Moved it to M11
GREAT NEWS!  i originated bug 12622 for m9.  i downloaded the nightly build pre m10 and "new message" no longer crashes the build on my box.  the message doesn't actually get sent when i ask but that is probably something to do with migration or whatever.  repeat, "new message" no longer crashes the program on my box with the current nightly build.
Sweetness!
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → WORKSFORME
Therefore I close this bug as works for me...
Status: RESOLVED → VERIFIED
Verified as worksforme.
topp@orn.net - pls let me know how you like using 5.0 mail :-)  You can email me
directly if you like.  Thanks!
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.