Closed Bug 1262279 Opened 4 years ago Closed 4 years ago

the identity menulist in compose window has 2 down arrows

Categories

(Thunderbird :: Message Compose Window, defect)

x86
Linux
defect
Not set

Tracking

(thunderbird46 wontfix, thunderbird47 fixed, thunderbird48 fixed, thunderbird_esr4546+ fixed)

RESOLVED FIXED
Thunderbird 48.0
Tracking Status
thunderbird46 --- wontfix
thunderbird47 --- fixed
thunderbird48 --- fixed
thunderbird_esr45 46+ fixed

People

(Reporter: aceman, Assigned: Paenglab)

References

Details

Attachments

(2 files, 1 obsolete file)

Attached image screenshot
The identity menulist in compose window has 2 down arrows instead of the usual one.
Attached patch 1262279.patch (obsolete) — Splinter Review
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8738487 - Flags: review?(acelists)
I also noticed that once you start editing the identity (overwrite the sending address) there stays only one arrow. That is the state also if you then choose from the predefined identities again.
I got 2 arrows only after reopening compose again.
This is without the patch yet.
Attached patch 1262279.patchSplinter Review
This one works correctly.
Attachment #8738487 - Attachment is obsolete: true
Attachment #8738487 - Flags: review?(acelists)
Attachment #8738597 - Flags: review?(acelists)
Comment on attachment 8738597 [details] [diff] [review]
1262279.patch

Review of attachment 8738597 [details] [diff] [review]:
-----------------------------------------------------------------

Yes, works for me. Thanks.
Attachment #8738597 - Flags: review?(acelists) → review+
Thanks

https://hg.mozilla.org/comm-central/rev/c137da0eb0b3
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 48.0
Comment on attachment 8738597 [details] [diff] [review]
1262279.patch

[Approval Request Comment]
If this is not a sec:{high,crit} bug, please state case for ESR consideration:
User impact if declined: two dropmarkers in msgIdentity menulist
Fix Landed on Version: 48
Risk to taking this patch (and alternatives if risky): low
String or UUID changes made by this patch: no
Attachment #8738597 - Flags: approval-mozilla-esr45?
Attachment #8738597 - Flags: approval-comm-beta?
Attachment #8738597 - Flags: approval-comm-aurora?
Attachment #8738597 - Flags: approval-comm-aurora? → approval-comm-aurora+
Duplicate of this bug: 1263025
Duplicate of this bug: 1263430
Comment on attachment 8738597 [details] [diff] [review]
1262279.patch

This is for tb, not fx
Attachment #8738597 - Flags: approval-mozilla-esr45?
Attachment #8738597 - Flags: approval-mozilla-esr45-
Attachment #8738597 - Flags: approval-comm-esr45?
Attachment #8738597 - Flags: approval-comm-esr45? → approval-comm-esr45+
Attachment #8738597 - Flags: approval-comm-beta? → approval-comm-beta-
Duplicate of this bug: 1267254
You need to log in before you can comment on or make changes to this bug.