Java plugin fails-because user cannot install to root owned directory

RESOLVED WONTFIX

Status

SeaMonkey
Installer
RESOLVED WONTFIX
16 years ago
10 years ago

People

(Reporter: Grace Bush, Assigned: dveditz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
When I hit this page http://java.sun.com/ I get a pop-up window from
http://home.netscape.com/plugins/jvm.html telling me that I need to
download the Java Run Time Environment (JRE) v1.3 Plug-in for Linux. The
installer fails every time. I believe this is because in order to
install to my /usr directory, I need to be root, but the installer never
prompts me for my root password.  The error message I'm actually given
says the Windows plug-in failed to load, but the packages that flicker
across the installer are definately Linux packages.

In order to load this, I had to download the file through FTP, open
Mozilla as root, and install the packages. Most new users will not be
able to figure that one out.  I'm constantly telling people how easy
Linux is, but then I run into problems like this.  Would it be possible
to add a prompt to your installer?

Thank you for your assistance.

Ali Dolan

Comment 1

16 years ago
If Mozilla were smart, it would install plugins to the user's plugins directory
instead of the system directory, and this problem wouldn't occur.  But nooooo...
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 2

16 years ago
Thanks Justin, your sarcasm is oh so helpful.

1) profile plugins were not even supported until recently
2) "Mozilla" being smart has nothing to do with this, it's how the JRE install
script was written. Now that profile plugins are supported that script could be
updated.
Having a similar problem with Banner Blind. It says this in my install.log

-------------------------------------------------------------------------------
http://bannerblind.mozdev.org/bannerblind.xpi  --  04/29/2002 17:09:44
-------------------------------------------------------------------------------

     Banner Blind
     ------------

     ** initInstall: 0
     ** ERROR (-202): Installing: /usr/local/mozilla-1.0rc1/chrome/bannerblind.jar
     ** ERROR (-214): Register Content:
     ** ERROR (-214): Register Locale:

     Install completed successfully  --  04/29/2002 17:09:48


Is there a bug for being able to install a .xpi as an individual user? This is a
requirement as far as I'm concerned. Also, why do three errors generate a
"Install completed successfully" message?
*** Bug 142253 has been marked as a duplicate of this bug. ***

Comment 5

16 years ago
The java installer leads you down the garden path, promising that it will be
easy.  After waiting forver for it to download, it gives this error message:

Install Results
Java 2 Plug-in for Linux: Download was unsuccessful. Please try again. The Java
Plug-in is 7.6Mb and will take you 37 minutes to fully download with a 28.8
modem or 19 minutes with a 56K modem. Alternatively, you can download this
plug-in directly from our FTP site at
ftp://ftp.netscape.com/pub/netscape6/english/6.2.2/windows/win32/plugins/jre131_02i.xpi
for Windows. Please e-mail ftp-plugins@netscape.com if you continue to have
problems. Error encountered -- -202

Comment 6

14 years ago
Related bug 213038
Product: Browser → Seamonkey
(Assignee)

Comment 7

10 years ago
The xpinstall script engine has been removed from the trunk, bugs in it are obsolete.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX

Updated

10 years ago
Component: Installer: XPI Packages → Installer
QA Contact: ktrina → general
You need to log in before you can comment on or make changes to this bug.