ftp Publish yields file that cannot access

VERIFIED FIXED

Status

SeaMonkey
Composer
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: sujay, Assigned: Kathleen Brade)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: publish)

(Reporter)

Description

16 years ago
using 2/18 build of netscape

1) launch netscape
2) launch composer
3) new blanke page
4) add some text
5) File | Publish 
6) enter valid publish location, user name and password
7) Publish

check that file on the server

you get this message:

Forbidden

Your client is not allowed to access the requested object.
(Assignee)

Comment 1

16 years ago
The location Sujay is attempting to publish to is behind a firewall, but for
completeness here is the url:
  ftp://marvin.mcom.com/testplans/enderblackbox/hello.html
I think this is a duplicate of bug #121314
However, I need more details before I can confirm that it is a duplicate.

Comment 2

16 years ago
I am seeing similar problems when trying to publish to an FTP server through 
Composer on today's build (02-18).

When I try to post to ftp://ttcqa.office.aol.com/sns   (behind firewall)I get a 
username and password prompt that appears to accept my username and password, 
but it does not appear to send that information to the server because the 
dialog keeps coming up.

And when I try to publish to ftp://members.aol.com/dslmichael  I get no 
message, and the page appears to be published, but when I check the server, the 
file was not published. 

Comment 3

16 years ago
I am not sure if this helps, but the ttcqa server is running iplanet web server 
software on a linux server, and the members.aol server is an "aolserver/3.4.2".
(Assignee)

Updated

16 years ago
Summary: Publish yields file that cannot access → ftp Publish yields file that cannot access
If you're on windows, or have a debug build, can you please set the env variable:

NSPR_LOG_MODULES=nsFTPProtocol:5
NSPR_LOG_FILE=126246.log

and then upload the log?

This will reveal passwords (whcih is why this isn't yet on by default), so you
may want to edit the log first....

My test program works, locally - let me try the ui now
The UI works for me (although it asserts several times). I'd really appreciate
the log, though.

What url are you using? URLs are relative toyour home directory, so to uplaod to
~/testUp, you should enter:

ftp://localhost/testUp/

The trailing / is probably needed. I need a log to see more, though.

Comment 6

16 years ago
boo hoo! All my ftp tests were to my own website, not behind our firewall, and it
works great there.

(Assignee)

Comment 7

16 years ago
I am able to ftp publish with a build from last Wednesday (optimized mozilla on
Mac).  My build from Friday (debug mozilla build on Mac with some changes) does
not work.

Does anyone have any ideas about what might have introduced this regression?
Status: NEW → ASSIGNED
(Assignee)

Comment 8

16 years ago
update: the problems I was seeing were due to a patch for bug 121314.  I am able
to publish to ftp servers in my build (except for marvin which is running
IIS--bug 121314)
(Assignee)

Updated

16 years ago
Keywords: nsbeta1
Whiteboard: publish
(Assignee)

Comment 9

16 years ago
I am going to guess that this bug is fixed now that bug 121314 is fixed; please
re-test
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

16 years ago
verified in 2/27 build...ftp publish works and you can also
see what you published on server without any "Forbidden...." messages..

Michael/Tucson will also test on a different FTP server to confirm
that this is working...
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.