forms are not working right on my box

VERIFIED DUPLICATE of bug 7533

Status

()

Core
HTML: Form Submission
P3
normal
VERIFIED DUPLICATE of bug 7533
19 years ago
19 years ago

People

(Reporter: wtopp, Assigned: Eric Pollmann)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
i try to do a medline search with m9,
http://www.healthgate.com/medline/adv-medline.shtml
i enter "somatostatin receptor" (no quotes) in the first search box line and
select "abstract" from the menu box.  i click "increments of" up to 200.  down
further there is a "published between" option.  on 4.61 these boxes come filled
with 1997 and 1999.  with m9 the boxes are blank.  i enter 1998 and 1999 and
select the button.  done in some sequences this action causes "somatostatin
receptor" to disappear and i need to re-enter it.  i then click "retrieve
documents" and get a message from medline that the search failed.  the form is
not being submitted properly.  with 4.61 the identical search works perfectly.
failed three times running on m9.

ALSO, when i use m9 to try to report a bug i get to the enter e-mail address and
password form and it won't accept input to the form.  i'm reporting this bug
with 4.61

Updated

19 years ago
Assignee: karnaze → kmcclusk

Comment 1

19 years ago
Reassigning to Kevin.

Updated

19 years ago
Status: NEW → ASSIGNED
The form data looks correct. The problem is probably with posting the form data.

url=http://www.healthgate.com/cgi-bin/q-format.cgi

 data=Content-type: application/x-www-form-urlencoded; charset=
Referer: http://www.healthgate.com/medline/adv-medline.shtml
Content-Length: 300

f=S&v=2&d=fmedl&range=Explicit&ReADER=1&search1=&field1=All&co1
ld2=All&co2=And&search3=&field3=All&co3=And&search4=&field4=All
&field5=All&co5=And&s4=&maxitems=10&range=TWOYEARS&AfterYear=19
9&Age=All&A13A=ALL&A12A=ALL&stem=0&Submit=Retrieve+documents

Updated

19 years ago
Assignee: kmcclusk → pollmann
Status: ASSIGNED → NEW
Eric, reassigning to you. Please check the post data from mozilla against the
post data generated from communicator. If different, reassign back to me.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 4

19 years ago
The part about the year fields "1997" and "1999" being reset to empty in
apprunner is definitely a dup of bug 12475.  But there is more here.  Why are we
getting an error page when Nav is getting results?  Let's check the data posted
by HTTP POST.

I just set up a server on blueviper so that anyone inside the firewall can do
this now.  To capture the HTTP request of a form posting:

 1) Save the page locally
 2) Edit the form action to post to the host "http://blueviper:8000"
 3) Load up the local page and post the form

The HTTP request should be echo'd back to you.

Communicator sends:

POST /cgi-bin/q-format.cgi HTTP/1.0
Referer: http://blueviper/forms/adv-medline.shtml
Connection: Keep-Alive
User-Agent: Mozilla/4.61 [en] (X11; I; Linux 2.2.5-15 i686)
Host: blueviper:8000
Accept: image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, image/png, */*
Accept-Encoding: gzip
Accept-Language: en
Accept-Charset: iso-8859-1,*,utf-8
Content-type: application/x-www-form-urlencoded
Content-length: 327

f=S&v=2&d=fmedl&range=Explicit&ReADER=1&search1=somatostatin+receptor&field1=Abstract&co1=And&search2=&field2=All&co2=And&search3=&field3=All&co3=And&search4=&field4=All&co4=And&search5=&field5=All&co5=And&s4=&maxitems=200&range=Explicit&AfterYear=1998&BeforeYear=1999&Age=All&A13A=ALL&A12A=ALL&stem=0&Submit=Retrieve+documents

We send exactly (EXACTLY) the same post data and content-length.  The only
difference is our headers, which are:

POST /cgi-bin/q-format.cgi HTTP/1.0
host: blueviper
user-agent: Mozilla/5.0 [en] (Unix; I)
Content-type: application/x-www-form-urlencoded; charset=ISO-8859-1
Referer: http://blueviper/forms/adv-medline.shtml
Content-Length: 327

You can manually post this to the server, as I did, by doing this:

pollmann blueviper(54):~> telnet www.healthgate.com 80
Trying 209.67.246.21...
Connected to www.healthgate.com.
Escape character is '^]'.
POST /cgi-bin/q-format.cgi HTTP/1.0
host: blueviper
user-agent: Mozilla/5.0 [en] (Unix; I)
Content-type: application/x-www-form-urlencoded; charset=ISO-8859-1
Referer: http://blueviper/forms/adv-medline.shtml
Content-Length: 327

f=S&v=2&d=fmedl&range=Explicit&ReADER=1&search1=somatostatin+receptor&field1=Abstract&co1=And&search2=&field2=All&co2=And&search3=&field3=All&co3=And&search4=&field4=All&co4=And&search5=&field5=All&co5=And&s4=&maxitems=200&range=Explicit&AfterYear=1998&BeforeYear=1999&Age=All&A13A=ALL&A12A=ALL&stem=0&Submit=Retrieve+documents
HTTP/1.0 200 OK
Server: Netscape-Enterprise/2.01
Date: Sat, 28 Aug 1999 02:08:14 GMT
Content-type: text/html

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML//EN">
<html>
...

And see that we are getting back a page that says "Sorry!"  This means our
headers are incompatible.  I'm now going to play a little guess-and-check to
find out which one it is...
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 5

19 years ago
Amazing, this is a dup of 7533.  I changed out post headers to use:

Content-type: application/x-www-form-urlencoded

And everything is happy.  Marking this a dup.

*** This bug has been marked as a duplicate of 7533 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 6

19 years ago
Verified.
You need to log in before you can comment on or make changes to this bug.