Mail Server Certificate not saved

NEW
Unassigned

Status

MailNews Core
Networking: POP
16 years ago
2 years ago

People

(Reporter: Georg Wild, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8+) Gecko/20020217
BuildID:    2002021706

When using Secure POP I got messages that the server and the certificate are not
identical.
This might not be an error because for example gmx has .de and .net and (as I
know) use therefor the same server. So I think accepting a certificate for some
server should make accepting this certificate forever!

Reproducible: Always
Steps to Reproduce:
1.Get Mail over SPOP from server with different cert
"Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.2a) Gecko/20020910"

I am not sure of what you meant, but here is my case:

My PopS server has a certificate with name = 'pop.xxx';
But the server can also be accessed by using the 'pop3.xxx' name (for example);

Likewise, my ISP has now a new/future server named 'testpop.xxx',
for which they simply use their 'pop.xxx' certificate.

At each _first_ connection, I get the warning dialog to inform me that the name
which I use and the name in the certificate are not the same: fine.

But I miss a check box to have Mozilla remember that I agree to proceed with
that server & certificate together :-(

NB: In its HttpS counterpart, the check box is present and working :-)
(Reporter)

Comment 2

15 years ago
I think this is somehow fixed in the meantime! The mentioned feature was not
there 1/2 year ago!
Close?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Well, I see *no* way to tell my v1.2.a to remember my choice (between two restarts).
I don't know about any previous version.

Either we are not talking about the same problem;
or it is broken in the release/build which I am using.

From my point of view, I would ask for REOPENING.
Created attachment 99867 [details]
Screenshot of dialog on v1.2.a (SergeG)

Here is the screenshot which I get: no check box !

(And the mailer does not automatically remember either: fine.)
(Reporter)

Comment 5

15 years ago
Sorry,
it seems like I have misinterpreted a dialog; this feature seems not to be
written yet!
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
"Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.2b) Gecko/20021016"

Bug still there.

Comment 7

15 years ago
Created attachment 117556 [details]
Screenshot of dialog on v1.2.a (SergeG)

serge - you uploaded a zipped .bmp image.
it is more useful to upload something that can be viewed in a single click.
if you couldn't have saved in a better format, you still shouldn't have zipped
it.

this attachment is the same as the previous one, but in .png instead of
.bmp.zip
Attachment #99867 - Attachment is obsolete: true

Comment 8

15 years ago
i also have this problem because i use secure imap over an ssh tunnel.
i know i've seen this somewhere else in the bugzilla database, 
but searching turns up nothing.

on my linux machine at work (rh7.3, moz1.3 release), i get the warning of
certificate mismatch almost every time it automatically checks my mail.  this
frequency is new as of 1.3; before it would ask once per session.  
if others are having this problem pop up every time mozilla automatically checks
their mail, this bug will be rather important (bump up priority and/or severity).

confirming bug.  
(the higher visibility may lead to it being marked as a dup,
and if it isn't, then this is certainly a valid issue)
Status: UNCONFIRMED → NEW
Ever confirmed: true
mass re-assign.
Assignee: naving → sspitzer
Product: MailNews → Core
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
Filter on "Nobody_NScomTLD_20080620"
QA Contact: sheelar → networking.pop
(Assignee)

Updated

9 years ago
Product: Core → MailNews Core
Removing myslef on all the bugs I'm cced on. Please NI me if you need something on MailNews Core bugs from me.
You need to log in before you can comment on or make changes to this bug.