Intermittent test_serviceworker_lifetime.html | Service worker was terminated, | Test timed out, etc.

RESOLVED FIXED in Firefox 49

Status

()

RESOLVED FIXED
3 years ago
a year ago

People

(Reporter: philor, Assigned: bkelly)

Tracking

({intermittent-failure})

unspecified
mozilla51
intermittent-failure
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox48 unaffected, firefox49 fixed, firefox50 fixed, firefox51 fixed)

Details

Attachments

(1 attachment)

6 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* fx-team: 5
* mozilla-inbound: 1

Platform breakdown:
* windowsxp: 2
* windows8-64: 2
* windows7-32: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1262702&startday=2016-04-04&endday=2016-04-10&tree=all
6 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* fx-team: 3
* mozilla-central: 1
* mozilla-beta: 1
* ash: 1

Platform breakdown:
* windowsxp: 6

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1262702&startday=2016-04-18&endday=2016-04-24&tree=all
16 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 14
* mozilla-aurora: 1
* fx-team: 1

Platform breakdown:
* linux64: 15
* windowsxp: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1262702&startday=2016-05-23&endday=2016-05-29&tree=all
51 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 24
* try: 14
* fx-team: 10
* mozilla-central: 3

Platform breakdown:
* linux64: 46
* linux32: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1262702&startday=2016-05-30&endday=2016-06-05&tree=all
43 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 20
* fx-team: 10
* mozilla-aurora: 6
* mozilla-central: 5
* try: 2

Platform breakdown:
* linux64: 40
* linux32: 3

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1262702&startday=2016-06-06&endday=2016-06-12&tree=all
12 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 9
* fx-team: 3

Platform breakdown:
* linux64: 10
* linux32: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1262702&startday=2016-06-13&endday=2016-06-19&tree=all
36 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 21
* mozilla-aurora: 7
* fx-team: 6
* mozilla-central: 1
* autoland: 1

Platform breakdown:
* linux64: 32
* windows7-32: 2
* linux32: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1262702&startday=2016-06-20&endday=2016-06-26&tree=all
44 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-aurora: 15
* mozilla-inbound: 11
* fx-team: 9
* autoland: 7
* mozilla-central: 2

Platform breakdown:
* linux64: 38
* linux32: 5
* windows7-32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1262702&startday=2016-06-27&endday=2016-07-03&tree=all
39 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* autoland: 11
* mozilla-inbound: 8
* mozilla-aurora: 8
* fx-team: 6
* try: 5
* mozilla-central: 1

Platform breakdown:
* linux64: 38
* linux32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1262702&startday=2016-07-04&endday=2016-07-10&tree=all
12 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-aurora: 4
* mozilla-inbound: 3
* autoland: 3
* fx-team: 2

Platform breakdown:
* linux64: 10
* linux32: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1262702&startday=2016-07-11&endday=2016-07-17&tree=all
17 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-aurora: 8
* mozilla-inbound: 4
* fx-team: 4
* mozilla-central: 1

Platform breakdown:
* linux64: 15
* linux32: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1262702&startday=2016-07-18&endday=2016-07-24&tree=all
status-firefox48: --- → unaffected
status-firefox49: --- → affected
status-firefox50: --- → affected
Any ideas, Kit?
Flags: needinfo?(kcambridge)
49 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* fx-team: 15
* autoland: 13
* mozilla-inbound: 12
* mozilla-aurora: 5
* mozilla-central: 3
* try: 1

Platform breakdown:
* linux64: 39
* linux32: 10

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1262702&startday=2016-07-25&endday=2016-07-31&tree=all
Not yet. :-( Keeping ni? to follow up, but I won't have cycles to look into this for a while.
87 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 32
* autoland: 16
* mozilla-aurora: 11
* fx-team: 10
* mozilla-beta: 9
* mozilla-central: 8
* ash: 1

Platform breakdown:
* linux64: 65
* linux32: 22

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1262702&startday=2016-08-01&endday=2016-08-07&tree=all
15 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 7
* autoland: 4
* mozilla-aurora: 2
* fx-team: 2

Platform breakdown:
* linux64: 10
* linux32: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1262702&startday=2016-08-10&endday=2016-08-10&tree=all
65 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 23
* autoland: 19
* mozilla-aurora: 8
* fx-team: 8
* mozilla-central: 3
* mozilla-beta: 3
* try: 1

Platform breakdown:
* linux64: 46
* linux32: 19

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1262702&startday=2016-08-08&endday=2016-08-14&tree=all
15 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-aurora: 5
* mozilla-inbound: 4
* autoland: 3
* mozilla-central: 2
* fx-team: 1

Platform breakdown:
* linux64: 12
* linux32: 3

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1262702&startday=2016-08-19&endday=2016-08-19&tree=all
62 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 23
* mozilla-aurora: 16
* autoland: 14
* mozilla-central: 3
* mozilla-beta: 2
* fx-team: 2
* try: 1
* ash: 1

Platform breakdown:
* linux64: 51
* linux32: 11

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1262702&startday=2016-08-15&endday=2016-08-21&tree=all
20 automation job failures were associated with this bug yesterday.

Repository breakdown:
* autoland: 9
* mozilla-inbound: 8
* mozilla-aurora: 2
* mozilla-beta: 1

Platform breakdown:
* linux64: 18
* linux32: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1262702&startday=2016-08-22&endday=2016-08-22&tree=all
15 automation job failures were associated with this bug yesterday.

Repository breakdown:
* autoland: 7
* mozilla-inbound: 4
* mozilla-aurora: 3
* fx-team: 1

Platform breakdown:
* linux64: 11
* linux32: 4

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1262702&startday=2016-08-23&endday=2016-08-23&tree=all
Any ideas Ben? This is really frequent on Beta too.
Flags: needinfo?(bkelly)
35 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-aurora: 12
* mozilla-beta: 8
* autoland: 8
* mozilla-inbound: 6
* mozilla-central: 1

Platform breakdown:
* linux64: 29
* linux32: 6

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1262702&startday=2016-08-25&endday=2016-08-25&tree=all
(Assignee)

Comment 24

2 years ago
I'll look on Monday.  I'm on PTO tomorrow.
31 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 11
* autoland: 8
* mozilla-beta: 4
* mozilla-aurora: 4
* fx-team: 3
* mozilla-central: 1

Platform breakdown:
* linux64: 24
* linux32: 7

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1262702&startday=2016-08-26&endday=2016-08-26&tree=all
110 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* autoland: 34
* mozilla-inbound: 31
* mozilla-aurora: 21
* mozilla-beta: 13
* mozilla-central: 6
* fx-team: 5

Platform breakdown:
* linux64: 89
* linux32: 21

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1262702&startday=2016-08-22&endday=2016-08-28&tree=all
(Assignee)

Updated

2 years ago
Assignee: nobody → bkelly
Status: NEW → ASSIGNED
Flags: needinfo?(bkelly)
(Assignee)

Comment 27

2 years ago
Created attachment 8786091 [details] [diff] [review]
Avoid racing with initial shutdown in test_service_worker_lifetime.html. r=kitcambridge

https://treeherder.mozilla.org/#/jobs?repo=try&revision=26ccdf91a0b3
(Assignee)

Comment 28

2 years ago
Comment on attachment 8786091 [details] [diff] [review]
Avoid racing with initial shutdown in test_service_worker_lifetime.html. r=kitcambridge

Try is green with ~30 pushes on linux64 pgo.  So I think this is good to go.

Kit, I believe the issue here is that the initial service worker instance spawned during the createIframe() call was sometimes shutting down right as the push event was being processed.  Normally the timing works our ok, but in pgo we start losing the race.

This patch avoids the problem by waiting to proceed until this initial service worker thread has positively been stopped.
Flags: needinfo?(kcambridge)
Attachment #8786091 - Flags: review?(kcambridge)
Comment on attachment 8786091 [details] [diff] [review]
Avoid racing with initial shutdown in test_service_worker_lifetime.html. r=kitcambridge

Review of attachment 8786091 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, Ben!
Attachment #8786091 - Flags: review?(kcambridge) → review+
Ben explained this to me a bit more on IRC. The explanation was very helpful, so capturing it here for posterity...

09:35 <bkelly> whats up?
09:36 <kitcambridge> bkelly: just trying to understand what's going on with that test. :-) so, createIframe spins up the service worker...
09:36 <kitcambridge> but it has nothing to do, so it shuts down
09:36 <bkelly> kitcambridge: right, because idle timer is set to zero
09:36 <kitcambridge> and that races with the setShutdownObserver(false)?
09:36 <bkelly> kitcambridge: but it still takes some time to shutdown
09:37 <bkelly> kitcambridge: and in non-pgo sometimes it shuts down after setShutdownObserver(false), but before we can fire the push event to trigger the waitUntil()
09:37 <bkelly> sorry in pgo
09:37 <kitcambridge> and in that case, we'll observe the earlier shutdown instead of the one caused by the push event
09:38 <bkelly> right
09:38 <kitcambridge> so your patch fixes that so it waits for the first shutdown
09:38 <kitcambridge> and after that, we attach another observer and fire the event
09:39 <bkelly> and that event uses a waitUntil() to keep it alive
09:39 <bkelly> so we have no shutdown race

Comment 31

2 years ago
Pushed by bkelly@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/31b100c982b5
Avoid racing with initial shutdown in test_service_worker_lifetime.html. r=kitcambridge
(Assignee)

Comment 32

2 years ago
Let me see if this works in FF49.
(Assignee)

Comment 33

2 years ago
Comment on attachment 8786091 [details] [diff] [review]
Avoid racing with initial shutdown in test_service_worker_lifetime.html. r=kitcambridge

The patch applies cleanly to beta and runs locally.

Approval Request Comment
[Feature/regressing bug #]: Service workers
[User impact if declined]: Test intermittents annoying RyanVM on beta/aurora.
[Describe test coverage new/current, TreeHerder]: The patch modifies an existing mochitest.
[Risks and why]: Minimal.  Only modified a test.
[String/UUID change made/needed]: None
Attachment #8786091 - Flags: approval-mozilla-beta?
Attachment #8786091 - Flags: approval-mozilla-aurora?

Comment 34

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/31b100c982b5
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox51: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
22 automation job failures were associated with this bug yesterday.

Repository breakdown:
* autoland: 9
* mozilla-beta: 3
* mozilla-aurora: 3
* fx-team: 3
* mozilla-inbound: 2
* mozilla-central: 2

Platform breakdown:
* linux64: 17
* linux32: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1262702&startday=2016-08-30&endday=2016-08-30&tree=all
Attachment #8786091 - Flags: approval-mozilla-beta?
Attachment #8786091 - Flags: approval-mozilla-aurora?

Comment 36

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/145d2272fe84
status-firefox50: affected → fixed
Flags: in-testsuite+

Comment 37

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/faf186e4d05c
status-firefox49: affected → fixed
39 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* autoland: 12
* mozilla-inbound: 7
* mozilla-beta: 6
* mozilla-aurora: 6
* fx-team: 5
* mozilla-central: 2
* ash: 1

Platform breakdown:
* linux64: 30
* linux32: 9

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1262702&startday=2016-08-29&endday=2016-09-04&tree=all
10 failures in 623 pushes (0.016 failures/push) were associated with this bug in the last 7 days.  

Repository breakdown:
* mozilla-inbound: 6
* autoland: 4

Platform breakdown:
* linux64: 10

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1262702&startday=2016-11-21&endday=2016-11-27&tree=all
1 failures in 822 pushes (0.001 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-beta: 1

Platform breakdown:
* windows7-32-vm: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1262702&startday=2017-07-17&endday=2017-07-23&tree=all
You need to log in before you can comment on or make changes to this bug.