The keyword currentColor should be inherited as currentColor

RESOLVED DUPLICATE of bug 760345

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 760345
2 years ago
2 years ago

People

(Reporter: Xavier Zalawa, Unassigned)

Tracking

45 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8738914 [details]
Testcase

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160315153207

Steps to reproduce:

1. Nest two depths of `div` HTML element.
2. Apply `background-color: currentColor` on the first depth and `background-color: inherit` on the second.
3. Apply the `color` CSS property on the two depths with a different value.



Actual results:

The keyword `currentColor` is inherited as the computed value of the `color` CSS property of its parent.
The background of each depth is filled with the same color.


Expected results:

The keyword `currentColor` should be inherited as it is.
The background of each depth should be filled with this own computed value of the `color` CSS property as it is defined in the CSS specification of W3C: https://drafts.csswg.org/css-color/#currentcolor-color
It seems that was agreed upon in 2012: https://lists.w3.org/Archives/Public/www-style/2012May/0541.html
(Reporter)

Comment 1

2 years ago
This issue follows a first one in the Blink tracker: https://bugs.chromium.org/p/chromium/issues/detail?id=592908

Updated

2 years ago
Component: Untriaged → CSS Parsing and Computation
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 760345
You need to log in before you can comment on or make changes to this bug.