Note: There are a few cases of duplicates in user autocompletion which are being worked on.

NS_ERROR_FAILURE in nsITelemetry.getKeyedHistogramById when opening miniclip.com

RESOLVED FIXED in Firefox 47

Status

()

Core
Plug-ins
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: brindusat, Unassigned)

Tracking

47 Branch
mozilla48
Points:
---

Firefox Tracking Flags

(firefox46 unaffected, firefox47 fixed, firefox48 fixed)

Details

Attachments

(1 attachment)

[Affected versions]:
- Nightly 48.0a1 (build id: 20160406030221)

[Affected platforms]:
- Windows 7 x64, 
- Windows 8.1 x32
- Windows 10 x64
- Mac OS 10.10
- Linux

[Steps to reproduce]:
1. Launch Firefox with a new profile and open the Browser Console (from menu [≡] → select "Developer" → select "Browser Console")
2. Navigate to http://www.miniclip.com/games/en/ .
3. Observe the Browser Console's content.

[Expected result]:
There shoudln't be any errors displayed in the Browser Console.

[Actual result]:
NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsITelemetry.getKeyedHistogramById] is displayed in the Browser Console.

[Additional notes]:
- Issue does not reproduce on Release (version 45.0.1, build id 20160315153207), Aurora (version 47.0a2, build id 20160406004015) and Beta (version 46.0b8, build id 20160404120533)

Comment 1

a year ago
This is from PluginContent.jsm for the line:

Services.telemetry.getKeyedHistogramById('PLUGIN_TINY_CONTENT').add(key);

PLUGIN_TINY_CONTENT is not a keyed histogram.

Regressed when initially added in bug 1237198, --> Tobias or François, can you take a look?

(setting affected to 47 as well because that bug *just* got uplifted)
Blocks: 1237198
status-firefox47: --- → affected
status-firefox48: --- → affected
Component: General → Plug-ins
Flags: needinfo?(tschneider)
Flags: needinfo?(francois)
Keywords: regression
Product: Firefox → Core
Also, .add(key) doesn't make sense. This is a count histogram, so .add(1) is the only value that makes sense.
Created attachment 8739110 [details] [diff] [review]
patch

Use getKeyedHistogramById(...).add(1) since PLUGIN_TINY_CONTENT is a count histogram.
Flags: needinfo?(tschneider)
Flags: needinfo?(francois)
Attachment #8739110 - Flags: review?(benjamin)
Attachment #8739110 - Flags: review?(benjamin) → review+
This also needs to be uplifted to Aurora.
Keywords: regression → checkin-needed

Comment 5

a year ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/f57d33cd122d
Keywords: checkin-needed

Comment 6

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/f57d33cd122d
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox48: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
Comment on attachment 8739110 [details] [diff] [review]
patch

Approval Request Comment
[Feature/regressing bug #]: bug 1237198
[User impact if declined]: Without this fix, we won't be able to collect plugin telemetry needed for our plugin blocking experiment (bug 1237198).
[Describe test coverage new/current, TreeHerder]: Just local testing. The patch landed in mozilla-central yesterday.
[Risks and why]: Low risk. This is a one-line patch that fixes how we report one particular telemetry probe.
[String/UUID change made/needed]: None.
Attachment #8739110 - Flags: approval-mozilla-aurora?
status-firefox46: --- → unaffected
Comment on attachment 8739110 [details] [diff] [review]
patch

Plugin block experiment related, Aurora47+
Attachment #8739110 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/f04cf5bb543f
status-firefox47: affected → fixed
Blocks: 1259463
No longer blocks: 1259463
You need to log in before you can comment on or make changes to this bug.