Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: Ray Holme, Unassigned)

Tracking

45 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160304160129

Steps to reproduce:

I have been logging into this website for several years. Yesterday after I entered my username and instead of going to the password screen. I just get a flashing screen saying that the site is proceeding to login.

I made NO changes in my login procedure. I updated Fedora (and all sub-products) over a week ago (all was fine until yesterday) and tried updating again after finding the problem. This is the only web site that does this and it has worked for a long time.


Actual results:

http://www.norwaysavingsbank.com/

  just flashes after entering  my username

I have another Fedora box (same revisions of OS + software) and the site works fine there. I called the vendor and I am the only person having this problem. Internet explorer also works fine.

I have NO idea what to do to capture this VERY peculiar error. I expect I will need to rebuild my machine but can think of no other alternatives.

It flashes about once a second "processing login".


Expected results:

I should have gone to the page itasking for a password.
Post your Graphic section from about:support,
next make sure that you're using latest GPU drivers,
if not, update it and redo the STR and post info from about:support again.
Component: Untriaged → Graphics
Flags: needinfo?(rayholme)
OS: Unspecified → Linux
Product: Firefox → Core
Hardware: Unspecified → x86_64
(Reporter)

Comment 2

2 years ago
Created attachment 8739400 [details]
screenshot from about:suport  graphics secion

Requested screenshot enclosed. I see nothing particular to note (4 errors may be quite old - I have no idea if they are related but doubt it as Firefox never complained, just looped).

Let me know anything else that I can do to help find the problem, or clear it.

Again - it worked the prior day (and many-many before that) with no change - loops now.

Tried again today, still loops.

Would re-installing firefox perhaps fix this? Next choice is reinstalling newer release of fedora. Now 4.4.6-200.fc22.x86_64 with firefox fully patched.
(Reporter)

Comment 3

2 years ago
How do I check GPU drivers?
Flags: needinfo?(rayholme)
(Reporter)

Comment 4

2 years ago
This problem is consistent on MY computer (flashing a screen saying "processing login").

My wife's computer runs this site fine. I maintain both systems and they are both running Fedora 22 at the same patch level for ALL programs (including Firefox). I check this site daily so must use her computer.

I am an experienced Unix administrator so I will try anything you need me to try, but I don't know how to check GPU (graphics processing unit?) drivers. My machine is newer (more cpus and memory and disk) and has a graphics driver board in it while hers does not. However this problem occurred at a random time (6 days after my last DNF update) and an update ran immediately had no effect.
(Reporter)

Comment 5

2 years ago
For the record, this continued for 7 days. Today, I brought up edit->preferences->security and was going to remove the saved password information. Before I did that, I tried again and the site worked normally.

I tried again witht the "security" page gone and it works.


No idea what fixed this. You can close it as a bug, but I sure am baffled.
(Reporter)

Comment 6

2 years ago
OK, I do have an idea what happened. Firefox was blocking an outdated Adobe Flash. I allowed it "this time" and back came the flash. I will update ALL and restart Firefox to make sure.
(Reporter)

Comment 7

2 years ago
OK, I updated my system (a new flash was installed), rebooted and restarted firefox with most recent version.

The flash is back. Yuck and I don't know why.

I also removed the saved password information as just looking at that last time made it work.

That also did not work. I will have to visit this site from another computer until it cures itself.

I wish there was something I could try to find out what it was.
(Reporter)

Comment 8

2 years ago
The flicker lines alternate between

   Waiting for .....
   Reading from .....

where the web site is named. The original login is at one place and then redirected to the real place (always has been).

I guess I will have to wait till I upgrade Fedora to a new release and pray that a new installation of Firefox will not continue with this.
When the site did come back (as noted above), it was exceedingly slow during what would have been the flicker time.
From comments, it seems not graphics bug. Frame load seems to be blocked by some reasons.

Updated

2 years ago
Component: Graphics → General
Product: Core → Firefox

Updated

2 years ago
Component: General → Untriaged
(Reporter)

Comment 10

2 years ago
OK, while this machine does have a graphics processor I would agree with Sotaro that it is NOT because of the graphics. We have a tight loop that is looking for web data and for some reason never seems to acknowledge getting it (unclear if it is or not).

Is there ANYTHING I can do to gather more data on this so you have a better chance to find it???
Hi Ray,

Have you tried a new profile or safe mode(https://goo.gl/PNe90E)?

Thanks,
Paul.
Flags: needinfo?(rayholme)
(Reporter)

Comment 12

2 years ago
OK, tried steps 1-6

1. Restart your computer
2. Clear your cookies and cache
3. Restart Firefox in Safe Mode
4. Troubleshoot your plugins
5. Reinstall Firefox
6. Refresh Firefox
STOP - OK.

At #4 it wanted to upgrade from 45 to 46 Firefox and since I used dnf (yum) to do things, I skipped the upgrade after downloading and not knowing where to install the tar file (not obvious to a find command).
Only Adobe flash is installed and it is/was current.

 So I did a complete dnf update to the machine (firefox did not change).

#5 did this and got back 45 (guess 46 is NOT current at fedora land yet)

(PS restarted firefox between each step above).

#6 WORKED!

Many thanks - darned if I know what really broke this.
Flags: needinfo?(rayholme)
Based on Comment 12 from the reporter, changing status to RESOLVED WORKS FOR ME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.