Missing awInputElement object in Mail compose window

VERIFIED FIXED in mozilla1.0

Status

MailNews Core
Composition
--
blocker
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: Antonio Lam, Assigned: varada)

Tracking

Trunk
mozilla1.0
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I tried today's linux trunk build, and realize the mail compose chrome
window is missing the "awInputElement" object.

I checked with today's window build, and the"awInputElement" is there.  It is 
missing only in Linux build.

This bug is currently preventing me from running my autamated test.
-->varada
Assignee: ducarroz → varada
(Assignee)

Comment 2

17 years ago
Marking worksforme. 
Couldnt be reproduced on reporter's build either.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

17 years ago
Re-open the bug.

Now it consistently saying it has no properties for 
<messageWindow>.awInputElement object in the JavaScript Console.

It just worked perfectly fine with 2002021513 build with the same test script. 
Only with today's build, the above error pop up, and the test can not continue 
from there.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Updated

17 years ago
Keywords: nsbeta1

Comment 4

17 years ago
Varada - you may need to work directly with Antonio to see this problem.
QA Contact: sheelar → alam

Comment 5

17 years ago
Discussed in 2/27/02 Mail & News bug meeting.  Decisions was to minus and Fuure
this bug.
Keywords: nsbeta1 → nsbeta1-
Target Milestone: --- → Future

Comment 6

17 years ago
Changing to an nsbeta1+ to unblock the S/MIME automated tests.  Varada, could
you look into this?  If you get a fix and the trunk is still in 0.9.9 this I
think it would be worth asking for checkin approval since it's blocking testing.
Keywords: nsbeta1- → nsbeta1+
Target Milestone: Future → mozilla1.0
(Assignee)

Comment 7

17 years ago
The problem doesnt seem to be related to compose directly. The test code tries
to enumerate all the windows to obtain the mail compose window by detecting a
function and then obtaining variables inside it. At the first try the code
seemed to fail at determining the window and couldnt proceed beyond it so
obtaining values from local variables is not going to be possible. 
Apparently something must have changed on the linux build that makes it unable
to get the window. I plan to help lam with his code when he gets back later today.
(Reporter)

Comment 8

17 years ago
Varada, I tried your suggestion on how to get the compose window:

var windowManager = 
Components.classes['@mozilla.org/rdf/datasource;1?name=window-mediator'].getServ
ice();
var iwindowManager = Components.interfaces.nsIWindowMediator;
var windowManager  = cwindowManager.QueryInterface(iwindowManager);
var mailWindow = windowManager.getMostRecentWindow('msgcompose');

And also, I added some delays in the script to make sure the compose window is 
fully loaded before proceeding to the next statement.

After doing all these, my test case just run fine
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

17 years ago
Verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.