Closed Bug 1262930 Opened 4 years ago Closed 3 years ago

23,800 instances of "No inner window available!" emitted from dom/base/nsGlobalWindow.cpp during linux64 debug testing

Categories

(Core :: DOM: Core & HTML, defect)

47 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla51
Tracking Status
firefox47 --- wontfix
firefox48 --- wontfix
firefox49 --- wontfix
firefox50 --- wontfix
firefox51 --- fixed

People

(Reporter: erahm, Assigned: ben.tian)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [tw-dom] btpp-close)

Attachments

(2 files, 3 obsolete files)

This currently the #2 most verbose warning during testing.

> 15430 [NNNNN] WARNING: No inner window available!: file dom/base/nsGlobalWindow.cpp, line 9767

This warning [1], from |nsGlobalWindow::GetKeyboardIndicators|, shows up in the following test suites:

> mozilla-central_ubuntu64_vm-debug_test-web-platform-tests-e10s-1-bm54-tests1-linux64-build1.txt:1047
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-browser-chrome-7-bm54-tests1-linux64-build0.txt:969
> mozilla-central_ubuntu64_vm-debug_test-web-platform-tests-e10s-3-bm121-tests1-linux64-build5.txt:938
> mozilla-central_ubuntu64_vm-debug_test-web-platform-tests-e10s-5-bm68-tests1-linux64-build4.txt:924
> mozilla-central_ubuntu64_vm-debug_test-web-platform-tests-reftests-e10s-bm68-tests1-linux64-build1.txt:904
> mozilla-central_ubuntu64_vm-debug_test-web-platform-tests-e10s-6-bm53-tests1-linux64-build2.txt:851
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-browser-chrome-5-bm131-tests1-linux64-build5.txt:757
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-browser-chrome-4-bm122-tests1-linux64-build12.txt:717
> mozilla-central_ubuntu64_vm-debug_test-web-platform-tests-e10s-2-bm114-tests1-linux64-build1.txt:670
> mozilla-central_ubuntu64_vm-debug_test-web-platform-tests-e10s-8-bm54-tests1-linux64-build5.txt:620
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-browser-chrome-6-bm53-tests1-linux64-build5.txt:610
> mozilla-central_ubuntu64_vm-debug_test-mochitest-other-bm131-tests1-linux64-build4.txt:545
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-browser-chrome-3-bm115-tests1-linux64-build13.txt:505
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-browser-chrome-2-bm131-tests1-linux64-build4.txt:497
> mozilla-central_ubuntu64_vm-debug_test-web-platform-tests-reftests-bm53-tests1-linux64-build5.txt:453
> mozilla-central_ubuntu64_vm-debug_test-web-platform-tests-e10s-4-bm68-tests1-linux64-build5.txt:393
> mozilla-central_ubuntu64_vm-debug_test-mochitest-browser-chrome-4-bm115-tests1-linux64-build2.txt:392
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-browser-chrome-1-bm116-tests1-linux64-build2.txt:328
> mozilla-central_ubuntu64_vm-debug_test-mochitest-browser-chrome-5-bm122-tests1-linux64-build1.txt:258
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-1-bm131-tests1-linux64-build5.txt:250
> mozilla-central_ubuntu64_vm-debug_test-web-platform-tests-e10s-7-bm113-tests1-linux64-build4.txt:216
> mozilla-central_ubuntu64_vm-debug_test-mochitest-jetpack-bm115-tests1-linux64-build7.txt:215
> mozilla-central_ubuntu64_vm-debug_test-mochitest-2-bm131-tests1-linux64-build7.txt:200
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-8-bm131-tests1-linux64-build0.txt:179
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-8-bm118-tests1-linux64-build3.txt:179
> mozilla-central_ubuntu64_vm-debug_test-mochitest-8-bm54-tests1-linux64-build0.txt:153
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-2-bm125-tests1-linux64-build2.txt:150
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-5-bm68-tests1-linux64-build4.txt:140
> mozilla-central_ubuntu64_vm-debug_test-mochitest-media-e10s-bm54-tests1-linux64-build0.txt:138
> mozilla-central_ubuntu64_vm-debug_test-mochitest-browser-chrome-2-bm131-tests1-linux64-build8.txt:134
> mozilla-central_ubuntu64_vm-debug_test-mochitest-media-bm114-tests1-linux64-build0.txt:128
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-3-bm68-tests1-linux64-build4.txt:124
> mozilla-central_ubuntu64_vm-debug_test-mochitest-browser-chrome-7-bm122-tests1-linux64-build7.txt:115
> mozilla-central_ubuntu64_vm-debug_test-mochitest-browser-chrome-1-bm131-tests1-linux64-build4.txt:113
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-7-bm123-tests1-linux64-build6.txt:111
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-6-bm115-tests1-linux64-build5.txt:104
> mozilla-central_ubuntu64_vm-debug_test-mochitest-1-bm130-tests1-linux64-build6.txt:102
> mozilla-central_ubuntu64_vm-debug_test-mochitest-3-bm118-tests1-linux64-build7.txt:101
> mozilla-central_ubuntu64_vm-debug_test-mochitest-browser-chrome-3-bm118-tests1-linux64-build2.txt:94
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-4-bm131-tests1-linux64-build3.txt:87
> mozilla-central_ubuntu64_vm-debug_test-mochitest-5-bm122-tests1-linux64-build8.txt:80
> mozilla-central_ubuntu64_vm-debug_test-mochitest-devtools-chrome-3-bm117-tests1-linux64-build8.txt:75
> mozilla-central_ubuntu64_vm-debug_test-mochitest-7-bm115-tests1-linux64-build4.txt:73
> mozilla-central_ubuntu64_vm-debug_test-mochitest-browser-chrome-6-bm118-tests1-linux64-build4.txt:64
> mozilla-central_ubuntu64_vm-debug_test-mochitest-6-bm117-tests1-linux64-build3.txt:53
> mozilla-central_ubuntu64_vm-debug_test-mochitest-devtools-chrome-6-bm54-tests1-linux64-build4.txt:51
> mozilla-central_ubuntu64_vm-debug_test-mochitest-4-bm122-tests1-linux64-build3.txt:50
> mozilla-central_ubuntu64_vm-debug_test-web-platform-tests-5-bm54-tests1-linux64-build2.txt:30
> mozilla-central_ubuntu64_vm-debug_test-mochitest-devtools-chrome-8-bm122-tests1-linux64-build1.txt:27
> mozilla-central_ubuntu64_vm-debug_test-mochitest-devtools-chrome-5-bm54-tests1-linux64-build4.txt:26
> mozilla-central_ubuntu64_vm-debug_test-mochitest-devtools-chrome-4-bm131-tests1-linux64-build5.txt:22
> mozilla-central_ubuntu64_vm-debug_test-mochitest-devtools-chrome-2-bm113-tests1-linux64-build6.txt:18
> mozilla-central_ubuntu64_vm-debug_test-mochitest-devtools-chrome-1-bm53-tests1-linux64-build5.txt:17
> mozilla-central_ubuntu64_vm-debug_test-mochitest-devtools-chrome-7-bm68-tests1-linux64-build6.txt:16
> mozilla-central_ubuntu64_vm-debug_test-crashtest-e10s-bm53-tests1-linux64-build4.txt:12
> mozilla-central_ubuntu64_vm-debug_test-mochitest-gl-e10s-bm120-tests1-linux64-build6.txt:9
> mozilla-central_ubuntu64_vm-debug_test-crashtest-bm67-tests1-linux64-build6.txt:8
> mozilla-central_ubuntu64_vm-debug_test-web-platform-tests-4-bm123-tests1-linux64-build8.txt:6
> mozilla-central_ubuntu64_vm-debug_test-mochitest-gl-bm53-tests1-linux64-build4.txt:6
> mozilla-central_ubuntu64_vm-debug_test-reftest-e10s-2-bm118-tests1-linux64-build10.txt:5
> mozilla-central_ubuntu64_vm-debug_test-reftest-e10s-1-bm120-tests1-linux64-build10.txt:5
> mozilla-central_ubuntu64_vm-debug_test-jsreftest-e10s-bm131-tests1-linux64-build9.txt:5
> mozilla-central_ubuntu64_vm-debug_test-web-platform-tests-3-bm116-tests1-linux64-build8.txt:4
> mozilla-central_ubuntu64_vm-debug_test-reftest-4-bm52-tests1-linux64-build7.txt:4
> mozilla-central_ubuntu64_vm-debug_test-reftest-3-bm131-tests1-linux64-build5.txt:4
> mozilla-central_ubuntu64_vm-debug_test-reftest-2-bm118-tests1-linux64-build2.txt:4
> mozilla-central_ubuntu64_vm-debug_test-reftest-1-bm131-tests1-linux64-build5.txt:4
> mozilla-central_ubuntu64_vm-debug_test-jsreftest-bm131-tests1-linux64-build9.txt:4
> mozilla-central_ubuntu64_vm-debug_test-web-platform-tests-8-bm54-tests1-linux64-build0.txt:2
> mozilla-central_ubuntu64_vm-debug_test-web-platform-tests-7-bm116-tests1-linux64-build0.txt:2
> mozilla-central_ubuntu64_vm-debug_test-web-platform-tests-6-bm54-tests1-linux64-build1.txt:2
> mozilla-central_ubuntu64_vm-debug_test-web-platform-tests-2-bm122-tests1-linux64-build5.txt:2
> mozilla-central_ubuntu64_vm-debug_test-web-platform-tests-1-bm118-tests1-linux64-build1.txt:2

It shows up in 8205 tests. A few of the most prevalent:

> 1561 - Shutdown
> 99 - jetpack-package/addon-sdk/source/test/test-simple-prefs.js.testUnloadOfDynamicPrefGeneration
> 51 - dom/html/test/test_fullscreen-api.html
> 42 - dom/plugins/test/mochitest/test_pluginstream_err.html
> 42 - browser/components/sessionstore/test/browser_formdata_cc.js
> 40 - browser/components/privatebrowsing/test/browser/browser_privatebrowsing_windowtitle.js
> 40 - browser/base/content/test/general/browser_overflowScroll.js
> 37 - dom/manifest/test/browser_ManifestObtainer_obtain.js
> 37 - browser/base/content/test/general/browser_sanitizeDialog.js
> 36 - toolkit/components/passwordmgr/test/browser/browser_passwordmgrdlg.js

[1] https://dxr.mozilla.org/mozilla-central/rev/68c0b7d6f16ce5bb023e08050102b5f2fe4aacd8/dom/base/nsGlobalWindow.cpp#9767
Looks like the only caller is nsBaseWidget::NotifyUIStateChanged().
I'm guessing this is a regression from bug 1241764.
Blocks: 1241764
Whiteboard: [tw-dom] btpp-fixlater
We see an awful lot of these in the Thunderbird test suite.
Keywords: regression
Wayne, have you confirmed this is a regression?

Kyle, WDYT?
Flags: needinfo?(vseerror)
Flags: needinfo?(khuey)
A stack would be useful.
Flags: needinfo?(khuey)
(In reply to Andrew Overholt [:overholt] from comment #4)
> Wayne, have you confirmed this is a regression?

No, I have not. I have not tested anything. A presumption in part based on comment 2
Flags: needinfo?(vseerror)
Eric, can you provide a stack for khuey?
Flags: needinfo?(erahm)
Attached file stacks.txt
This is the log with stack dumping enabled while running:

> ./mach test dom/html/test/test_fullscreen-api.html

Is this enough info for you Kyle?
Flags: needinfo?(erahm) → needinfo?(khuey)
How is that calling GetKeyboardIndicators?
Flags: needinfo?(khuey)
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #9)
> How is that calling GetKeyboardIndicators?

Looks like maybe mach did a bad job at symbolizing the log. Results from gdb make more sense:

> Breakpoint 1, nsGlobalWindow::GetKeyboardIndicators (this=<optimized out>, aShowAccelerators=<optimized out>, 
>     aShowFocusRings=<optimized out>) at /home/erahm/dev/mozilla-central/dom/base/nsGlobalWindow.cpp:9779
> 9779        NS_WARNING("No inner window available!");
> (gdb) bt
> #0  0x00007fffea365be0 in nsGlobalWindow::GetKeyboardIndicators(bool*, bool*) (this=<optimized out>, aShowAccelerators=<optimized out>, aShowFocusRings=<optimized out>) at /home/erahm/dev/mozilla-central/dom/base/nsGlobalWindow.cpp:9779
> #1  0x00007fffea344075 in nsGlobalWindow::InitializeShowFocusRings() (this=0x7fffd4634800)
>     at /home/erahm/dev/mozilla-central/dom/base/nsGlobalWindow.cpp:9714
> #2  0x00007fffea343d82 in nsGlobalWindow::nsGlobalWindow(nsGlobalWindow*) (this=0x7fffd4634800, aOuterWindow=0x7fffd4633800)
>     at /home/erahm/dev/mozilla-central/dom/base/nsGlobalWindow.cpp:1228
> #3  0x00007fffea37797e in nsGlobalChromeWindow::nsGlobalChromeWindow(nsGlobalWindow*) (this=0x7fffd4634800, aOuterWindow=0x7fffffffb8a7)
>     at /home/erahm/dev/mozilla-central/dom/base/nsGlobalWindow.h:1932
> #4  0x00007fffea34a458 in nsGlobalChromeWindow::Create(nsGlobalWindow*) (aOuterWindow=0x7fffffffb8a7)
>     at /home/erahm/dev/mozilla-central/dom/base/nsGlobalWindow.cpp:13157
> #5  0x00007fffea348a30 in nsGlobalWindow::SetNewDocument(nsIDocument*, nsISupports*, bool) (this=0x7fffd4633800, aDocument=
>     0x7fffd46d2000, aState=0x0, aForceReuseInnerWindow=<optimized out>)
>     at /home/erahm/dev/mozilla-central/dom/base/nsGlobalWindow.cpp:2550
> #6  0x00007fffebadbf8f in nsDocumentViewer::InitInternal(nsIWidget*, nsISupports*, mozilla::gfx::IntRectTyped<mozilla::gfx::UnknownUnits> const&, bool, bool, bool) (this=0x7fffd593ad80, aParentWidget=<optimized out>, aState=0x0, aBounds=..., aDoCreation=true, aNeedMakeCX=<optimized out>, aForceSetNewDocument=<optimized out>) at /home/erahm/dev/mozilla-central/layout/base/nsDocumentViewer.cpp:874
> #7  0x00007fffebadb9e2 in nsDocumentViewer::Init(nsIWidget*, mozilla::gfx::IntRectTyped<mozilla::gfx::UnknownUnits> const&) (this=0x7fffd4633800, aParentWidget=0x7fffffffb8a7, aBounds=...) at /home/erahm/dev/mozilla-central/layout/base/nsDocumentViewer.cpp:618
> #8  0x00007fffebed7394 in nsDocShell::SetupNewViewer(nsIContentViewer*) (this=0x7fffd4633000, aNewViewer=<optimized out>)
>     at /home/erahm/dev/mozilla-central/docshell/base/nsDocShell.cpp:9251
> #9  0x00007fffebed6d44 in nsDocShell::Embed(nsIContentViewer*, char const*, nsISupports*) (this=0x7fffd4633000, aContentViewer=0x7fffd593ad80, aCommand=0x7fffffffb8a6 "", aExtraInfo=0x7fffeea55be0 <vtable for nsGlobalChromeWindow+1128>)
>     at /home/erahm/dev/mozilla-central/docshell/base/nsDocShell.cpp:7141
> #10 0x00007fffebedb401 in nsDocShell::CreateAboutBlankContentViewer(nsIPrincipal*, nsIURI*, bool) (this=0x7fffd4633000, aPrincipal=
>     0x7fff80004005, aBaseURI=0x0, aTryToSaveOldPresentation=<optimized out>)
>     at /home/erahm/dev/mozilla-central/docshell/base/nsDocShell.cpp:7971
> #11 0x00007fffebf3bc71 in nsWebShellWindow::Initialize(nsIXULWindow*, nsIXULWindow*, nsIURI*, int, int, bool, nsITabParent*, nsWidgetInitData&) (this=<optimized out>, aParent=0x6469752e6c746e69, aOpener=<optimized out>, aUrl=0x7fffd587aa00, aInitialWidth=<optimized out>, aInitialHeight=<optimized out>, aIsHiddenWindow=<optimized out>, aOpeningTab=<optimized out>, widgetInitData=...)
>     at /home/erahm/dev/mozilla-central/xpfe/appshell/nsWebShellWindow.cpp:218
> #12 0x00007fffebf3a029 in nsAppShellService::JustCreateTopWindow(nsIXULWindow*, nsIURI*, unsigned int, int, int, bool, nsITabParent*, nsWebShellWindow**) (this=<optimized out>, aParent=0x0, aUrl=0x7fffd587aa00, aChromeMask=4094, aInitialWidth=1, aInitialHeight=1, aIsHiddenWindow=<optimized out>, aOpeningTab=0x0, aResult=<optimized out>) at /home/erahm/dev/mozilla-central/xpfe/appshell/nsAppShellService.cpp:742
> #13 0x00007fffebf39c55 in nsAppShellService::CreateHiddenWindowHelper(bool) (this=0x7fffd46a3340, aIsPrivate=<optimized out>)
>     at /home/erahm/dev/mozilla-central/xpfe/appshell/nsAppShellService.cpp:140
> #14 0x00007fffec1a4752 in nsAppStartup::CreateHiddenWindow() (this=<optimized out>)
>     at /home/erahm/dev/mozilla-central/toolkit/components/startup/nsAppStartup.cpp:245
> #15 0x00007fffec200fc4 in XREMain::XRE_mainRun() (this=0x7fffffffc680)
>     at /home/erahm/dev/mozilla-central/toolkit/xre/nsAppRunner.cpp:4273
> #16 0x00007fffec201720 in XREMain::XRE_main(int, char**, nsXREAppData const*) (this=0x7fffffffc680, argc=<optimized out>, argv=<optimized out>, aAppData=<optimized out>) at /home/erahm/dev/mozilla-central/toolkit/xre/nsAppRunner.cpp:4441
> #17 0x00007fffec201c48 in XRE_main(int, char**, nsXREAppData const*, uint32_t) (argc=-18265, argv=0x7fffffffb8a6, aAppData=0x7fffeea55be0 <vtable for nsGlobalChromeWindow+1128>, aFlags=<optimized out>) at /home/erahm/dev/mozilla-central/toolkit/xre/nsAppRunner.cpp:4547
> #18 0x000000000040513e in main(int, char**, char**) (argc=5, argv=<optimized out>, envp=0x7fffffffda68, xreDirectory=<optimized out>)
>     at /home/erahm/dev/mozilla-central/browser/app/nsBrowserApp.cpp:220
> #19 0x000000000040513e in main(int, char**, char**) (argc=5, argv=<optimized out>, envp=0x7fffffffda68)
>     at /home/erahm/dev/mozilla-central/browser/app/nsBrowserApp.cpp:360
Flags: needinfo?(khuey)
Ok.  Moving the keyboard indicator/etc handling onto the outer window probably makes sense here.  I'm not going to have time to do it in the short term though.
Flags: needinfo?(khuey)
Since we're aiming for a "ship no regressions" policy, can you help mentor someone on this, Kyle?
Flags: needinfo?(khuey)
I can work on this bug.
Assignee: nobody → btian
Version: Trunk → 47 Branch
Bug 1174789 removed method |nsGlobalWindow::GetKeyboardIndicator| but similar logs as below still show on the latest m-c. I'll refer to bug 1174798 for the fix and keep checking other places printing similar logs.

===
[Child 13117] WARNING: No inner window available!: file /home/bentian/WORKSPACE/projects/gecko/central/dom/base/nsGlobalWindow.cpp, line 10026

[Parent 13039] WARNING: No inner window available!: file /home/bentian/WORKSPACE/projects/gecko/central/dom/base/nsGlobalWindow.cpp, line 9694
Whiteboard: [tw-dom] btpp-fixlater → [tw-dom] btpp-active
(In reply to Ben Tian [:btian] from comment #15)
> [Child 13117] WARNING: No inner window available!: file
> /home/bentian/WORKSPACE/projects/gecko/central/dom/base/nsGlobalWindow.cpp,
> line 10026
Callstack of above log while testing dom/html/test/test_fullscreen-api.html

Breakpoint 1, nsGlobalWindow::ShouldShowFocusRing (this=0x7fffccd34000)
    at /home/bentian/WORKSPACE/projects/gecko/central/dom/base/nsGlobalWindow.cpp:10026
10026	  FORWARD_TO_INNER(ShouldShowFocusRing, (), false);
(gdb) bt
#0  nsGlobalWindow::ShouldShowFocusRing (this=0x7fffccd34000)
    at /home/bentian/WORKSPACE/projects/gecko/central/dom/base/nsGlobalWindow.cpp:10026
#1  0x00007fffefb8324b in nsGlobalWindow::SetKeyboardIndicators (this=0x7fffccd34000, 
    aShowAccelerators=UIStateChangeType_Set, aShowFocusRings=UIStateChangeType_Set)
    at /home/bentian/WORKSPACE/projects/gecko/central/dom/base/nsGlobalWindow.cpp:10049
#2  0x00007ffff1815f8e in mozilla::dom::TabChild::Init (this=0x7fffd297dc00)
    at /home/bentian/WORKSPACE/projects/gecko/central/dom/ipc/TabChild.cpp:859
#3  0x00007ffff18146a6 in mozilla::dom::TabChild::Create (aManager=0x7fffe397e9d8, aTabId=..., aContext=..., 
    aChromeFlags=2148798462) at /home/bentian/WORKSPACE/projects/gecko/central/dom/ipc/TabChild.cpp:579
#4  0x00007ffff182ddd8 in mozilla::dom::nsIContentChild::AllocPBrowserChild (this=0x7fffe397e9d8, aTabId=..., 
    aContext=..., aChromeFlags=@0x7fffffffc940: 2148798462, aCpID=..., aIsForApp=@0x7fffffffc8b0: false, 
    aIsForBrowser=@0x7fffffffc920: false)
    at /home/bentian/WORKSPACE/projects/gecko/central/dom/ipc/nsIContentChild.cpp:61
#5  0x00007ffff17c9425 in mozilla::dom::ContentChild::AllocPBrowserChild (this=0x7fffe397e020, aTabId=..., 
    aContext=..., aChromeFlags=@0x7fffffffc940: 2148798462, aCpID=..., aIsForApp=@0x7fffffffc8b0: false, 
    aIsForBrowser=@0x7fffffffc920: false)
    at /home/bentian/WORKSPACE/projects/gecko/central/dom/ipc/ContentChild.cpp:1527
#6  0x00007fffef05af5d in mozilla::dom::PContentChild::OnMessageReceived (this=0x7fffe397e020, msg__=...)
    at /home/bentian/WORKSPACE/projects/gecko/central/obj-x86_64-pc-linux-gnu/ipc/ipdl/PContentChild.cpp:7424
#7  0x00007fffee9dc315 in mozilla::ipc::MessageChannel::DispatchAsyncMessage (this=0x7fffe397e088, aMsg=...)
    at /home/bentian/WORKSPACE/projects/gecko/central/ipc/glue/MessageChannel.cpp:1658
#8  0x00007fffee9dbe00 in mozilla::ipc::MessageChannel::DispatchMessage(IPC::Message&&) (this=0x7fffe397e088, 
    aMsg=<unknown type in /home/bentian/WORKSPACE/projects/gecko/central/obj-x86_64-pc-linux-gnu/dist/bin/libxul.so, CU 0x20e9db9, DIE 0x2186531>) at /home/bentian/WORKSPACE/projects/gecko/central/ipc/glue/MessageChannel.cpp:1596
#9  0x00007fffee9dbb26 in mozilla::ipc::MessageChannel::OnMaybeDequeueOne (this=0x7fffe397e088)
    at /home/bentian/WORKSPACE/projects/gecko/central/ipc/glue/MessageChannel.cpp:1563
#10 0x00007fffee9f93c6 in mozilla::detail::RunnableMethodArguments<>::applyImpl<mozilla::ipc::MessageChannel, bool (mozilla::ipc::MessageChannel::*)()>(mozilla::ipc::MessageChannel*, bool (mozilla::ipc::MessageChannel::*)(), mozilla::Tuple<>&, mozilla::IndexSequence<>) (o=0x7fffe397e088, 
    m=(bool (mozilla::ipc::MessageChannel::*)(mozilla::ipc::MessageChannel * const)) 0x7fffee9db9b0 <mozilla::ipc::MessageChannel::OnMaybeDequeueOne()>, args=...)
    at /home/bentian/WORKSPACE/projects/gecko/central/obj-x86_64-pc-linux-gnu/dist/include/nsThreadUtils.h:729
#11 0x00007fffee9f908a in mozilla::detail::RunnableMethodArguments<>::apply<mozilla::ipc::MessageChannel, bool (mozilla::ipc::MessageChannel::*)()>(mozilla::ipc::MessageChannel*, bool (mozilla::ipc::MessageChannel::*)()) (
    this=0x7fffe396d6b8, o=0x7fffe397e088, 
    m=(bool (mozilla::ipc::MessageChannel::*)(mozilla::ipc::MessageChannel * const)) 0x7fffee9db9b0 <mozilla::ipc::MessageChannel::OnMaybeDequeueOne()>)
    at /home/bentian/WORKSPACE/projects/gecko/central/obj-x86_64-pc-linux-gnu/dist/include/nsThreadUtils.h:736
#12 0x00007fffee9f8b5d in mozilla::detail::RunnableMethodImpl<bool (mozilla::ipc::MessageChannel::*)(), false, true>::Run (this=0x7fffe396d680)
    at /home/bentian/WORKSPACE/projects/gecko/central/obj-x86_64-pc-linux-gnu/dist/include/nsThreadUtils.h:764
#13 0x00007fffee9e7789 in mozilla::ipc::MessageChannel::RefCountedTask::Run (this=0x7fffe394b810)
    at /home/bentian/WORKSPACE/projects/gecko/central/obj-x86_64-pc-linux-gnu/dist/include/mozilla/ipc/MessageChannel.h:476
#14 0x00007fffee9e7998 in mozilla::ipc::MessageChannel::DequeueTask::Run (this=0x7fffe39b9bb0)
    at /home/bentian/WORKSPACE/projects/gecko/central/obj-x86_64-pc-linux-gnu/dist/include/mozilla/ipc/MessageChannel.h:495
#15 0x00007fffee21d9e5 in nsThread::ProcessNextEvent (this=0x7fffe228ab00, aMayWait=false, aResult=0x7fffffffce8f)
    at /home/bentian/WORKSPACE/projects/gecko/central/xpcom/threads/nsThread.cpp:1068
#16 0x00007fffee286a67 in NS_ProcessNextEvent (aThread=0x7fffe228ab00, aMayWait=false)
    at /home/bentian/WORKSPACE/projects/gecko/central/xpcom/glue/nsThreadUtils.cpp:290
#17 0x00007fffee9dff83 in mozilla::ipc::MessagePump::Run (this=0x7fffe394cd80, aDelegate=0x7fffffffd220)
    at /home/bentian/WORKSPACE/projects/gecko/central/ipc/glue/MessagePump.cpp:100
#18 0x00007fffee9e0957 in mozilla::ipc::MessagePumpForChildProcess::Run (this=0x7fffe394cd80, 
    aDelegate=0x7fffffffd220) at /home/bentian/WORKSPACE/projects/gecko/central/ipc/glue/MessagePump.cpp:317
#19 0x00007fffee95048d in MessageLoop::RunInternal (this=0x7fffffffd220)
    at /home/bentian/WORKSPACE/projects/gecko/central/ipc/chromium/src/base/message_loop.cc:235
#20 0x00007fffee950422 in MessageLoop::RunHandler (this=0x7fffffffd220)
    at /home/bentian/WORKSPACE/projects/gecko/central/ipc/chromium/src/base/message_loop.cc:228
(In reply to Ben Tian [:btian] from comment #15)
> [Child 13117] WARNING: No inner window available!: file
> /home/bentian/WORKSPACE/projects/gecko/central/dom/base/nsGlobalWindow.cpp,
> line 10026

This log only shows during TabChild::Init as comment 16. I'll confirm whether |mInnerWindow| should be nullptr then. If it's normal I'll attach a patch to remove the warning.
 
> [Parent 13039] WARNING: No inner window available!: file
> /home/bentian/WORKSPACE/projects/gecko/central/dom/base/nsGlobalWindow.cpp,
> line 9694

This log shows during GC as following. 

===
Breakpoint 1, nsGlobalWindow::GetExistingListenerManager (this=0x7fffd2421800)
    at /home/bentian/WORKSPACE/projects/gecko/central/dom/base/nsGlobalWindow.cpp:9694
9694	  FORWARD_TO_INNER(GetExistingListenerManager, (), nullptr);
(gdb) bt
#0  nsGlobalWindow::GetExistingListenerManager (this=0x7fffd2421800)
    at /home/bentian/WORKSPACE/projects/gecko/central/dom/base/nsGlobalWindow.cpp:9694
#1  0x00007fffe6facd85 in mozilla::dom::TraceBlackJS (aTrc=0x7fffdcacf5e0, aGCNumber=203, aIsShutdownGC=false)
    at /home/bentian/WORKSPACE/projects/gecko/central/dom/base/nsCCUncollectableMarker.cpp:496
#2  0x00007fffe652dfc3 in XPCJSRuntime::TraceNativeBlackRoots (this=0x7fffe0753800, trc=0x7fffdcacf5e0)
    at /home/bentian/WORKSPACE/projects/gecko/central/js/xpconnect/src/XPCJSRuntime.cpp:619
#3  0x00007fffe545d910 in mozilla::CycleCollectedJSRuntime::TraceBlackJS (aTracer=0x7fffdcacf5e0, 
    aData=0x7fffe0753800) at /home/bentian/WORKSPACE/projects/gecko/central/xpcom/base/CycleCollectedJSRuntime.cpp:788
#4  0x00007fffeb7731ef in js::gc::GCRuntime::markRuntime (this=0x7fffdcacd600, trc=0x7fffdcacf5e0, 
    traceOrMark=js::gc::GCRuntime::MarkRuntime, lock=...)
    at /home/bentian/WORKSPACE/projects/gecko/central/js/src/gc/RootMarking.cpp:343
#5  0x00007fffeb2e1b75 in js::gc::GCRuntime::beginMarkPhase (this=0x7fffdcacd600, reason=JS::gcreason::FULL_GC_TIMER, 
    lock=...) at /home/bentian/WORKSPACE/projects/gecko/central/js/src/jsgc.cpp:3910
#6  0x00007fffeb2e8d91 in js::gc::GCRuntime::incrementalCollectSlice (this=0x7fffdcacd600, budget=..., 
    reason=JS::gcreason::FULL_GC_TIMER, lock=...)
    at /home/bentian/WORKSPACE/projects/gecko/central/js/src/jsgc.cpp:5893
#7  0x00007fffeb2e9ba8 in js::gc::GCRuntime::gcCycle (this=0x7fffdcacd600, nonincrementalByAPI=false, budget=..., 
    reason=JS::gcreason::FULL_GC_TIMER) at /home/bentian/WORKSPACE/projects/gecko/central/js/src/jsgc.cpp:6181
#8  0x00007fffeb2ea108 in js::gc::GCRuntime::collect (this=0x7fffdcacd600, nonincrementalByAPI=false, budget=..., 
    reason=JS::gcreason::FULL_GC_TIMER) at /home/bentian/WORKSPACE/projects/gecko/central/js/src/jsgc.cpp:6291
#9  0x00007fffeb2ea55c in js::gc::GCRuntime::startGC (this=0x7fffdcacd600, gckind=GC_NORMAL, 
    reason=JS::gcreason::FULL_GC_TIMER, millis=0)
    at /home/bentian/WORKSPACE/projects/gecko/central/js/src/jsgc.cpp:6364
#10 0x00007fffeb2ed90c in JS::StartIncrementalGC (cx=0x7fffdcacd000, gckind=GC_NORMAL, 
    reason=JS::gcreason::FULL_GC_TIMER, millis=0)
    at /home/bentian/WORKSPACE/projects/gecko/central/js/src/jsgc.cpp:7245
#11 0x00007fffe70a7181 in nsJSContext::GarbageCollectNow (aReason=JS::gcreason::FULL_GC_TIMER, 
    aIncremental=nsJSContext::IncrementalGC, aShrinking=nsJSContext::NonShrinkingGC, aSliceMillis=0)
    at /home/bentian/WORKSPACE/projects/gecko/central/dom/base/nsJSEnvironment.cpp:1223
#12 0x00007fffe70a6fec in FullGCTimerFired (aTimer=0x7fffc99fd660, aClosure=0x0)
    at /home/bentian/WORKSPACE/projects/gecko/central/dom/base/nsJSEnvironment.cpp:1175
#13 0x00007fffe554ab6a in nsTimerImpl::Fire (this=0x7fffc99fd660)
    at /home/bentian/WORKSPACE/projects/gecko/central/xpcom/threads/nsTimerImpl.cpp:524
#14 0x00007fffe55237ab in nsTimerEvent::Run (this=0x7fffd33600c8)
    at /home/bentian/WORKSPACE/projects/gecko/central/xpcom/threads/TimerThread.cpp:286
#15 0x00007fffe55296eb in nsThread::ProcessNextEvent (this=0x7ffff6b7b500, aMayWait=false, aResult=0x7fffffffc08f)
    at /home/bentian/WORKSPACE/projects/gecko/central/xpcom/threads/nsThread.cpp:1068
#16 0x00007fffe559276d in NS_ProcessNextEvent (aThread=0x7ffff6b7b500, aMayWait=false)
    at /home/bentian/WORKSPACE/projects/gecko/central/xpcom/glue/nsThreadUtils.cpp:290
#17 0x00007fffe5cebc89 in mozilla::ipc::MessagePump::Run (this=0x7fffe218dc00, aDelegate=0x7ffff6b426e0)
(In reply to Ben Tian [:btian] from comment #17)
> This log only shows during TabChild::Init as comment 16. I'll confirm
> whether |mInnerWindow| should be nullptr then. If it's normal I'll attach a
> patch to remove the warning.

*remove the warning when TabChild::Init calls into the function.
(In reply to Ben Tian [:btian] from comment #17)
> This log only shows during TabChild::Init as comment 16. I'll confirm
> whether |mInnerWindow| should be nullptr then. If it's normal I'll attach a
> patch to remove the warning.

|mInnerWindow| becomes non-nullptr once it's assigned in [1] after TabChild::Init.

[1] https://dxr.mozilla.org/mozilla-central/source/dom/base/nsGlobalWindow.cpp#2826

Attached WIP patch removes warning below by skipping ShouldShowFocusRing check.

> [Child 13117] WARNING: No inner window available!: file
> /home/bentian/WORKSPACE/projects/gecko/central/dom/base/nsGlobalWindow.cpp,
> line 10026
Change:
- rename |InitKeyboardIndicators| to |SetInitialKeyboardIndicators|.
Attachment #8771262 - Attachment is obsolete: true
(In reply to Ben Tian [:btian] from comment #20)
> WIP Patch (v2): Remove "no inner window" warning during TabChild::Init() by
> skipping ShouldShowFocusRing check

The following shows remaining and reduced # of "no inner window" warning, with attached patch, on the most prevalent tests in comment 1:

> 2 (-42) - dom/html/test/test_fullscreen-api.html
> 0 (-30) - dom/plugins/test/mochitest/test_pluginstream_err.html
> 0 (-84) - browser/components/sessionstore/test/browser_formdata_cc.js
> 2 (-34) - browser/components/privatebrowsing/test/browser/browser_privatebrowsing_windowtitle.js
> 0 (-80) - browser/base/content/test/general/browser_overflowScroll.js
> 0 (-76) - dom/manifest/test/browser_ManifestObtainer_obtain.js
> 0 (-4) - browser/base/content/test/general/browser_sanitizeDialog.js
> 0 (-4) - toolkit/components/passwordmgr/test/browser/browser_passwordmgrdlg.js
Comment on attachment 8771329 [details] [diff] [review]
Patch 1 (v2): Remove "no inner window" warning during TabChild::Init() by skipping ShouldShowFocusRing check

Kyle,

Can you review my patch that removes "no inner window" warning during TabChild::Init by skipping |ShouldShowFocusRing| check?

Bug 1174798 change removed comment 1 warning but other ones remain as comment 15. This patch removes the more frequent one with comment 16 call stack, and comment 21 lists reduced # of warning on comment 1 tests. 

Try result is in
https://treeherder.mozilla.org/#/jobs?repo=try&revision=2c253a9322ec
Attachment #8771329 - Attachment description: WIP Patch (v2): Remove "no inner window" warning during TabChild::Init() by skipping ShouldShowFocusRing check → Patch 1 (v2): Remove "no inner window" warning during TabChild::Init() by skipping ShouldShowFocusRing check
Attachment #8771329 - Flags: review?(khuey)
Why is skipping the check ok?
Flags: needinfo?(btian)
Comment on attachment 8771329 [details] [diff] [review]
Patch 1 (v2): Remove "no inner window" warning during TabChild::Init() by skipping ShouldShowFocusRing check

Review of attachment 8771329 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/base/nsGlobalWindow.cpp
@@ +3695,5 @@
> +void
> +nsPIDOMWindowOuter::SetInitialKeyboardIndicators(
> +  UIStateChangeType aShowAccelerators, UIStateChangeType aShowFocusRings)
> +{
> +  MOZ_ASSERT(IsOuterWindow());

Please add an assertion that we do *not* have an inner window here.
Attachment #8771329 - Flags: review?(khuey) → review+
As :btian explained to me in person, if we trigger the warning, then the function returned false.
Flags: needinfo?(btian)
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ca723ddedfe5
Remove "no inner window" warning during TabChild::Init() by skipping ShouldShowFocusRing check. r=khuey
Keywords: checkin-needed
So just to sum up previous comments, it looks like this bug has morphed into |nsGlobalWindow::ShouldShowFocusRing| spewing warnings -- |nsGlobalWindow::GetKeyboardIndicator| seems okay (in the not in my top 10 warnings sense) -- and is by far the most verbose warning during testing. Here's the full report:

> 23806 WARNING: No inner window available!: file dom/base/nsGlobalWindow.cpp, line 10026

This warning [1] shows up in the following test suites:

>   1604 - desktop-test-linux64/debug-mochitest-browser-chrome-e10s-7 bc7
>   1546 - desktop-test-linux64/debug-web-platform-tests-e10s-7 7
>   1506 - desktop-test-linux64/debug-web-platform-tests-e10s-1 1
>   1416 - desktop-test-linux64/debug-mochitest-browser-chrome-e10s-6 bc6
>   1406 - desktop-test-linux64/debug-mochitest-browser-chrome-e10s-3 bc3
>   1394 - desktop-test-linux64/debug-web-platform-tests-e10s-8 8
>   1292 - desktop-test-linux64/debug-mochitest-browser-chrome-e10s-4 bc4
>   1266 - desktop-test-linux64/debug-web-platform-tests-e10s-4 4
>   1260 - desktop-test-linux64/debug-web-platform-tests-e10s-5 5
>   1206 - desktop-test-linux64/debug-web-platform-tests-e10s-9 9
>   1134 - desktop-test-linux64/debug-web-platform-tests-e10s-3 3
>   1030 - desktop-test-linux64/debug-mochitest-browser-chrome-e10s-2 bc2
>   1028 - desktop-test-linux64/debug-web-platform-tests-e10s-2 2
>   1022 - desktop-test-linux64/debug-mochitest-browser-chrome-e10s-1 bc1
>    932 - desktop-test-linux64/debug-web-platform-tests-reftests-e10s Wr
>    882 - desktop-test-linux64/debug-mochitest-browser-chrome-e10s-5 bc5
>    504 - desktop-test-linux64/debug-web-platform-tests-e10s-11 11
>    498 - desktop-test-linux64/debug-web-platform-tests-e10s-12 12
>    346 - desktop-test-linux64/debug-web-platform-tests-e10s-6 6
>    268 - desktop-test-linux64/debug-mochitest-clipboard-e10s cl
>    268 - desktop-test-linux64/debug-mochitest-e10s-1 1
>    238 - desktop-test-linux64/debug-mochitest-e10s-5 5
>    222 - desktop-test-linux64/debug-web-platform-tests-e10s-10 10
>    190 - desktop-test-linux64/debug-mochitest-e10s-3 3
>    146 - desktop-test-linux64/debug-mochitest-e10s-9 9
>    128 - desktop-test-linux64/debug-mochitest-2 2
>    126 - desktop-test-linux64/debug-mochitest-e10s-8 8
>    126 - desktop-test-linux64/debug-mochitest-e10s-10 10
>    108 - desktop-test-linux64/debug-mochitest-e10s-7 7
>     74 - desktop-test-linux64/debug-mochitest-browser-chrome-5 bc5
>     64 - desktop-test-linux64/debug-firefox-ui-functional-local-e10s en-US
>     62 - desktop-test-linux64/debug-mochitest-e10s-4 4
>     58 - desktop-test-linux64/debug-mochitest-e10s-2 2
>     56 - desktop-test-linux64/debug-mochitest-e10s-6 6
>     52 - desktop-test-linux64/debug-mochitest-chrome-1 c1
>     50 - desktop-test-linux64/debug-firefox-ui-functional-remote-e10s en-US
>     32 - desktop-test-linux64/debug-mochitest-gpu-e10s gpu
>     32 - desktop-test-linux64/debug-mochitest-4 4
>     28 - desktop-test-linux64/debug-mochitest-browser-chrome-2 bc2
>     26 - desktop-test-linux64/debug-mochitest-chrome-3 c3
>     24 - desktop-test-linux64/debug-mochitest-media-e10s mda
>     16 - desktop-test-linux64/debug-mochitest-5 5
>     10 - desktop-test-linux64/debug-mochitest-webgl-e10s gl
>      8 - desktop-test-linux64/debug-mochitest-8 8
>      8 - desktop-test-linux64/debug-crashtest-e10s C
>      8 - desktop-test-linux64/debug-mochitest-clipboard cl
>      8 - desktop-test-linux64/debug-mochitest-browser-chrome-6 bc6
>      6 - desktop-test-linux64/debug-mochitest-chrome-2 c2
>      6 - desktop-test-linux64/debug-mochitest-browser-chrome-3 bc3
>      6 - desktop-test-linux64/debug-mochitest-3 3
>      6 - desktop-test-linux64/debug-mochitest-10 10
>      4 - desktop-test-linux64/debug-jsreftest-e10s-1 J1
>      4 - desktop-test-linux64/debug-reftest-e10s-5 R5
>      4 - desktop-test-linux64/debug-reftest-no-accel-e10s-1 Ru1
>      4 - desktop-test-linux64/debug-reftest-no-accel-e10s-8 Ru8
>      4 - desktop-test-linux64/debug-reftest-e10s-4 R4
>      4 - desktop-test-linux64/debug-reftest-e10s-6 R6
>      4 - desktop-test-linux64/debug-reftest-no-accel-e10s-3 Ru3
>      4 - desktop-test-linux64/debug-reftest-e10s-7 R7
>      4 - desktop-test-linux64/debug-reftest-e10s-2 R2
>      4 - desktop-test-linux64/debug-reftest-e10s-3 R3
>      4 - desktop-test-linux64/debug-reftest-no-accel-e10s-7 Ru7
>      4 - desktop-test-linux64/debug-reftest-no-accel-e10s-5 Ru5
>      4 - desktop-test-linux64/debug-jsreftest-e10s-2 J2
>      4 - desktop-test-linux64/debug-reftest-e10s-8 R8
>      4 - desktop-test-linux64/debug-reftest-e10s-1 R1
>      4 - desktop-test-linux64/debug-reftest-no-accel-e10s-4 Ru4
>      4 - desktop-test-linux64/debug-reftest-no-accel-e10s-6 Ru6
>      4 - desktop-test-linux64/debug-reftest-no-accel-e10s-2 Ru2
>      2 - desktop-test-linux64/debug-mochitest-1 1

It shows up in 8073 tests. A few of the most prevalent:

>    694 - [e10s] Shutdown
>     96 - [e10s] dom/tests/mochitest/bugs/test_bug260264.html
>     84 - [e10s] browser/components/sessionstore/test/browser_formdata_cc.js
>     78 - [e10s] browser/base/content/test/general/browser_overflowScroll.js
>     74 - [e10s] dom/manifest/test/browser_ManifestObtainer_obtain.js
>     56 - [e10s] browser/components/sessionstore/test/browser_615394-SSWindowState_events.js
>     54 - [e10s] toolkit/mozapps/extensions/test/browser/browser_discovery.js
>     54 - [e10s] browser/base/content/test/referrer/browser_referrer_middle_click_in_container.js
>     52 - [e10s] browser/components/sessionstore/test/browser_522545.js
>     50 - [e10s] browser/base/content/test/referrer/browser_referrer_middle_click.js

[1] https://hg.mozilla.org/mozilla-central/annotate/f44bb9de08ad/dom/base/nsGlobalWindow.cpp#l10026
Summary: 15,400 instances of "No inner window available!" emitted from dom/base/nsGlobalWindow.cpp during linux64 debug testing → 23,800 instances of "No inner window available!" emitted from dom/base/nsGlobalWindow.cpp during linux64 debug testing
(In reply to Wes Kocher (:KWierso) from comment #28)
> This seems to have caused android crashes, backed out in
> https://hg.mozilla.org/integration/mozilla-inbound/rev/b4d52dc84179
> https://treeherder.mozilla.org/logviewer.html#?job_id=32237465&repo=mozilla-
> inbound#L2343

I'm investigating the android crash. Still figuring how to run mochitest on Android emulator with gdb for call stack.
(In reply to Ben Tian [:btian] from comment #30)
> (In reply to Wes Kocher (:KWierso) from comment #28)
> > This seems to have caused android crashes, backed out in
> > https://hg.mozilla.org/integration/mozilla-inbound/rev/b4d52dc84179
> > https://treeherder.mozilla.org/logviewer.html#?job_id=32237465&repo=mozilla-
> > inbound#L2343

The crash seems to result from the MOZ_ASSERT of no inner window added in comment 26, since [1] with the assertion has no crash. The comment 22 try result [2] before the change also matches the finding.

[1] https://treeherder.mozilla.org/#/jobs?repo=try&revision=be77d82ffa78&selectedJob=24591353
[2] https://treeherder.mozilla.org/#/jobs?repo=try&revision=2c253a9322ec&selectedJob=24022859

Next I'll check whether method |GetCurrentInnerWindow| is suitable here or |mInnerWindow| is non-nullpter then. If the latter the patch may require further revision.
(In reply to Ben Tian [:btian] from comment #31)
> > > https://treeherder.mozilla.org/logviewer.html#?job_id=32237465&repo=mozilla-
> > > inbound#L2343
> Next I'll check whether method |GetCurrentInnerWindow| is suitable here or
> |mInnerWindow| is non-nullpter then. If the latter the patch may require
> further revision.

|mInnerWindow| is non-nullpter during TabChild:;Init on Fennec, as the warning msg shows only on linux64 debug testing. A try with quick build flag hack is running to verify.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=55e45cac991b
Change:
- skip ShouldShowFocusRing check only if |mInnerWindow| is nullptr
Attachment #8772691 - Attachment is obsolete: true
Comment on attachment 8775841 [details] [diff] [review]
[final] Patch 1: Skip ShouldShowFocusRing check during TabChild::Init() if no inner window is available, r=khuey

Kyle,

Can you review my updated patch to solve comment 28 crash on Fennec debug build? The patch skips ShouldShowFocusRing check during TabChild::Init() ONLY if |mInnerWindow| is nullptr. So Fennec doesn't skip the check but linux64 does per comment 31 and comment 32. 

Try result is in https://treeherder.mozilla.org/#/jobs?repo=try&revision=a0290fbf2e33
Flags: needinfo?(btian)
Attachment #8775841 - Flags: review?(khuey)
Attachment #8775841 - Attachment description: Patch 1 (v4): Skip ShouldShowFocusRing check during TabChild::Init() if no inner window is available → [final] Patch 1: Skip ShouldShowFocusRing check during TabChild::Init() if no inner window is available, r=khuey
Keywords: checkin-needed
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2b634a956b26
Skip ShouldShowFocusRing check during TabChild::Init() if no inner window is available. r=khuey
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/2b634a956b26
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
Whiteboard: [tw-dom] btpp-active → [tw-dom] btpp-close
Thank you very much Ben :)

In case you didn't know that, we are deprecating btpp-* whiteborad, and have a plan to map btpp-* into priorities. https://wiki.mozilla.org/Platform/DOM_Bug_Triage
Hi Ben,
Since this bug is a regression and also affects 49/50, do you want to uplift this for 49/50 if this patch is not too risky?
Flags: needinfo?(btian)
I suggest no need to uplift, as the linux64-debug-only log spam has no user impact.
Flags: needinfo?(btian)
Since there is no user impact, it's just a log spam. Let's let it ride the train on 51. Mark 48/49/50 as won't fix.
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.