Closed Bug 12630 Opened 21 years ago Closed 21 years ago

Note: This may be bug 12475! "submit" and "preview" buttons for talkback don't trigger action -M9 on Linux

Categories

(Core :: Layout: Form Controls, defect, P3)

x86
Linux
defect

Tracking

()

VERIFIED DUPLICATE of bug 12729

People

(Reporter: dinotrac, Assigned: harishd)

References

()

Details

Attachments

(1 file)

Using Milestone 9 on a (mostly) Debian 2.2.9 AMD-k6 with 64 mb of ram.
When trying to submit or preview a response to a Linux Today article
, I can depress the submit or preview button and they will visually appear to go
down and up, but nothing appears to get submitted.  I sit and wait -- nothing
happens.

Actually entering the talkback is great : it works well, is snappy, wraps
correctly.  I especially like those silly little "wraparound arrows" at the end
of a wrapped line.
Summary: "submit" and "preview" buttons for talkback don't trigger action -M9 on Linux → Note: This may be bug 12475! "submit" and "preview" buttons for talkback don't trigger action -M9 on Linux
When I submitted this bug, I missed bug 12475 in "known editor issues".  I
couldn't get to the page referenced in that bug description, but I suspect that
bug isn't fixed and that this shouldn't be reported as a new bug.

Note: of the choices on the screen, it appeared that marking it as duplicate of
but 12475 would mark it fixed, thus failing to leave any bug open (so it
appears).  What is the right way to handle this?
Assignee: karnaze → kmcclusk
Reassign to Kevin.
Status: NEW → ASSIGNED
Assignee: kmcclusk → pollmann
Status: ASSIGNED → NEW
Eric, reassigning to you. Please check the post data from mozilla against the
post data generated from communicator. If different, reassign back to me.
Attached file Reduced test case
Assignee: pollmann → harishd
Harish, can you check this out:

When I have a form like this, I get a content model that corresponds:
<FORM>        form<
 <INPUT>       input<>
</FORM>       >

But if I open up a <P> tag before the form closes, the form no longer contains
it's children:
<FORM>        form<>
 <INPUT>      input<>
 <P>          p<>
</FORM>

This is the source of this bug, as when a submit can not find it's parent form,
it will not submit the form.  (nsGfxButtonControlFrame::MouseClicked checks for
mFormFrame != nsnull which is failing)

Can we close all open <P> tags when a form ends?
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 12729 ***
Status: RESOLVED → VERIFIED
verified dup
You need to log in before you can comment on or make changes to this bug.