Closed Bug 12631 Opened 21 years ago Closed 20 years ago

Displays tables wrong

Categories

(Core :: DOM: HTML Parser, defect, P3, minor)

x86
Other
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: Rob.Hagopian, Assigned: harishd)

References

()

Details

(Whiteboard: [TESTCASE])

Attachments

(1 file)

The "In other news" column appears below the main story instead of to the right.
Attached file testcase
Whiteboard: [TESTCASE]
I made a testcase for another bug which turned out to be duplicate of this one
(bug 12769 - problem with http://www.salon.com), so here is one more testcase:
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=1454
Is this bug a dup of bug # 13099?  The components are marked as different, but
the problems look to be the same.

I will let the experts decide what the component is the problem, but it looks
like one could be resolved to the other.
Assignee: karnaze → rickg
Component: HTMLTables → Parser
QA Contact: chrisd → janc
*** Bug 13099 has been marked as a duplicate of this bug. ***
*** Bug 13696 has been marked as a duplicate of this bug. ***
Assignee: rickg → karnaze
Assignee: karnaze → harishd
Harish, the parser is putting the relevant text outside the table. Here is the
content model.

  body refcount=3<
    Text refcount=3<\n\n\n\n>
    p refcount=3<
      Text refcount=3<\n>
      table border=1 refcount=6<
        tbody refcount=3<
          tr refcount=3<
            td width=700 refcount=4<
              Text refcount=3<This testcase is distilled from\n     >
              a href=http://www.cnn.com refcount=3<
                Text refcount=3<http://www.cnn.com>
              >
              Text refcount=4<.\n     It shows that error correction is differen
t compared to older browsers.\n     The content looks like this:\n>
              pre refcount=3<
                Text refcount=7<<P>\n<TABLE>\n</P> <!-- misplaced P end tag -->\
nMission Mir timeline\n</TABLE>\n>
              >
              Text refcount=3<\nNetscape 3.04 and 4.61, and IE4 all display "Mis
sion Mir timeline" within the table.>
              br refcount=3<>
              Text refcount=3<\nApprunner nightly build 1999-08-26-17-M10 displa
y it outside.\n\n>
            >
          >
        >
      >
    >
    Text refcount=3< >
    Comment refcount=2<!-- bogus P end tag -->
    Text refcount=3<\n\n  Mission Mir timeline\n>
    table refcount=4<
    >
    Text refcount=3<\n\n\n>
  >
>
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Fix is in.

Mrking bug FIXED.
updated qa contact.
QA Contact: janc → bsharma
Verified on:
build: 2001-05-21-11-Mtrunk
platform: WinNT

The test case and the cnn web page displays fine.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.