Closed Bug 1263138 Opened 7 years ago Closed 7 years ago

Sometimes scroll is not working on page after restarting the browser with "Always restore tabs" enabled

Categories

(Firefox for Android Graveyard :: Toolbar, defect)

46 Branch
ARM
Android
defect
Not set
normal

Tracking

(firefox45 affected, firefox46 affected, firefox47 unaffected)

RESOLVED DUPLICATE of bug 1259735
Tracking Status
firefox45 --- affected
firefox46 --- affected
firefox47 --- unaffected

People

(Reporter: cos_flaviu, Unassigned)

Details

Attachments

(1 file)

Environment: 
Device: Nexus 5 (Android 6.0.1);
Builds: Release 45.0.2 and 46 Beta 8;

Steps to reproduce:
1. Launch fennec;
2. Go to settings and enable "Always restore tabs";
3. Open a few pages in different tabs;
4. Restart fennec;
5. After the page is fully loaded scroll the page.

Expected result:
Scroll works fine.

Actual result:
Scroll is not working on page after restarting the browser.

Notes:

Please check the attached logs.

Please check the following video:
https://youtu.be/e7TU384aONA
^ The video is private. However this might be a dupe of bug 1259735. If you run into this, try rotating the phone and see if that fixes it. If so it's probably a dupe.
My bad, I forgot to make the video public. Please check again now.
Thanks. Yeah, it does look a lot like bug 1259735. Opening the URL bar and going back will trigger a full layout/repaint which fixes the problem, same as an orientation change would. I'm going to close it as a dupe but we should verify this once that patch is uplifted.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.