Closed Bug 1263154 Opened 4 years ago Closed 4 years ago

pdf doesnt print correctly in browser

Categories

(Firefox :: PDF Viewer, defect)

45 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 47
Tracking Status
firefox45 --- wontfix
firefox46 --- wontfix
firefox47 + fixed
firefox48 --- fixed
firefox-esr45 --- affected

People

(Reporter: k.wiesjahn, Unassigned)

References

Details

(Keywords: regression, Whiteboard: checking-needed for ff47 "Avoid applying transform twice during PDF printing" patch)

Attachments

(3 files)

Attached file print_pdf.zip
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160315153207

Steps to reproduce:

opened pdf file in firefox browser and printed directly


Actual results:

only one quarter (left upper corner) printed



Expected results:

complete page (worked perfectly with older versions of firefox)
Could you provide the PDF document (link or attachment), please.
Flags: needinfo?(k.wiesjahn)
(In reply to Loic from comment #1)
> Could you provide the PDF document (link or attachment), please.

http://brillen.de/partner/upload/msteiner/Einst_aktiv.pdf
Flags: needinfo?(k.wiesjahn)
How do you print it? With a physical printer or virtual printer (like PDF Creator or MS Document XPS Writer).
Nevermind, I'm able to reproduce the issue with a virtual printer.
Attached file Einst_aktiv_print.pdf
It's a reression but I can't reproduce with FF48:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=3e04659fdf6aef792f7cf9840189c6c38d08d1e8&tochange=3d37c7e5b8dd28a4a017e2296e824619f9379b88

So it has been already fixed, probably by bug 1256037.
Status: UNCONFIRMED → NEW
Component: Untriaged → PDF Viewer
Depends on: 1256037
Ever confirmed: true
Keywords: regression
This sounds bad. Is there a backportable fix we could land on 46/47 for this? Possibly ESR45 as well.
Too late for 46. I commented in bug 1263154 to ask if uplifting to 47 seems reasonable.
Aurora47 is currently on version 1.4.121, which was the the update prior to this one. So backporting bug 1256037 probably wouldn't be a big deal. I don't see any major issues caused by the 1.4.137 update in Bugzilla anyway. And actually, we'd probably want to take version 1.4.185 from bug 1261352 instead since it contains e10s fixes. Yury, since Brendan is on PTO, what's your take?
Flags: needinfo?(bdahl) → needinfo?(ydelendik)
Jonas, I'd welcome your thoughts as well here as well :)
Flags: needinfo?(jonas.jenwald)
The https://github.com/mozilla/pdf.js/commit/069f4b9bdf8a43a336f1650c5806ec41c3154f2e fixes the issue.

The patch is trivial and affects only certain PDF documents. Liz, would you like me to prepare the uplift for ff46/beta (along with ff47 one) as well?
Flags: needinfo?(jonas.jenwald) → needinfo?(lhenry)
It's very last minute for 46; I think we should stick with possibly uplifting to 47 here.
Flags: needinfo?(lhenry)
Approval Request Comment
[Feature/regressing bug #]: bug 1226621
[User impact if declined]: some PDF may not print properly
[Describe test coverage new/current, TreeHerder]: the patch is present on m-c
[Risks and why]: low, affects PDF printing and only documents generated by specific generators
[String/UUID change made/needed]: none
Flags: needinfo?(ydelendik)
Attachment #8742990 - Flags: approval-mozilla-aurora?
Comment on attachment 8742990 [details] [diff] [review]
Avoid applying transform twice during PDF printing (ff47)

Based on comment 6 this is already fixed in Nightly, let's uplift this fix to Aurora47.
Attachment #8742990 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
r=me
Keywords: checkin-needed
Whiteboard: checking-needed for ff47 "Avoid applying transform twice during PDF printing" patch
landed as https://hg.mozilla.org/releases/mozilla-aurora/rev/4e0ea7414288
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 47
QA Whiteboard: [good first verify]
I have reproduced this bug with nightly 48.0a1 (2016-04-08) on Windows 10, 64 bit!

The Bug's fix is now verified on Release 47.0 and Beta 48.0b6.

Firefox 47.0
Build ID 	20160604131506
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:47.0) Gecko/20100101 Firefox/47.0

Beta 48.0b6
Build ID 	20160706215822
User Agent 	Mozilla/5.0 (Windows NT 10.0; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0

 [bugday-20160713]
You need to log in before you can comment on or make changes to this bug.