Closed Bug 1263241 Opened 5 years ago Closed 5 years ago

Firefox crashing when directed to cloudfront URLS

Categories

(Core :: Audio/Video: Playback, defect)

45 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1236639

People

(Reporter: william.staves, Unassigned)

References

()

Details

(Keywords: crash)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.110 Safari/537.36

Steps to reproduce:

in firefox open this URL https://don1uexbbetbo.cloudfront.net/content/mp3s/uncertain_elections_2016.mp3

originally I was debugging it on this page https://conversations.wfmagazines.com/podcast/2016_elections_create_uncertainty which works on other browsers, then I realized it was something about trying to view mp3 files from cloudfront. 

(I checked the mimetypes too, they are correctly set to audio/mpeg)


Actual results:

Firefox immediately crashes and the bug report app launches


Expected results:

should show the audio player, should be able to display https://conversations.wfmagazines.com/podcast/2016_elections_create_uncertainty without crashing
Keywords: crash
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core
It's a dupe of bug 1236639 which is fixed in 46+.
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0f363ae95dc90d593394ef464aa500804c824962&tochange=c33f30666b37dbceffb9fbe5089a668db8893a85
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1236639
Filed bug 1263334 for remaining issue.
You need to log in before you can comment on or make changes to this bug.