Pref dialog needs up to 10s to open

RESOLVED WORKSFORME

Status

SeaMonkey
Preferences
RESOLVED WORKSFORME
17 years ago
4 years ago

People

(Reporter: BenB, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({perf, regression})

Trunk
x86
Linux
perf, regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I recently switched from 0.9.4.1 to the trunk / 0.9.8 and noticed that opeing
the pref dialog got a lot slower, by about a factor of 10. In 0.9.4.1, it took
less than a second. Now, it takes, when I'm lucky 1.5 - 2 second, much longer
otherwise. 3-4s are pretty common, in one case it took about 10s to open the
dialog! I have never seen this with 0.9.4.1.

Note that I am using a fast machine (Athlon 1.2GHz, 1 GB RAM).

sairuh's perf test don't show anything like that. The results (1-2s on that
machine) seem unchanged since long.
(Reporter)

Updated

17 years ago
Keywords: mozilla1.0, perf, regression

Comment 1

17 years ago
Do you have a large prefs.js file?  Is there anything possibly unique about your
prefs.js file?  Do you observe the same perf hit with a new profile?
(Reporter)

Comment 2

17 years ago
My pref.js is 44k large and has a lot of Mailnews accounts.
(This is no different from 0.9.4.1.)

A new profile seems a bit faster. But maybe it's just normal derivation.

I don't build the help extension (giving me an error on the console).
i haven't seen the pref window open take as long as 10sec [ouch!]. but the
current performance has been kinda up'n'down of late. my results [and test
methodology] are at http://mozilla.org/quality/perf/preferences/index.html
(Reporter)

Updated

17 years ago
Summary: Pref dialog needs to up 10s to open → Pref dialog needs up to 10s to open

Comment 4

16 years ago
-> Default owner
Assignee: sgehani → ben
(Reporter)

Comment 5

15 years ago
fixed by now, I think.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.