Closed Bug 1263358 Opened 4 years ago Closed 3 months ago

IndexError: list index out of range

Categories

(Testing :: mozregression, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1567259

People

(Reporter: Oriol, Unassigned, NeedInfo)

Details

(Keywords: reproducible)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160408030212

Steps to reproduce:

Run a bisection with all defaults, between 2012-12-09 and 2012-12-10.


Actual results:

Error:

    platform: Windows-10-10.0.10586
    python: 2.7.11 FROZEN (32bit)
    mozregui: 0.9.2
    mozregression: 2.3.2
    message: IndexError: list index out of range
    traceback:   File ".\mozregui\bisection.py", line 72, in bisect_further
      File "..\mozregression\bisector.py", line 561, in bisect
      File "..\mozregression\build_range.py", line 293, in range_for_inbounds
      File "..\mozregression\build_range.py", line 198, in check_expand
      File "..\mozregression\build_range.py", line 238, in get_future



Expected results:

No error.

Version: 0.9.2
Using mozregression version: 2.3.2
Still reproducible both with mozregui 0.9.17
and mozregression 2.3.21

Updated error:

platform: Windows-7-6.1.7601-SP1
python: 2.7.14 FROZEN (32bit)
mozregui: 0.9.17
mozregression: 2.3.21
message: IndexError: list index out of range
traceback:   File ".\mozregui\bisection.py", line 72, in bisect_further
  File "..\mozregression\bisector.py", line 585, in bisect
  File "..\mozregression\build_range.py", line 293, in range_for_inbounds
  File "..\mozregression\build_range.py", line 198, in check_expand
  File "..\mozregression\build_range.py", line 238, in get_future


It's also reproducible with 2016-12-12 and 2016-12-13
but the error stack is different:

platform: Windows-7-6.1.7601-SP1
python: 2.7.14 FROZEN (32bit)
mozregui: 0.9.17
mozregression: 2.3.21
message: IndexError: list index out of range
traceback:   File ".\mozregui\bisection.py", line 82, in check_merge
  File "..\mozregression\bisector.py", line 263, in handle_merge
  File "..\mozregression\build_range.py", line 94, in __getitem__


With mozregression (command line version), with the 2016-12-12 to 2016-12-13 range, it finishes with:

 1:31.11 INFO: Expanding higher limit of the range to fe17931bfd5f
 1:37.58 WARNING: Skipping build 3c9a0a6cdfff: Unable to find build info using the taskcluster route 'gecko.v2.mozilla-central.revision.3c9a0a6cdfff95eaa1c851344e898b3b15d55609.firefox.win64-opt'
 1:38.53 WARNING: Skipping build 4ee7b6591cf4: Unable to find build info using the taskcluster route 'gecko.v2.mozilla-central.revision.4ee7b6591cf4128098225651e734dbf04eef57bb.firefox.win64-opt'
 1:38.55 INFO: No more inbound revisions, bisection finished.
 1:38.55 INFO: Last good revision: fe17931bfd5f0658a94f40a71b0463cfa1e03c6c
 1:38.55 INFO: First bad revision: fe17931bfd5f0658a94f40a71b0463cfa1e03c6c
 1:38.56 INFO: Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?changeset=fe17931bfd5f0658a94f40a71b0463cfa1e03c6c

 1:38.56 WARNING: It seems that you used two changesets that are in in the same push. Check the pushlog url.

(with a wrong pushlog)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: reproducible
Summary: Bisection on Mozregression-gui throws IndexError: list index out of range → IndexError: list index out of range
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1567259

Note: the TreeHerder logs in comment 2 and comment 3 are unrelated to this bug -- they're some other Python script that happens to also hit a IndexError: list index out of range error message.

Aryx, do you know if there's anything that needs to be done to prevent such mis-linking from TreeHerder? I notice this bug doesn't have the "intermittent-failure" keyword, so I'm not sure why it would've been showing up as a suggestion in the TreeHerder UI.

(Maybe it wasn't showing up as a suggestion, and it was just linked due to humans doing a manual bugzilla search and manually entering its bug number into the TreeHerder bug-starring UI? If so, then perhaps there's not much we can do about that besides educating sheriffs & trying to make bug titles more specific.)

Flags: needinfo?(aryx.bugmail)
You need to log in before you can comment on or make changes to this bug.