Closed Bug 1263396 Opened 4 years ago Closed 4 years ago

When inside of reader mode for a Medium article: after you've gone Back & Forward, subsequent "Back" clicks will just refresh the page

Categories

(Toolkit :: Reader Mode, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1263628
Tracking Status
firefox48 --- affected

People

(Reporter: dholbert, Unassigned)

References

Details

Attachments

(1 file)

STR:
 1. Visit https://medium.com/frog-and-toad-are-cofounders
 2. Click some article, e.g. "Project Management" "Toad Gets Organized" which is currently the first one.
 3. Click the Reader Mode icon. [enter Reader Mode]
 4. Click back button.  [leave Reader Mode]
 5. Click forward button. [reenter Reader Mode]
 6. Click back button.

EXPECTED RESULTS:
I should be taken out of Reader Mode, the same as happened in step 4.

ACTUAL RESULTS:
The page just reloads.

(I think this might have to do with some redirect that Medium performs after you load a page, to add a # with a suffix onto the URL.)
Summary: When inside of reader mode for a Medium article, clicking "Back" may not actually take you back anywhere → When inside of reader mode for a Medium article, after you've gone Back & Forward, subsequent "Back" clicks will just refresh the page
Attachment #8739693 - Attachment description: screencast of bug → screencast of bug ("back" button is broken -- won't navigate back -- from 15 seconds onward)
I'm using Firefox Nightly, 48.0a1 (2016-04-09) on Ubuntu Linux.
I can reproduce in current release, too (Firefox 45.0.1).  So, this is not necessarily a regression.
Summary: When inside of reader mode for a Medium article, after you've gone Back & Forward, subsequent "Back" clicks will just refresh the page → When inside of reader mode for a Medium article: after you've gone Back & Forward, subsequent "Back" clicks will just refresh the page
(Note that this is distinct from bug 1263394, though both bugs are about reader mode + "back" navigation.  This bug here is about an issue with the "Back" button when you're inside of Reader Mode, whereas bug 1263394 is about a distinct issue with the "Back" button, after you've explicitly left Reader Mode.)
See Also: → 1263394
Is this fixed in bug 1263628?
Flags: needinfo?(dholbert)
Yes! Thanks for noticing.

At least: the STR now give me EXPECTED RESULTS in current nightly (which includes bug 1263628's patch) -- and it became fixed in this range (based on some targeted "mozregression --launch" runs for the past couple days' builds):
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ae7413abfa4d&tochange=f05a1242fb29

And that range includes bug 1263628.

So, I'll dupe this to bug 1263628 I suppose.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(dholbert)
Resolution: --- → DUPLICATE
Duplicate of bug: 1263628
(Er, since this bug is about "back" navigation, it seems possible that this was actually fixed by this other bug from that same fix range:
  Bug 1184950 - Use goBack to leave the reader view when possible

But, not sure. *shrug* I'll just leave it as-is for now.)
You need to log in before you can comment on or make changes to this bug.