Browser window won't repaint after javascript error

VERIFIED WORKSFORME

Status

()

Core
DOM: Core & HTML
P3
normal
VERIFIED WORKSFORME
19 years ago
2 years ago

People

(Reporter: Mark Bickford, Assigned: vidur (gone))

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
There is an apparent Javascript error at the above URL, and it hangs the M9
browser window.  Using the M9 release and choosing a country and vehicle, the JS
error freezes the client area of the browser; Apprunner as a whole remains
alive, as does the chrome, and a new, working window can be launched from the
menu bar.  The bug is that the initial rendering window refuses to repaint, or
do anything, until the program finally exits.

Observed 8/27/1999 on a 486-DX4 (100MHz) running Win95b.

Updated

19 years ago
Assignee: mccabe → jband

Comment 1

19 years ago
John, can you take a look at this?

Updated

19 years ago
Assignee: jband → vidur
Component: Javascript Engine → DOM Level 0

Comment 2

19 years ago
I could not reproduce this.

In any case, this sounds like a JS embedding problem and not an engine problem.

Flinging this at the DOM folk

Updated

19 years ago
QA Contact: cbegle → desale

Comment 3

19 years ago
layout issue, not core js
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
I can't reproduce this with a modern apprunner.  Please reopen with a minimal
test case if you still see this bug.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 5

19 years ago
Tested with 99-10-19-09. Working fine, so marking verified.
You need to log in before you can comment on or make changes to this bug.