Closed Bug 126341 Opened 18 years ago Closed 17 years ago

Download mail from multiple accounts into Local Folders inbox

Categories

(MailNews Core :: Database, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 46041

People

(Reporter: bugzilla, Assigned: Bienvenu)

References

Details

Download POP3 e-mail from multiple accounts into a Local Folders inbox, and not 
individual inboxes by account (by preference).
Severity: trivial → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: esther → sheelar
Workaround: Set up a filter for each account that redirects every mail into the
desired folder.
So there are additionaly two problems that should be fixed (IMHO):
first: I did so and set up a filter that moves all incoming mail to "local
folder/inbox" BUT there's no option in filter settings to move ALL mail. I did
it with "Mail ist not older than 100 days" but there's no "all mail" option

second: If I'm reading messages in my local folder, there's no way to activate
mail reception. I have to click on one of the mailboxes an there, I can receive
all accounts.
When browsing mail in Local Folders, the Get Msg button should automatically
check for mail on all accounts ("Get All New Messages", as found in the
drop-down menu).
If you're browsing in local folder, there is NO drop-down-menu, the whole button
is grayed out! (Or is it changed in a nightly build, I use 0.9.9)
I cannot get mail while staying in local folder, I have to click on one of my
mailboxes.
True.   One other thing to be fixed/added in this bug is to add code for the Get
Msg button in Local Folders so it can be clicked (and gets all new messages).
*** Bug 141975 has been marked as a duplicate of this bug. ***
*** Bug 146711 has been marked as a duplicate of this bug. ***
*** Bug 155020 has been marked as a duplicate of this bug. ***
I would like for mozilla to move on from separate root-folders per account: Many
things would be so much easier when we had only one root element and with every
account you would be able to specify where to store emails after download.
This paired with virtual folders (bug 11051) would make for an easier and more
customizable email experiance.
This is inspired by KMail which completely separates accounts from folder
structure (misses virtual folders, though).
Yes, I think we should be able to forget we have multiple accounts, and just get
all mails. This is very annoying, it is marked as enhancement but I consider it
as a conception bug.
*** Bug 208946 has been marked as a duplicate of this bug. ***
*** Bug 218854 has been marked as a duplicate of this bug. ***
Is this bug still alive?
Isn't this a dupe of bug 46041?  46041 doesn't mention "local folders", but the
rest of the bug is the same.
yes, looks like a dup.

*** This bug has been marked as a duplicate of 46041 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.