Several shipping languages are missing in languageNames.properties (ach, cak, kab, lij, ltg, zam)

RESOLVED FIXED in Firefox 59

Status

()

P1
normal
RESOLVED FIXED
3 years ago
a year ago

People

(Reporter: ajtzibsyani, Assigned: m_kato)

Tracking

(Depends on: 1 bug)

47 Branch
mozilla59
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 wontfix, firefox56 wontfix, firefox57 wontfix, firefox58 wontfix, firefox59 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Posted image name idioma.png
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160408004012

Steps to reproduce:

Select the language name


Actual results:

I observe only the language code and not the name


Expected results:

should have seen Maya' Kaqchikel (cak)
Component: Untriaged → Preferences

Comment 1

3 years ago
STR: Set intl.accept_languages to "cak,kaq,en-us,en".


https://dxr.mozilla.org/mozilla-central/source/toolkit/locales/en-US/chrome/global/languageNames.properties
https://dxr.mozilla.org/mozilla-central/source/gfx/thebes/gfxLanguageTagList.cpp
Has STR: --- → yes
Component: Preferences → Internationalization
Product: Firefox → Core
(Reporter)

Updated

3 years ago
Component: Internationalization → Locale switching and selection
Product: Core → Firefox for Android

Comment 2

3 years ago
Obviously it appears on the desktop version.
Component: Locale switching and selection → Internationalization
Product: Firefox for Android → Core
Depends on: 356038
Note that there is a Firefox localization in this language, so it's probably worth adding it manually if bug 356038 isn't getting fixed any time soon.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: check name maya kaqchikel → Language code "cak" (Maya Kaqchikel) not defined in languageNames.properties
(Reporter)

Comment 4

2 years ago
Hello everyone. In the Configuration appears cak code instead of the name of the Mayan language kaqchikel, in aurora, beta and the official version
Flags: needinfo?(m_kato)
(Assignee)

Comment 5

2 years ago
Pike, Is "cak" included in official L10N package?
Flags: needinfo?(m_kato) → needinfo?(l10n)
(In reply to Makoto Kato [:m_kato] from comment #5)
> Pike, Is "cak" included in official L10N package?

Yes.
https://hg.mozilla.org/releases/mozilla-release/raw-file/default/browser/locales/shipped-locales

At this point I assume it's not the only locale missing from languageNames.properties (assuming it should be there):
* cak: Maya Kaqchikel (I see it defined as 'Kaqchikel' in the .cpp file)
* kab: Kabyle
Flags: needinfo?(l10n)
(Assignee)

Updated

2 years ago
Assignee: nobody → m_kato
Priority: -- → P1
Should we also look at Fennec? I've just realized that we have several small languages there, more than Firefox (trs, tsz, zam are the first examples coming to mind)
https://hg.mozilla.org/releases/mozilla-aurora/raw-file/default/mobile/android/locales/all-locales

They're not all shipping in the multilocale build yet, but they will at some point (currently in single locale builds).
(Assignee)

Comment 8

2 years ago
(In reply to Francesco Lodolo [:flod] from comment #7)
> Should we also look at Fennec? I've just realized that we have several small
> languages there, more than Firefox (trs, tsz, zam are the first examples
> coming to mind)
> https://hg.mozilla.org/releases/mozilla-aurora/raw-file/default/mobile/
> android/locales/all-locales
> 
> They're not all shipping in the multilocale build yet, but they will at some
> point (currently in single locale builds).

Sebastian, could you answer it?
Flags: needinfo?(s.kaspari)
Waiting for Sebastian's answer. In the meantime I've checked Nightly's language switcher, and I see cak and son without a proper language name.
Redirecting to the core team in Taipei.
Flags: needinfo?(whuang)
Flags: needinfo?(s.kaspari)
Flags: needinfo?(jcheng)
relaying the ni to Wesly (1e)
Flags: needinfo?(whuang) → needinfo?(wehuang)
Max, would you help check if you have time? Maybe bring it into our next Triage if needed? Thanks.
Flags: needinfo?(wehuang) → needinfo?(max)

Comment 13

2 years ago
Hi jwu,

Would you help to follow up on the please? Thank you.
Flags: needinfo?(max) → needinfo?(topwu.tw)
Seems like the ball was dropped here. Actually, "cak" is not the only locale affected (ex: "son", "zam", and more).
This is an important thing to fix if we want our users to be able to switch to their language (most of them are not familiar with locale codes).

With the permission of :rnewman, I'm copy/pasting here his comments from an email thread from a year ago: ""son" and "cak" show like that because your device's Android version doesn't know what they are. We turn "en_US" into "English (United States)" by calling Java's Locale.getDisplayName; esoteric locales like cak aren't in the OS's lookup table, so we fall back to the locale code.
Fixing this is expensive from a localization perspective: every locale would have to localize every locale's name, so we'd be adding about 6,000 strings, and there'd be a bit of coding pain, too."

However, talking with Flod this weekend, we realized that we have translations for shipping locales in mercurial, so we should be able to leverage this.
To clarify: I don't think we need to translate 6k strings, we already have language names in languages.properties, and we should leverage that information instead of using Android's data.
Does the file "languages.properties" mean "mobile/android/chrome/content/languages.properties"? I cannot find "cak" in this file.

https://searchfox.org/mozilla-central/source/mobile/android/chrome/content/languages.properties
Is there anything we can help with here?

Updated

a year ago
status-firefox56: --- → affected
status-firefox57: --- → affected
status-firefox58: --- → affected
status-firefox-esr52: --- → affected
> Fixing this is expensive from a localization perspective: every locale would have to localize every locale's name, so we'd be adding about 6,000 strings, and there'd be a bit of coding pain, too."

I wonder if we need those translations. The languages in the preference are not translated to the currently selected language (e.g. German is always "Deutsch" - no matter what language is currently selected).

We recently added "cak" etc. support to Focus for Android and the only thing we had to add is the name for "cak" in cak itself. Not sure if there are other places in Fennec that would need translations of the language name though.
You're correct Sebastian, we wouldn't need localizers to translate every locale's name into all the other languages.

I think flod summarizes things well in comment 15: we have all the localizations we need in https://hg.mozilla.org/mozilla-central/file/default/toolkit/locales/en-US/chrome/global/languageNames.properties
We could leverage this work by using those.

FWIW I've just looked at Nightly's language switcher, and I still see "cak", "son" and "zam" without a proper language name on my device.
Too late for a fix for 56 and 57, but it would be nice to fix this for 59 or 58 (once mozilla-central is 59)
status-firefox56: affected → wontfix
status-firefox57: affected → wontfix
status-firefox-esr52: affected → wontfix
Summary: Language code "cak" (Maya Kaqchikel) not defined in languageNames.properties → Several shipping languages are missing in languageNames.properties (ach, cak, kab, lij, ltg, zam)
I believe the issue Fennec should be moved into a different bug (in Firefox for Android). 

As far as I can tell, the language switcher menu changes depending on the phone, which means we're getting translation from the OS.
No longer blocks: 1428712
Duplicate of this bug: 1428712
(Assignee)

Comment 26

a year ago
mozreview-review
Comment on attachment 8943146 [details]
Bug 1263437 - Add missing information for languages shipping in Firefox/Fennec: ach, cak, kab, lij, ltg, zam

https://reviewboard.mozilla.org/r/213446/#review219542
Attachment #8943146 - Flags: review?(m_kato) → review+

Comment 27

a year ago
Pushed by francesco.lodolo@mozillaitalia.org:
https://hg.mozilla.org/integration/autoland/rev/de1dc67e7984
Add missing information for languages shipping in Firefox/Fennec: ach, cak, kab, lij, ltg, zam r=m_kato

Comment 28

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/de1dc67e7984
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox59: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Depends on: 1431632
See Also: → bug 1431633
Filed bug 1431633 for Fennec, leaving it to Fennec folks to reopen NI as needed.
Flags: needinfo?(topwu.tw)
Flags: needinfo?(jcheng)
we've built 58rc2, and this isn't a new issue, wontfix for that release.
status-firefox58: affected → wontfix
You need to log in before you can comment on or make changes to this bug.