W3C spec pages are not rendered at all

RESOLVED FIXED in Firefox 48

Status

()

Core
Graphics: Layers
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: hiro, Assigned: mattwoodrow)

Tracking

({regression})

Trunk
mozilla48
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox48 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8739808 [details]
A screen shot

STR
1) disable E10S
2) make browser width narrow to collapse sidebar in the content
3) open https://w3c.github.io/web-animations/#dom-animationeffecttiming-fill

See attachment as a result.

There are tons of below messages on console:
[GFX3-]: FillGlyphs bad surface 1
[GFX2-]: DrawTargetCairo context in error state: invalid matrix (not invertible)(5)
(Reporter)

Comment 1

2 years ago
https://drafts.csswg.org/css-animations-1/#the-animation-delay-property
http://w3c.github.io/performance-timeline/#the-performance-observer-interface

Other specs are not rendered correctly too.
Summary: https://w3c.github.io/web-animations/#dom-animationeffecttiming-fill is not rendered at all → W3C spec pages are not rendered at all
Duplicate of this bug: 1264485
I can reproduce this with https://www.w3.org/TR/SVG/masking.html in a fullscreen browser (no need for "make browser width narrow" step).

Matt, this is flagged as a regression from your bug 852754, and it's a pretty bad regression (making sites completely 100% unusable).  Any chance you can take a look soon?

Also, requesting tracking to be sure we don't lose track of this:
[Tracking Requested - why for this release]: Serious rendering regression on important site (where web specs are hosted). Dogfooding bug for anyone who needs to read web specs (and has e10s disabled).
tracking-firefox48: --- → ?
Keywords: regression
(Sorry, meant to needinfo mattwoodrow in previous comment)
Flags: needinfo?(matt.woodrow)
(Assignee)

Updated

2 years ago
Assignee: nobody → matt.woodrow
(Assignee)

Comment 5

2 years ago
Created attachment 8741636 [details] [diff] [review]
Don't let cairo go into error state for an empty image
Flags: needinfo?(matt.woodrow)
Attachment #8741636 - Flags: review?(lsalzman)
Attachment #8741636 - Flags: review?(lsalzman) → review+
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1265256
Blocks: 1265574

Comment 8

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/4c229ab19c49
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox48: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
Duplicate of this bug: 1265256

Comment 10

2 years ago
I can still reproduce the glitch(Bug 1265256 comment#0) on Windows7 with HWA and e10s both disabled.

https://hg.mozilla.org/mozilla-central/rev/ae7413abfa4d3954a6a4ce7c1613a7100f367f9a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0 ID:20160419030312
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Alice0775 White from comment #10)
> I can still reproduce the glitch(Bug 1265256 comment#0) on Windows7 with HWA
> and e10s both disabled.
> 
> https://hg.mozilla.org/mozilla-central/rev/
> ae7413abfa4d3954a6a4ce7c1613a7100f367f9a

For me it's fixed with the same nightly on Linux.
(Reporter)

Comment 12

2 years ago
A problem still there is that "W3C Editor's Draft" is not shown up while collapsing sidebar.
Depends on: 1266775
I'm going to close this bug up again. The thing in comment 10 was referring to bug 1265256 which has been reopened to track that issue.
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
tracking-firefox48: ? → ---
You need to log in before you can comment on or make changes to this bug.