Closed Bug 1263544 Opened 4 years ago Closed 4 years ago

Choosing "Edit" after adding a reader view page as a bookmark has no action

Categories

(Firefox for Android :: General, defect)

48 Branch
ARM
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1246239
Tracking Status
firefox48 --- affected
fennec 48+ ---

People

(Reporter: TeoVermesan, Assigned: ahunt)

References

(Blocks 1 open bug)

Details

Tested using:
Device: Nexus 6 (Android 6.0)
Build: Firefox for Android 48.0a1 (2016-04-10)

Steps to reproduce:
1. Go to news.google.com
2. Choose an article and enter reader view
3. Open Menu and tap the bookmark star icon
4. Choose "OPTIONS" from the "Bookmark added" snackbar
5. Choose "Edit"

Actual results:
- tapping "Edit" has no action
- tapping "Add to Home Screen" will add the page to homescreen

Note:
- "edit" button works ok for normal pages
Blocks: 1234331
Assignee: nobody → ahunt
tracking-fennec: --- → ?
Blocks: migrate-RL
This snackbar will actually not be shown anymore when we land Bug 1246239. However that also means we're losing functionality, which makes me reconsider that.

If we did want to fix this we'd either have to strip the about:reader from the URL when creating this snackbar. Alternatively a correct fix for Bug 1234967 would result in us using Bookmark IDs/GUIDs instead of the URL (but my current solution doesn't do that, and implementing that fix might be complicated).
Bug 1246239 has now landed on fx-team, so should be on nightly soon. Closing this as a duplicate for now!
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1246239
tracking-fennec: ? → 48+
You need to log in before you can comment on or make changes to this bug.