Closed Bug 1263587 Opened 4 years ago Closed 4 years ago

No ability to add the page in reader view to the "Reading List" folder if the normal page was bookmarked before

Categories

(Firefox for Android :: General, defect)

48 Branch
ARM
Android
defect
Not set

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox48 --- affected

People

(Reporter: TeoVermesan, Unassigned)

References

(Blocks 1 open bug)

Details

Steps to reproduce:
1. Go to https://en.m.wikipedia.org/wiki/Mozilla
2. Open Menu and tap the bookmark star icon
3. Enter reader view 
4. Open Menu

Actual results:
- Bookmark star is blue
- No ability to add the page in reader view to the reading list folder

Expected results:
- The action of adding a normal page to bookmarks should be independent with the action of bookmarking a page in reader view (adding it to reading list folder)
I believe this is a deliberate product choice. If the user wants to bookmark the page in reader view, they can un-bookmark it and re-bookmark it.
Flags: needinfo?(bbermes)
Flags: needinfo?(alam)
Blocks: migrate-RL
(In reply to Teodora Vermesan (:TeoVermesan) from comment #0)
> Steps to reproduce:
> 1. Go to https://en.m.wikipedia.org/wiki/Mozilla
> 2. Open Menu and tap the bookmark star icon
> 3. Enter reader view 
> 4. Open Menu
> 
> Actual results:
> - Bookmark star is blue
> - No ability to add the page in reader view to the reading list folder

Yes, the site was indeed bookmarked so the star is blue. 

The ability to add the page in Reader view to Reading List (offline available) needs to be done:
1) Activate Reader View
2) Bookmark it
Flags: needinfo?(alam)
Agree with antlam
Flags: needinfo?(bbermes)
Closing this for now as this seems to be the behaviour we want!
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.