mozilla startup slow, hogs processor, runs 'md5sum'

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
major
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Kit, Assigned: asa)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020415

Prior to my last Mozilla upgrade, Mozilla startup quickly and efficiently. Now,
whenever I start mozilla, it spawns a process called 'md5sum.' This will run for
a few minutes, during which my processor load will climb from 0.25 (or so) to
over 1.0. Eventually, this process  stops running and mozilla-bin actually runs.
At this point, Mozilla starts and operates normally.

This may not even be a bug in mozilla -- I guess something could be broken on my
system, but I am at a loss to explain this behavior. If you can shed any light
on this I would appreciate it.

Reproducible: Always
Steps to Reproduce:
1. Run mozilla.
2. Wait for md5sum to  run.
3. Mozilla starts.

Actual Results:  Load climbed from about .30 to as high as .75. md5sum ran for
approximately 2 minutes before mozilla-bin appeared on top.

Expected Results:  Mozilla should startup much quicker.

I am running Redhad 7.1, although many libraries have been upgraded to Redhat
7.2 libs. FWIW, I run blackbox as my desktop.

Comment 1

16 years ago
I have the same problem. I think I heard on IRC that it's md5summing it's chrome.  

Comment 2

16 years ago
It looks like it's fixed in 0.9.9.

Comment 3

16 years ago
reporter, can you get 0.9.9 and try again?

Comment 4

16 years ago
Reporter: Please reopen if this still occurs with a recent nightly, available at:
http://ftp.mozilla.org/pub/mozilla/nightly/latest/

Thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Keywords: perf
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.