Fix TSFTextStore.h compilation with mingw.

RESOLVED FIXED in Firefox 48

Status

()

Core
Widget: Win32
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Jacek Caban, Assigned: Jacek Caban)

Tracking

Trunk
mozilla48
Points:
---

Firefox Tracking Flags

(firefox46 affected, firefox47 wontfix, firefox48 fixed, firefox49 unaffected, firefox-esr38 unaffected, firefox-esr4548+ fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
Created attachment 8740014 [details] [diff] [review]
fix

Since bug 1255627, I get errors like this:

 0:06.15 /home/jacek/mozilla/mozilla-central/widget/windows/TSFTextStore.h: In static member function ‘static void mozilla::widget::TSFTextStore::CommitComposition(bool)’:
 0:06.16 /home/jacek/mozilla/mozilla-central/widget/windows/TSFTextStore.h:122:38: error: conversion from ‘mozilla::StaticRefPtr<mozilla::widget::TSFTextStore>’ to non-scalar type ‘RefPtr<mozilla::widget::TSFTextStore>’ requested
 0:06.16      RefPtr<TSFTextStore> textStore = sEnabledTextStore;
 0:06.16                                       ^

GCC is more picky about assignment in the declaration.
Attachment #8740014 - Flags: review?(masayuki)
Attachment #8740014 - Flags: review?(masayuki) → review+

Comment 2

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/a2d94f934b2a
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox48: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla48

Comment 3

2 years ago
Will this get uplifted as well?
(In reply to arlolra from comment #3)
> Will this get uplifted as well?

Oh, indeed, only bug 1255627 was uplifted.
status-firefox46: --- → affected
status-firefox47: --- → affected
status-firefox49: --- → unaffected
status-firefox-esr38: --- → unaffected
status-firefox-esr45: --- → affected
Comment on attachment 8740014 [details] [diff] [review]
fix

Approval Request Comment
[Feature/regressing bug #]: bug 1255627 (had been fixed on 48 and this was also fixed on 48, but only bug 1255627 was uplifted to 47, 46 and esr45)
[User impact if declined]: This is just a fix of bugstate of mingw.
[Describe test coverage new/current, TreeHerder]: Landed on 48 (currently, Aurora)
[Risks and why]: No, just avoiding bustate of mingw, no behavior changes.
[String/UUID change made/needed]: No.
Attachment #8740014 - Flags: approval-mozilla-esr45?
Attachment #8740014 - Flags: approval-mozilla-beta?

Comment 6

2 years ago
Comment on attachment 8740014 [details] [diff] [review]
fix

We are in RC week. AFAICT, this is not a new regression, wont fix for Fx47 as it's too late to uplift any fixes other than for release blockers at this point.
Attachment #8740014 - Flags: approval-mozilla-beta? → approval-mozilla-beta-

Updated

2 years ago
status-firefox47: affected → wontfix
Sorry this missed the cutoff. Masayuki I don't understand the impact here. 

If we aren't taking this in beta 47, it should probably also wait for esr45.3.0 that will release along with 48.
Flags: needinfo?(masayuki)
tracking-firefox-esr45: --- → 48+
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #7)
> Sorry this missed the cutoff. Masayuki I don't understand the impact here. 

IIRC, mingw is used by Wine to use Gecko as Trident. So, if they use 45esr, we should fix this even if it's tire-3 because the fix has no risk.
Flags: needinfo?(masayuki)
Comment on attachment 8740014 [details] [diff] [review]
fix

Let's uplift this, I'd like builds to work and it seems unlikely to break anything that isn't already broken.
Attachment #8740014 - Flags: approval-mozilla-esr45? → approval-mozilla-esr45+

Comment 10

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-esr45/rev/d27564cb3702
status-firefox-esr45: affected → fixed
You need to log in before you can comment on or make changes to this bug.