about:debugging does not warn when attempting to upload invalid WebExtension manifest

RESOLVED DUPLICATE of bug 1231128

Status

()

Firefox
Developer Tools: about:debugging
RESOLVED DUPLICATE of bug 1231128
2 years ago
2 years ago

People

(Reporter: cliabhach, Unassigned)

Tracking

47 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.110 Safari/537.36

Steps to reproduce:

Create a web extension with a manifest.json containing "manifest_version" property set to something other than 2.

Open Firefox Developer Edition.
Set about:config flag 'xpinstall.signatures.required' to false.
Click the 'Load Temporary Add-on' button on about:debugging.
Select the manifest.json file you created earlier.


Actual results:

The file selection window disappeared. That's it. Nothing else happened.


Expected results:

An error or popup (or something in the console) saying that Firefox only supports manifest_version 2 at this time.

Updated

2 years ago
Component: Untriaged → Developer Tools: about:debugging

Comment 1

2 years ago
I see it in Fx47.0a2 (2016-03-20), but WFM in 48.0a1 (2016-04-09) on Win10, a warning say: There was an error during installation: Extension is invalid.

Fixed in bug 1231128.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1231128

Comment 2

2 years ago
Hi cliabhach, welcome to Bugzilla!

Thanks a lot for taking the time to log this bug. Your problem looks similar to bug 1231128, which was fixed recently, and adds an error message to about:debugging when 'Load Temporary Add-on' fails.

The fix landed in Firefox Nightly last week, so it will be available in the next Firefox Developer Edition, which releases in about 3 weeks from now.
(Reporter)

Comment 3

2 years ago
Wow, sorry, I completely missed that one. Figures that my first bug report is a duplicate....
(In reply to cliabhach from comment #3)
> Wow, sorry, I completely missed that one. Figures that my first bug report
> is a duplicate....

Don't worry about it, it's better to file so the issue gets logged at least! :) It's easy to miss duplicate issues, and the team working on a component should be able to spot them quickly.
You need to log in before you can comment on or make changes to this bug.