Right click to open context menu automatically click back button

RESOLVED INVALID

Status

()

RESOLVED INVALID
3 years ago
a year ago

People

(Reporter: brad, Unassigned)

Tracking

45 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160315153207

Steps to reproduce:

Right click on the page, but before releasing the button, move the mouse over 2 pixels.  (aka right click and start to move the move to the dropdown menu at the same time)


Actual results:

Back button was clicked


Expected results:

The right click menu should have opened.  It appears a feature was added that allows you to hold down the right click button while opening the menu, and whichever option was selected, on mouseup, would trigger a click.  However, this behavior is absolutely maddening when I am simply trying to open the menu to select an option in the list.  I have always used Firefox by right clicking ( mousedown + mouseup ) and then selecting a menu option.


Proposed solution:

If rightclick mouseup happens within a certain number of milliseconds, don't trigger a click on the element and instead treat the down+up as a single "action" whose desired purposed was to open the context menu.

Updated

3 years ago
Component: Untriaged → Menus

Comment 1

a year ago
This is by design. Context menus in other applications like TextEdit.app and Calendar.app work the same way.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.