Resource timing initiatorType should be "iframe" instead of "subdocument"

RESOLVED FIXED in Firefox 48

Status

()

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: valentin, Assigned: valentin)

Tracking

unspecified
mozilla48
Points:
---

Firefox Tracking Flags

(firefox48 fixed)

Details

(Whiteboard: btpp-active)

Attachments

(1 attachment, 1 obsolete attachment)

Comment hidden (empty)
(Assignee)

Comment 1

3 years ago
Created attachment 8740221 [details] [diff] [review]
Resource timing initiatorType should be "iframe" instead of "subdocument"
Attachment #8740221 - Flags: review?(bzbarsky)
Comment on attachment 8740221 [details] [diff] [review]
Resource timing initiatorType should be "iframe" instead of "subdocument"

Won't this set initiatorType to "iframe" for a <frame> element, while per spec it should be "frame"?

Please add a corresponding test.
Attachment #8740221 - Flags: review?(bzbarsky) → review-
Whiteboard: btpp-active
(Assignee)

Comment 3

3 years ago
Created attachment 8740725 [details] [diff] [review]
Resource timing initiatorType should be "iframe" instead of "subdocument"

MozReview-Commit-ID: D262VzFMDCM
Attachment #8740725 - Flags: review?(bzbarsky)
(Assignee)

Updated

3 years ago
Attachment #8740221 - Attachment is obsolete: true
Comment on attachment 8740725 [details] [diff] [review]
Resource timing initiatorType should be "iframe" instead of "subdocument"

>+        nsContentUtils::ASCIIToLower(initType);

You shouldn't need this.  The case should be correct anyway.

Also, you don't want the tagName.  The spec says it should be the localName.  So like so:

  if (frameElement) {
    timedChannel->SetInitiatorType(frameElement->LocalName());
  }

r=me with that.  Thank you for adding the test, though it would be ever better if it were a web platform test, since this is not testing anything Gecko-specific.
Attachment #8740725 - Flags: review?(bzbarsky) → review+
(Assignee)

Comment 5

3 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/f43c0ea2c7c847ca361375164b3a4c58eb714426
Bug 1263790 - Resource timing initiatorType should be "iframe" instead of "subdocument" r=bz

Comment 6

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/f43c0ea2c7c8
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox48: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1272605
You need to log in before you can comment on or make changes to this bug.